[PATCH] system, home: Validate ‘services’ field value.

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal

Debbugs page

Ludovic Courtès wrote 1 years ago
[PATCH] system, home: Validate ‘services ’ field value.
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
f23f108051950fa0d7a2022630789a51a3de755d.1708720176.git.ludo@gnu.org
This guides newcomers who might stick a single (service …) form
in this field.

* gnu/services.scm (validate-service-list): New macro.
(%validate-service-list): New procedure.
* gnu/system.scm (<operating-system>)[services]: Add ‘sanitize’.
* gnu/home.scm (<home-environment>)[services]: Add ‘sanitize’.

Change-Id: I9e29bd9a078e87b627ab766fd669ba9de79f8473
---
gnu/home.scm | 5 +++--
gnu/services.scm | 19 ++++++++++++++++++-
gnu/system.scm | 5 +++--
3 files changed, 24 insertions(+), 5 deletions(-)

Hi!

The goal here is to recognize this likely pitfall for newcomers
and to guide them.

Thoughts?

Ludo'.

Toggle diff (87 lines)
diff --git a/gnu/home.scm b/gnu/home.scm
index 2fefe7ba53..b390c8d534 100644
--- a/gnu/home.scm
+++ b/gnu/home.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
-;;; Copyright © 2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,7 +67,8 @@ (define-record-type* <home-environment> home-environment
this-home-environment)))
(services home-environment-user-services
- (default '()))
+ (default '())
+ (sanitize validate-service-list))
(location home-environment-location ; <location>
(default (and=> (current-source-location)
diff --git a/gnu/services.scm b/gnu/services.scm
index 59481af10f..88593e8091 100644
--- a/gnu/services.scm
+++ b/gnu/services.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
@@ -91,6 +91,8 @@ (define-module (gnu services)
for-home
for-home?
+ validate-service-list
+
service-error?
missing-value-service-error?
missing-value-service-error-type
@@ -1271,4 +1273,19 @@ (define-syntax-rule (for-home exp ...)
(syntax-parameterize ((for-home? (identifier-syntax #t)))
exp ...))
+(define-with-syntax-properties (validate-service-list (value properties))
+ (%validate-service-list value properties))
+
+(define (%validate-service-list value properties)
+ (match value
+ (((? service?) ...) value)
+ (_
+ (raise
+ (make-compound-condition
+ (condition
+ (&error-location
+ (location (source-properties->location properties))))
+ (formatted-message
+ (G_ "'services' field must contain a list of services")))))))
+
;;; services.scm ends here.
diff --git a/gnu/system.scm b/gnu/system.scm
index aede35775e..aef81d8ccf 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
@@ -294,7 +294,8 @@ (define-record-type* <operating-system> operating-system
this-operating-system)))
(services operating-system-user-services ; list of services
(thunked) ;allow for system-dependent services
- (default %base-services))
+ (default %base-services)
+ (sanitize validate-service-list))
(pam-services operating-system-pam-services ; list of PAM services
(default (base-pam-services)))

base-commit: b386c11e7804e0b577411d930b60f1e0a4a0382c
--
2.41.0
Ludovic Courtès wrote 12 months ago
Re: [bug#69340] [PATCH] system, home: Validate ‘ services’ field value.
(address . 69340-done@debbugs.gnu.org)
87ttkysg15.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (10 lines)
> This guides newcomers who might stick a single (service …) form
> in this field.
>
> * gnu/services.scm (validate-service-list): New macro.
> (%validate-service-list): New procedure.
> * gnu/system.scm (<operating-system>)[services]: Add ‘sanitize’.
> * gnu/home.scm (<home-environment>)[services]: Add ‘sanitize’.
>
> Change-Id: I9e29bd9a078e87b627ab766fd669ba9de79f8473

Pushed as 29de2edfbbed21ac016f73a45d399795fc2e4dfb.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help