Unbootable, unfixable system

  • Open
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Hilton Chain
  • Nathan Dehnel
Owner
unassigned
Submitted by
Nathan Dehnel
Severity
normal
N
N
Nathan Dehnel wrote on 23 Feb 08:15 +0100
(name . bug-guix)(address . bug-guix@gnu.org)
CAEEhgEujo0WCp=vfCK4U07hvxdL=c166tfK4ax-EWvDSWiQXQA@mail.gmail.com
This config results in grub rescue "unknown filesystem <uuid of my
btrfs rootfs>" when I try to boot it. I have verified that all the
device uuids are correct, and the bootloader, mapped-devices, and
file-systems sections are identical in form to my other system which
boots fine. i can mount the boot partition and unlock and mount the
root partition manually, so they're not broken. I have no idea why
it's not working. My guess is that reconfigure is broken inside a
chroot somehow.

(use-modules (gnu))
(use-service-modules networking ssh sysctl shepherd base)
(use-package-modules vpn linux)
(use-modules (nongnu packages linux)
(nongnu system linux-initrd)
(gnu services)
(guix packages)
(gooby-channel packages baksnapper))
(define bashrc
(local-file "../bashrc"))
(define nanorc
(local-file "../nano/nanorc"))
(operating-system
(kernel linux)
(initrd microcode-initrd)
(firmware (list linux-firmware))
(locale "en_US.utf8")
(timezone "America/Chicago")
(keyboard-layout (keyboard-layout "us"))
(host-name "guixoffline")
(bootloader
(bootloader-configuration
(bootloader grub-efi-bootloader)
(targets '("/boot/efi1"))
(keyboard-layout keyboard-layout)))
(mapped-devices
(list (mapped-device
(source
(uuid "14930dad-016d-4b59-b7d8-d5af2c33f4b0"))
(target "offline1")
(type luks-device-mapping))
))
(file-systems
(cons* (file-system
(mount-point "/boot/efi1")
(device (uuid "3339-DAE2" 'fat32))
(type "vfat"))
(file-system
(mount-point "/")
(device "/dev/mapper/offline1")
(type "btrfs")
(options "compress=zlib:9")
(dependencies mapped-devices))
%base-file-systems))
(users (cons* (user-account
(name "nathan")
(comment "Nathan Dehnel")
(group "users")
(home-directory "/home/nathan")
(supplementary-groups '("wheel" "netdev" "audio" "video")))
%base-user-accounts))
(packages
(append
(specification->package "btrfs-progs")
(specification->package "parted")
(specification->package "mdadm")
(specification->package "git")
(specification->package "nss-certs")
(specification->package "nix")
(specification->package "efibootmgr")
(specification->package "smartmontools")
(specification->package "iotop")
(specification->package "bcache-tools")
(specification->package "lsof")
(specification->package "wireguard-tools")
(specification->package "baksnapper")
(specification->package "file")
(specification->package "rsync"))
%base-packages))
(services
(append
(list
(service openssh-service-type
(openssh-configuration
(permit-root-login #t)
(password-authentication? #t)
(authorized-keys
`(("root" ,(local-file "ssh/root-gentoodesktop.pub"))
("root" ,(local-file "ssh/baksnapper-gentoodesktop.pub"))
("root" ,(local-file "ssh/baksnapper-gentooserver.pub"))
("root" ,(local-file "ssh/nathan-guixlaptop.pub"))
))))
(service connman-service-type)
(service ntp-service-type)
(service gpm-service-type)
(simple-service 'nanorc etc-service-type
(list `("nanorc", nanorc)))
)
%base-services)))
J
J
Josselin Poiret wrote on 23 Feb 11:33 +0100
87a5nrmpw3.fsf@jpoiret.xyz
Hi Nathan,

Nathan Dehnel <ncdehnel@gmail.com> writes:

Toggle quote (9 lines)
> This config results in grub rescue "unknown filesystem <uuid of my
> btrfs rootfs>" when I try to boot it. I have verified that all the
> device uuids are correct, and the bootloader, mapped-devices, and
> file-systems sections are identical in form to my other system which
> boots fine. i can mount the boot partition and unlock and mount the
> root partition manually, so they're not broken. I have no idea why
> it's not working. My guess is that reconfigure is broken inside a
> chroot somehow.

I see you're using LUKS. Is it LUKS1 or LUKS2? LUKS2 unfortunately
doesn't work at present, because we're still on Grub 2.06.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmXYdGwQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5Fhcair27DAC1SVXvf7eihf1dxpH8VB1IQoEnx7oKT7Ed
vbJQ38Zk/IIH4s1Rtz3mFPZhuwUTf4OxyFu4ln9iGagDFml/7HN/M+H+Cns4nPx7
tlSnsSamXbLoVBxekLs42Iz5SFVQWDvwmbz2FLCDcuuBsrVF1GvVL119BGT3U1BE
aSmgohgksE24JcEj380K3uoBQnsWjl1InEurE25cKWE5W6H0ypALdL6+kv2HAsFL
QKpECr07YCUUvRYQj2azZ35iDaFXQQ8U1NY+npfUXUaOwYi0L2jmSPXJulTM2nCP
FcFVQyTOLmAns7vwjP3OQHssOZJQtbI1zq2iVnEsIgB+MjJJE+A5gGzDqawLJwiw
CZdzKT5+q10aYhb+QFDXDYuQejFhUfBoeMSbCmyxmjDJlPEAgwEIN/bBISg13jXq
TKQL/igOmTSdUk+Yc4be4E/2xXFre0rDKRKpPZTvu0ZmaCTwhBnNzXzN9I66BAnN
uI3FVlARtUk1UpaJ93LeLPacg+oMPYI=
=plTA
-----END PGP SIGNATURE-----

N
N
Nathan Dehnel wrote on 23 Feb 18:17 +0100
Re: Unbootable, unfixable system
CAEEhgEspAvJ-sn0KJCQNPKjYJVLw78PboAvmTn=F1SzcmsJkpw@mail.gmail.com
It seems I may have fallen for the grub luks2 compatibility issue,
which I didn't know about. I will investigate later.

On Fri, Feb 23, 2024 at 1:15?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
Toggle quote (99 lines)
>
> This config results in grub rescue "unknown filesystem <uuid of my
> btrfs rootfs>" when I try to boot it. I have verified that all the
> device uuids are correct, and the bootloader, mapped-devices, and
> file-systems sections are identical in form to my other system which
> boots fine. i can mount the boot partition and unlock and mount the
> root partition manually, so they're not broken. I have no idea why
> it's not working. My guess is that reconfigure is broken inside a
> chroot somehow.
>
> (use-modules (gnu))
> (use-service-modules networking ssh sysctl shepherd base)
> (use-package-modules vpn linux)
> (use-modules (nongnu packages linux)
> (nongnu system linux-initrd)
> (gnu services)
> (guix packages)
> (gooby-channel packages baksnapper))
> (define bashrc
> (local-file "../bashrc"))
> (define nanorc
> (local-file "../nano/nanorc"))
> (operating-system
> (kernel linux)
> (initrd microcode-initrd)
> (firmware (list linux-firmware))
> (locale "en_US.utf8")
> (timezone "America/Chicago")
> (keyboard-layout (keyboard-layout "us"))
> (host-name "guixoffline")
> (bootloader
> (bootloader-configuration
> (bootloader grub-efi-bootloader)
> (targets '("/boot/efi1"))
> (keyboard-layout keyboard-layout)))
> (mapped-devices
> (list (mapped-device
> (source
> (uuid "14930dad-016d-4b59-b7d8-d5af2c33f4b0"))
> (target "offline1")
> (type luks-device-mapping))
> ))
> (file-systems
> (cons* (file-system
> (mount-point "/boot/efi1")
> (device (uuid "3339-DAE2" 'fat32))
> (type "vfat"))
> (file-system
> (mount-point "/")
> (device "/dev/mapper/offline1")
> (type "btrfs")
> (options "compress=zlib:9")
> (dependencies mapped-devices))
> %base-file-systems))
> (users (cons* (user-account
> (name "nathan")
> (comment "Nathan Dehnel")
> (group "users")
> (home-directory "/home/nathan")
> (supplementary-groups '("wheel" "netdev" "audio" "video")))
> %base-user-accounts))
> (packages
> (append
> (specification->package "btrfs-progs")
> (specification->package "parted")
> (specification->package "mdadm")
> (specification->package "git")
> (specification->package "nss-certs")
> (specification->package "nix")
> (specification->package "efibootmgr")
> (specification->package "smartmontools")
> (specification->package "iotop")
> (specification->package "bcache-tools")
> (specification->package "lsof")
> (specification->package "wireguard-tools")
> (specification->package "baksnapper")
> (specification->package "file")
> (specification->package "rsync"))
> %base-packages))
> (services
> (append
> (list
> (service openssh-service-type
> (openssh-configuration
> (permit-root-login #t)
> (password-authentication? #t)
> (authorized-keys
> `(("root" ,(local-file "ssh/root-gentoodesktop.pub"))
> ("root" ,(local-file "ssh/baksnapper-gentoodesktop.pub"))
> ("root" ,(local-file "ssh/baksnapper-gentooserver.pub"))
> ("root" ,(local-file "ssh/nathan-guixlaptop.pub"))
> ))))
> (service connman-service-type)
> (service ntp-service-type)
> (service gpm-service-type)
> (simple-service 'nanorc etc-service-type
> (list `("nanorc", nanorc)))
> )
> %base-services)))
N
N
Nathan Dehnel wrote on 25 Feb 01:48 +0100
CAEEhgEtkUzXhj-w3FzPY9vY=N6c1heVBfg6FFwxQQVx5PSL=Vw@mail.gmail.com
Yeah, that was the problem.

On Fri, Feb 23, 2024 at 11:17?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
Toggle quote (104 lines)
>
> It seems I may have fallen for the grub luks2 compatibility issue,
> which I didn't know about. I will investigate later.
>
> On Fri, Feb 23, 2024 at 1:15?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
> >
> > This config results in grub rescue "unknown filesystem <uuid of my
> > btrfs rootfs>" when I try to boot it. I have verified that all the
> > device uuids are correct, and the bootloader, mapped-devices, and
> > file-systems sections are identical in form to my other system which
> > boots fine. i can mount the boot partition and unlock and mount the
> > root partition manually, so they're not broken. I have no idea why
> > it's not working. My guess is that reconfigure is broken inside a
> > chroot somehow.
> >
> > (use-modules (gnu))
> > (use-service-modules networking ssh sysctl shepherd base)
> > (use-package-modules vpn linux)
> > (use-modules (nongnu packages linux)
> > (nongnu system linux-initrd)
> > (gnu services)
> > (guix packages)
> > (gooby-channel packages baksnapper))
> > (define bashrc
> > (local-file "../bashrc"))
> > (define nanorc
> > (local-file "../nano/nanorc"))
> > (operating-system
> > (kernel linux)
> > (initrd microcode-initrd)
> > (firmware (list linux-firmware))
> > (locale "en_US.utf8")
> > (timezone "America/Chicago")
> > (keyboard-layout (keyboard-layout "us"))
> > (host-name "guixoffline")
> > (bootloader
> > (bootloader-configuration
> > (bootloader grub-efi-bootloader)
> > (targets '("/boot/efi1"))
> > (keyboard-layout keyboard-layout)))
> > (mapped-devices
> > (list (mapped-device
> > (source
> > (uuid "14930dad-016d-4b59-b7d8-d5af2c33f4b0"))
> > (target "offline1")
> > (type luks-device-mapping))
> > ))
> > (file-systems
> > (cons* (file-system
> > (mount-point "/boot/efi1")
> > (device (uuid "3339-DAE2" 'fat32))
> > (type "vfat"))
> > (file-system
> > (mount-point "/")
> > (device "/dev/mapper/offline1")
> > (type "btrfs")
> > (options "compress=zlib:9")
> > (dependencies mapped-devices))
> > %base-file-systems))
> > (users (cons* (user-account
> > (name "nathan")
> > (comment "Nathan Dehnel")
> > (group "users")
> > (home-directory "/home/nathan")
> > (supplementary-groups '("wheel" "netdev" "audio" "video")))
> > %base-user-accounts))
> > (packages
> > (append
> > (specification->package "btrfs-progs")
> > (specification->package "parted")
> > (specification->package "mdadm")
> > (specification->package "git")
> > (specification->package "nss-certs")
> > (specification->package "nix")
> > (specification->package "efibootmgr")
> > (specification->package "smartmontools")
> > (specification->package "iotop")
> > (specification->package "bcache-tools")
> > (specification->package "lsof")
> > (specification->package "wireguard-tools")
> > (specification->package "baksnapper")
> > (specification->package "file")
> > (specification->package "rsync"))
> > %base-packages))
> > (services
> > (append
> > (list
> > (service openssh-service-type
> > (openssh-configuration
> > (permit-root-login #t)
> > (password-authentication? #t)
> > (authorized-keys
> > `(("root" ,(local-file "ssh/root-gentoodesktop.pub"))
> > ("root" ,(local-file "ssh/baksnapper-gentoodesktop.pub"))
> > ("root" ,(local-file "ssh/baksnapper-gentooserver.pub"))
> > ("root" ,(local-file "ssh/nathan-guixlaptop.pub"))
> > ))))
> > (service connman-service-type)
> > (service ntp-service-type)
> > (service gpm-service-type)
> > (simple-service 'nanorc etc-service-type
> > (list `("nanorc", nanorc)))
> > )
> > %base-services)))
H
H
Hilton Chain wrote on 25 Feb 03:59 +0100
Re: bug#69319: Unbootable, unfixable system
(name . Nathan Dehnel)(address . ncdehnel@gmail.com)
87edd15jw7.wl-hako@ultrarare.space
Hi Nathan,

On Sun, 25 Feb 2024 08:48:35 +0800,
Nathan Dehnel wrote:
Toggle quote (109 lines)
>
> On Fri, Feb 23, 2024 at 11:17?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
> >
> > On Fri, Feb 23, 2024 at 1:15?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
> > >
> > > This config results in grub rescue "unknown filesystem <uuid of my
> > > btrfs rootfs>" when I try to boot it. I have verified that all the
> > > device uuids are correct, and the bootloader, mapped-devices, and
> > > file-systems sections are identical in form to my other system which
> > > boots fine. i can mount the boot partition and unlock and mount the
> > > root partition manually, so they're not broken. I have no idea why
> > > it's not working. My guess is that reconfigure is broken inside a
> > > chroot somehow.
> > >
> > > (use-modules (gnu))
> > > (use-service-modules networking ssh sysctl shepherd base)
> > > (use-package-modules vpn linux)
> > > (use-modules (nongnu packages linux)
> > > (nongnu system linux-initrd)
> > > (gnu services)
> > > (guix packages)
> > > (gooby-channel packages baksnapper))
> > > (define bashrc
> > > (local-file "../bashrc"))
> > > (define nanorc
> > > (local-file "../nano/nanorc"))
> > > (operating-system
> > > (kernel linux)
> > > (initrd microcode-initrd)
> > > (firmware (list linux-firmware))
> > > (locale "en_US.utf8")
> > > (timezone "America/Chicago")
> > > (keyboard-layout (keyboard-layout "us"))
> > > (host-name "guixoffline")
> > > (bootloader
> > > (bootloader-configuration
> > > (bootloader grub-efi-bootloader)
> > > (targets '("/boot/efi1"))
> > > (keyboard-layout keyboard-layout)))
> > > (mapped-devices
> > > (list (mapped-device
> > > (source
> > > (uuid "14930dad-016d-4b59-b7d8-d5af2c33f4b0"))
> > > (target "offline1")
> > > (type luks-device-mapping))
> > > ))
> > > (file-systems
> > > (cons* (file-system
> > > (mount-point "/boot/efi1")
> > > (device (uuid "3339-DAE2" 'fat32))
> > > (type "vfat"))
> > > (file-system
> > > (mount-point "/")
> > > (device "/dev/mapper/offline1")
> > > (type "btrfs")
> > > (options "compress=zlib:9")
> > > (dependencies mapped-devices))
> > > %base-file-systems))
> > > (users (cons* (user-account
> > > (name "nathan")
> > > (comment "Nathan Dehnel")
> > > (group "users")
> > > (home-directory "/home/nathan")
> > > (supplementary-groups '("wheel" "netdev" "audio" "video")))
> > > %base-user-accounts))
> > > (packages
> > > (append
> > > (specification->package "btrfs-progs")
> > > (specification->package "parted")
> > > (specification->package "mdadm")
> > > (specification->package "git")
> > > (specification->package "nss-certs")
> > > (specification->package "nix")
> > > (specification->package "efibootmgr")
> > > (specification->package "smartmontools")
> > > (specification->package "iotop")
> > > (specification->package "bcache-tools")
> > > (specification->package "lsof")
> > > (specification->package "wireguard-tools")
> > > (specification->package "baksnapper")
> > > (specification->package "file")
> > > (specification->package "rsync"))
> > > %base-packages))
> > > (services
> > > (append
> > > (list
> > > (service openssh-service-type
> > > (openssh-configuration
> > > (permit-root-login #t)
> > > (password-authentication? #t)
> > > (authorized-keys
> > > `(("root" ,(local-file "ssh/root-gentoodesktop.pub"))
> > > ("root" ,(local-file "ssh/baksnapper-gentoodesktop.pub"))
> > > ("root" ,(local-file "ssh/baksnapper-gentooserver.pub"))
> > > ("root" ,(local-file "ssh/nathan-guixlaptop.pub"))
> > > ))))
> > > (service connman-service-type)
> > > (service ntp-service-type)
> > > (service gpm-service-type)
> > > (simple-service 'nanorc etc-service-type
> > > (list `("nanorc", nanorc)))
> > > )
> > > %base-services)))
> >
> > It seems I may have fallen for the grub luks2 compatibility issue,
> > which I didn't know about. I will investigate later.
> >
> Yeah, that was the problem.

GRUB currently doesn't support Argon2 PBKDFs, if you are going to use LUKS2, you
have to specify pbkdf2:
Toggle snippet (3 lines)
cryptsetup --type=luks2 --pbkdf=pbkdf2

In case it's needed, I packaged a GRUB variant with Argon2 support and its
bootloader definition in my channel:

I re-installed my system with this GRUB variant (also intended to test it)
recently, and it works just fine.

I think this bug can be closed now?
N
N
Nathan Dehnel wrote on 25 Feb 06:20 +0100
(name . Hilton Chain)(address . hako@ultrarare.space)
CAEEhgEte5waie5OO1LRosoY-pGjmFC2yUF+a-k8EpyNsJur6Qg@mail.gmail.com
I tried that and it didn't work, I had to use --type=luks1

On Sat, Feb 24, 2024 at 8:59?PM Hilton Chain <hako@ultrarare.space> wrote:
Toggle quote (129 lines)
>
> Hi Nathan,
>
> On Sun, 25 Feb 2024 08:48:35 +0800,
> Nathan Dehnel wrote:
> >
> > On Fri, Feb 23, 2024 at 11:17?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
> > >
> > > On Fri, Feb 23, 2024 at 1:15?AM Nathan Dehnel <ncdehnel@gmail.com> wrote:
> > > >
> > > > This config results in grub rescue "unknown filesystem <uuid of my
> > > > btrfs rootfs>" when I try to boot it. I have verified that all the
> > > > device uuids are correct, and the bootloader, mapped-devices, and
> > > > file-systems sections are identical in form to my other system which
> > > > boots fine. i can mount the boot partition and unlock and mount the
> > > > root partition manually, so they're not broken. I have no idea why
> > > > it's not working. My guess is that reconfigure is broken inside a
> > > > chroot somehow.
> > > >
> > > > (use-modules (gnu))
> > > > (use-service-modules networking ssh sysctl shepherd base)
> > > > (use-package-modules vpn linux)
> > > > (use-modules (nongnu packages linux)
> > > > (nongnu system linux-initrd)
> > > > (gnu services)
> > > > (guix packages)
> > > > (gooby-channel packages baksnapper))
> > > > (define bashrc
> > > > (local-file "../bashrc"))
> > > > (define nanorc
> > > > (local-file "../nano/nanorc"))
> > > > (operating-system
> > > > (kernel linux)
> > > > (initrd microcode-initrd)
> > > > (firmware (list linux-firmware))
> > > > (locale "en_US.utf8")
> > > > (timezone "America/Chicago")
> > > > (keyboard-layout (keyboard-layout "us"))
> > > > (host-name "guixoffline")
> > > > (bootloader
> > > > (bootloader-configuration
> > > > (bootloader grub-efi-bootloader)
> > > > (targets '("/boot/efi1"))
> > > > (keyboard-layout keyboard-layout)))
> > > > (mapped-devices
> > > > (list (mapped-device
> > > > (source
> > > > (uuid "14930dad-016d-4b59-b7d8-d5af2c33f4b0"))
> > > > (target "offline1")
> > > > (type luks-device-mapping))
> > > > ))
> > > > (file-systems
> > > > (cons* (file-system
> > > > (mount-point "/boot/efi1")
> > > > (device (uuid "3339-DAE2" 'fat32))
> > > > (type "vfat"))
> > > > (file-system
> > > > (mount-point "/")
> > > > (device "/dev/mapper/offline1")
> > > > (type "btrfs")
> > > > (options "compress=zlib:9")
> > > > (dependencies mapped-devices))
> > > > %base-file-systems))
> > > > (users (cons* (user-account
> > > > (name "nathan")
> > > > (comment "Nathan Dehnel")
> > > > (group "users")
> > > > (home-directory "/home/nathan")
> > > > (supplementary-groups '("wheel" "netdev" "audio" "video")))
> > > > %base-user-accounts))
> > > > (packages
> > > > (append
> > > > (specification->package "btrfs-progs")
> > > > (specification->package "parted")
> > > > (specification->package "mdadm")
> > > > (specification->package "git")
> > > > (specification->package "nss-certs")
> > > > (specification->package "nix")
> > > > (specification->package "efibootmgr")
> > > > (specification->package "smartmontools")
> > > > (specification->package "iotop")
> > > > (specification->package "bcache-tools")
> > > > (specification->package "lsof")
> > > > (specification->package "wireguard-tools")
> > > > (specification->package "baksnapper")
> > > > (specification->package "file")
> > > > (specification->package "rsync"))
> > > > %base-packages))
> > > > (services
> > > > (append
> > > > (list
> > > > (service openssh-service-type
> > > > (openssh-configuration
> > > > (permit-root-login #t)
> > > > (password-authentication? #t)
> > > > (authorized-keys
> > > > `(("root" ,(local-file "ssh/root-gentoodesktop.pub"))
> > > > ("root" ,(local-file "ssh/baksnapper-gentoodesktop.pub"))
> > > > ("root" ,(local-file "ssh/baksnapper-gentooserver.pub"))
> > > > ("root" ,(local-file "ssh/nathan-guixlaptop.pub"))
> > > > ))))
> > > > (service connman-service-type)
> > > > (service ntp-service-type)
> > > > (service gpm-service-type)
> > > > (simple-service 'nanorc etc-service-type
> > > > (list `("nanorc", nanorc)))
> > > > )
> > > > %base-services)))
> > >
> > > It seems I may have fallen for the grub luks2 compatibility issue,
> > > which I didn't know about. I will investigate later.
> > >
> > Yeah, that was the problem.
>
> GRUB currently doesn't support Argon2 PBKDFs, if you are going to use LUKS2, you
> have to specify pbkdf2:
> --8<---------------cut here---------------start------------->8---
> cryptsetup --type=luks2 --pbkdf=pbkdf2
> --8<---------------cut here---------------end--------------->8---
>
> In case it's needed, I packaged a GRUB variant with Argon2 support and its
> bootloader definition in my channel:
> https://github.com/rakino/Rosenthal/blob/trunk/rosenthal/packages/bootloaders.scm
> https://github.com/rakino/Rosenthal/blob/trunk/rosenthal/bootloader/grub.scm
>
> I re-installed my system with this GRUB variant (also intended to test it)
> recently, and it works just fine.
>
> I think this bug can be closed now?
H
H
Hilton Chain wrote on 25 Feb 10:47 +0100
(name . Nathan Dehnel)(address . ncdehnel@gmail.com)
87il2cswo4.wl-hako@ultrarare.space
Hi Nathan

On Sun, 25 Feb 2024 13:20:06 +0800,
Nathan Dehnel wrote:
Toggle quote (3 lines)
>
> On Sat, Feb 24, 2024 at 8:59?PM Hilton Chain <hako@ultrarare.space> wrote:
> >
[...]
Toggle quote (18 lines)
> > GRUB currently doesn't support Argon2 PBKDFs, if you are going to use LUKS2, you
> > have to specify pbkdf2:
> > --8<---------------cut here---------------start------------->8---
> > cryptsetup --type=luks2 --pbkdf=pbkdf2
> > --8<---------------cut here---------------end--------------->8---
> >
> > In case it's needed, I packaged a GRUB variant with Argon2 support and its
> > bootloader definition in my channel:
> > https://github.com/rakino/Rosenthal/blob/trunk/rosenthal/packages/bootloaders.scm
> > https://github.com/rakino/Rosenthal/blob/trunk/rosenthal/bootloader/grub.scm
> >
> > I re-installed my system with this GRUB variant (also intended to test it)
> > recently, and it works just fine.
> >
> > I think this bug can be closed now?
>
> I tried that and it didn't work, I had to use --type=luks1

Then it might be because the ‘luks2’ module is not automatically installed to
GRUB's core image. This should be fixed in GRUB 2.12, but we are still shipping
2.06...
?