[PATCH 0/2] Update nicotine+ to 3.3.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Juliana Sims
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 19 Feb 19:02 +0100
(address . guix-patches@gnu.org)(name . Juliana Sims)(address . juli@incana.org)
cover.1708364747.git.juli@incana.org
Hello,

This patch series starts with a simple version bump of nicotine+, followed by a
patch to port it to g-expressions.

Thanks,
Juli

Juliana Sims (2):
gnu: nicotine+: Update to 3.3.0.
gnu: nicotine+: Use g-expressions.

gnu/packages/nicotine.scm | 83 +++++++++++++++++++++------------------
1 file changed, 45 insertions(+), 38 deletions(-)


base-commit: 7d6550eec7fe98517a2096d55760a4d5be3ad8ef
--
2.41.0
J
J
Juliana Sims wrote on 19 Feb 19:05 +0100
[PATCH 1/2] gnu: nicotine+: Update to 3.3.0.
(address . 69277@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
3b26bf335c62fbbde02e885721743c8be304bb45.1708364747.git.juli@incana.org
* gnu/packages/nicotine.scm (nicotine+): Update to 3.3.0.

Change-Id: I793131250f33af003b6adc72bdf03b0759e23d8e
---
gnu/packages/nicotine.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 08232c2756..3c8a384659 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -34,17 +34,17 @@ (define-module (gnu packages nicotine)
(define-public nicotine+
(package
(name "nicotine+")
- (version "3.2.1")
+ (version "3.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Nicotine-Plus/nicotine-plus")
(commit version)))
(file-name (git-file-name name version))
- (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))
+ (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
(modules '((guix build utils)))
;; Remove test that relies on network access.
- (snippet '(delete-file-recursively "test/integration"))))
+ (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
(build-system python-build-system)
(arguments
`(#:imported-modules ((guix build glib-or-gtk-build-system)
--
2.41.0
J
J
Juliana Sims wrote on 19 Feb 19:05 +0100
[PATCH 2/2] gnu: nicotine+: Use g-expressions.
(address . 69277@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
8efebe7659bf32271d048d4481b50423450516b2.1708364748.git.juli@incana.org
* gnu/packages/nicotine.scm (nicotine+): Use g-expressions, lint, style.

Change-Id: If51864440781825dddc7745a88c6efec02ed8e30
---
gnu/packages/nicotine.scm | 81 +++++++++++++++++++++------------------
1 file changed, 44 insertions(+), 37 deletions(-)

Toggle diff (111 lines)
diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 3c8a384659..5a96a76e47 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2022 Fatima Toothpaste <fatimatoothpaste@disroot.org>
+;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,7 @@
(define-module (gnu packages nicotine)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages bash)
@@ -35,46 +37,51 @@ (define-public nicotine+
(package
(name "nicotine+")
(version "3.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Nicotine-Plus/nicotine-plus")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
- (modules '((guix build utils)))
- ;; Remove test that relies on network access.
- (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Nicotine-Plus/nicotine-plus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
+ (modules '((guix build utils)))
+ ;; Remove test that relies on network access.
+ (snippet '(delete-file-recursively
+ "pynicotine/tests/unit/test_version.py"))))
(build-system python-build-system)
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ (list
+ #:imported-modules `((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
- #:modules
- ((guix build utils)
- (guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:))
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append
- (assoc-ref outputs "out")
- "/bin/nicotine"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program prog
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
- (add-after 'wrap-program 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
- (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "xvfb-run" "python" "-m" "unittest")))))))
- (inputs
- (list bash-minimal gspell gtk+ python-pygobject libappindicator python-pytaglib))
- (native-inputs
- (list gettext-minimal xvfb-run))
+ #:modules `((guix build utils)
+ (guix build python-build-system)
+ ((guix build glib-or-gtk-build-system)
+ #:prefix glib-or-gtk:))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/nicotine")
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH"))))))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-wrap))
+ (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-compile-schemas))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "xvfb-run" "python" "-m" "unittest")))))))
+ (inputs (list bash-minimal
+ gspell
+ gtk+
+ python-pygobject
+ libappindicator
+ python-pytaglib))
+ (native-inputs (list gettext-minimal xvfb-run))
(home-page "https://nicotine-plus.org/")
(synopsis "Graphical client for Soulseek")
(description
--
2.41.0
J
J
Juliana Sims wrote on 19 Feb 19:21 +0100
[PATCH v2 1/2] gnu: nicotine+: Update to 3.3.0.
(address . 69277@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
2abfd2daf4291e16ef019c0a2d727bee9b9b28a2.1708366901.git.juli@incana.org
Hello,

I forgot to use gtk4 as the latest release of nicotine+ supports it. This patch
series is identical to the previous one except that it uses gtk instead of gtk+.

Thanks,
Juli

* gnu/packages/nicotine.scm (nicotine+): Update to 3.3.0.
---
gnu/packages/nicotine.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 08232c2756..909adfd3d0 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -34,17 +34,17 @@ (define-module (gnu packages nicotine)
(define-public nicotine+
(package
(name "nicotine+")
- (version "3.2.1")
+ (version "3.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Nicotine-Plus/nicotine-plus")
(commit version)))
(file-name (git-file-name name version))
- (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))
+ (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
(modules '((guix build utils)))
;; Remove test that relies on network access.
- (snippet '(delete-file-recursively "test/integration"))))
+ (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
(build-system python-build-system)
(arguments
`(#:imported-modules ((guix build glib-or-gtk-build-system)
@@ -72,7 +72,7 @@ (define-public nicotine+
(when tests?
(invoke "xvfb-run" "python" "-m" "unittest")))))))
(inputs
- (list bash-minimal gspell gtk+ python-pygobject libappindicator python-pytaglib))
+ (list bash-minimal gspell gtk python-pygobject libappindicator python-pytaglib))
(native-inputs
(list gettext-minimal xvfb-run))
(home-page "https://nicotine-plus.org/")

base-commit: 7d6550eec7fe98517a2096d55760a4d5be3ad8ef
--
2.41.0
J
J
Juliana Sims wrote on 19 Feb 19:21 +0100
[PATCH v2 2/2] gnu: nicotine+: Use g-expressions.
(address . 69277@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
45639fd3485db932d0976c82f57bda93a135a0f8.1708366901.git.juli@incana.org
* gnu/packages/nicotine.scm (nicotine+): Use g-expressions, lint, style.

Change-Id: If51864440781825dddc7745a88c6efec02ed8e30
---
gnu/packages/nicotine.scm | 81 +++++++++++++++++++++------------------
1 file changed, 44 insertions(+), 37 deletions(-)

Toggle diff (111 lines)
diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 909adfd3d0..6b08f2a66d 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2022 Fatima Toothpaste <fatimatoothpaste@disroot.org>
+;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,7 @@
(define-module (gnu packages nicotine)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages bash)
@@ -35,46 +37,51 @@ (define-public nicotine+
(package
(name "nicotine+")
(version "3.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Nicotine-Plus/nicotine-plus")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
- (modules '((guix build utils)))
- ;; Remove test that relies on network access.
- (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Nicotine-Plus/nicotine-plus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
+ (modules '((guix build utils)))
+ ;; Remove test that relies on network access.
+ (snippet '(delete-file-recursively
+ "pynicotine/tests/unit/test_version.py"))))
(build-system python-build-system)
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ (list
+ #:imported-modules `((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
- #:modules
- ((guix build utils)
- (guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:))
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append
- (assoc-ref outputs "out")
- "/bin/nicotine"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program prog
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
- (add-after 'wrap-program 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
- (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "xvfb-run" "python" "-m" "unittest")))))))
- (inputs
- (list bash-minimal gspell gtk python-pygobject libappindicator python-pytaglib))
- (native-inputs
- (list gettext-minimal xvfb-run))
+ #:modules `((guix build utils)
+ (guix build python-build-system)
+ ((guix build glib-or-gtk-build-system)
+ #:prefix glib-or-gtk:))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/nicotine")
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH"))))))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-wrap))
+ (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-compile-schemas))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "xvfb-run" "python" "-m" "unittest")))))))
+ (inputs (list bash-minimal
+ gspell
+ gtk
+ python-pygobject
+ libappindicator
+ python-pytaglib))
+ (native-inputs (list gettext-minimal xvfb-run))
(home-page "https://nicotine-plus.org/")
(synopsis "Graphical client for Soulseek")
(description
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69277@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69277
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch