[PATCH] gnu: libtorrent-rasterbar: Update to 2.0.10.

  • Open
  • quality assurance status badge
Details
One participant
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 19 Feb 17:16 +0100
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
f919291c278f062906ae7a09edf8132eaa125c30.1708359393.git.~@wolfsden.cz
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.

Change-Id: I9056b2cb6eac9740f95daf2fb73d874ca95f1a7f
---
gnu/packages/bittorrent.scm | 32 +++++---------------------------
1 file changed, 5 insertions(+), 27 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0d544235c1..34a7c17738 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -418,16 +418,10 @@ (define-public mktorrent
(license (list l:public-domain ; sha1.*, used to build without OpenSSL
l:gpl2+)))) ; with permission to link with OpenSSL
-(define %v2_empty_file.torrent
- (origin (method url-fetch)
- (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
- (sha256
- (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
-
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "2.0.9")
+ (version "2.0.10")
(source
(origin
(method url-fetch)
@@ -436,14 +430,7 @@ (define-public libtorrent-rasterbar
"releases/download/v" version "/"
"libtorrent-rasterbar-" version ".tar.gz"))
(sha256
- (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
- ;; https://github.com/arvidn/libtorrent/issues/7566
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- (modules '((guix build utils)))
- (snippet
- #~(substitute* "test/test_copy_file.cpp"
- (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
- (string-append all ", TMPFS_MAGIC\n"))))))
+ (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-Dpython-bindings=ON"
@@ -452,14 +439,6 @@ (define-public libtorrent-rasterbar
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- ;; https://github.com/arvidn/libtorrent/issues/7567
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- ;; Do not forget to remove the %v2_empty_file.torrent variable.
- (add-before 'configure 'copy-v2_empty_file.torrent
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (copy-file (assoc-ref (or native-inputs inputs)
- "%v2_empty_file.torrent")
- "test/test_torrents/v2_empty_file.torrent")))
(replace 'check
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let* ((disabled-tests
@@ -500,10 +479,9 @@ (define-public libtorrent-rasterbar
;; "--output-on-failure")
)))))))
(inputs (list boost openssl))
- (native-inputs `(("libfaketime" ,libfaketime)
- ("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
+ (native-inputs (list libfaketime
+ python-wrapper
+ pkg-config))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description

base-commit: fdbf4192f5eaa7fdb5e6e2e98ada0726c8104824
--
2.41.0
?