[PATCH] gnu: libtorrent-rasterbar: Update to 2.0.10.

  • Done
  • quality assurance status badge
Details
4 participants
  • Adam Faiz
  • John Kehayias
  • Z572
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 19 Feb 2024 17:16
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
f919291c278f062906ae7a09edf8132eaa125c30.1708359393.git.~@wolfsden.cz
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.

Change-Id: I9056b2cb6eac9740f95daf2fb73d874ca95f1a7f
---
gnu/packages/bittorrent.scm | 32 +++++---------------------------
1 file changed, 5 insertions(+), 27 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0d544235c1..34a7c17738 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -418,16 +418,10 @@ (define-public mktorrent
(license (list l:public-domain ; sha1.*, used to build without OpenSSL
l:gpl2+)))) ; with permission to link with OpenSSL
-(define %v2_empty_file.torrent
- (origin (method url-fetch)
- (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
- (sha256
- (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
-
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "2.0.9")
+ (version "2.0.10")
(source
(origin
(method url-fetch)
@@ -436,14 +430,7 @@ (define-public libtorrent-rasterbar
"releases/download/v" version "/"
"libtorrent-rasterbar-" version ".tar.gz"))
(sha256
- (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
- ;; https://github.com/arvidn/libtorrent/issues/7566
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- (modules '((guix build utils)))
- (snippet
- #~(substitute* "test/test_copy_file.cpp"
- (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
- (string-append all ", TMPFS_MAGIC\n"))))))
+ (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-Dpython-bindings=ON"
@@ -452,14 +439,6 @@ (define-public libtorrent-rasterbar
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- ;; https://github.com/arvidn/libtorrent/issues/7567
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- ;; Do not forget to remove the %v2_empty_file.torrent variable.
- (add-before 'configure 'copy-v2_empty_file.torrent
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (copy-file (assoc-ref (or native-inputs inputs)
- "%v2_empty_file.torrent")
- "test/test_torrents/v2_empty_file.torrent")))
(replace 'check
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let* ((disabled-tests
@@ -500,10 +479,9 @@ (define-public libtorrent-rasterbar
;; "--output-on-failure")
)))))))
(inputs (list boost openssl))
- (native-inputs `(("libfaketime" ,libfaketime)
- ("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
+ (native-inputs (list libfaketime
+ python-wrapper
+ pkg-config))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description

base-commit: fdbf4192f5eaa7fdb5e6e2e98ada0726c8104824
--
2.41.0
A
A
Adam Faiz wrote on 6 Aug 2024 15:07
[PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.
(address . 69276@debbugs.gnu.org)
9a9ec5ec-5b51-cad9-b01e-76d495752240@disroot.org
From 4af05095ca922bb6d0335a6e946a404d4764ac1f Mon Sep 17 00:00:00 2001
Message-ID: <4af05095ca922bb6d0335a6e946a404d4764ac1f.1722949379.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
References: <cover.1722949379.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 6 Aug 2024 19:57:47 +0800
Subject: [PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.

* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.
[source]<snippet>: Remove test/test_copy_file.cpp patch since it's resolved.
[native-inputs]: Remove no longer needed file (v2_empty_file.torrent).
[arguments]<#:phases>: And remove a phase copying it into the correct place.
---
gnu/packages/bittorrent.scm | 28 +++-------------------------
1 file changed, 3 insertions(+), 25 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 5c2fa9c688..abc598f7fa 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -418,16 +418,10 @@ (define-public mktorrent
(license (list l:public-domain ; sha1.*, used to build without OpenSSL
l:gpl2+)))) ; with permission to link with OpenSSL
-(define %v2_empty_file.torrent
- (origin (method url-fetch)
- (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
- (sha256
- (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
-
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "2.0.9")
+ (version "2.0.10")
(source
(origin
(method url-fetch)
@@ -436,14 +430,7 @@ (define-public libtorrent-rasterbar
"releases/download/v" version "/"
"libtorrent-rasterbar-" version ".tar.gz"))
(sha256
- (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
- ;; https://github.com/arvidn/libtorrent/issues/7566
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- (modules '((guix build utils)))
- (snippet
- #~(substitute* "test/test_copy_file.cpp"
- (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
- (string-append all ", TMPFS_MAGIC\n"))))))
+ (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-Dpython-bindings=ON"
@@ -452,14 +439,6 @@ (define-public libtorrent-rasterbar
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- ;; https://github.com/arvidn/libtorrent/issues/7567
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- ;; Do not forget to remove the %v2_empty_file.torrent variable.
- (add-before 'configure 'copy-v2_empty_file.torrent
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (copy-file (assoc-ref (or native-inputs inputs)
- "%v2_empty_file.torrent")
- "test/test_torrents/v2_empty_file.torrent")))
(replace 'check
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let* ((disabled-tests
@@ -502,8 +481,7 @@ (define-public libtorrent-rasterbar
(inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
+ ("pkg-config" ,pkg-config)))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description
--
2.41.0
A
A
Adam Faiz wrote on 6 Aug 2024 15:09
[PATCH 2/2] gnu: libtorrent-rasterbar: Use gexps and new input style.
(address . 69276@debbugs.gnu.org)
405ac53a-7195-4b9f-db06-022e6bb3433c@disroot.org
From 646cc0c6857c41564eda8ccc0ade07ae16a18a6c Mon Sep 17 00:00:00 2001
Message-ID: <646cc0c6857c41564eda8ccc0ade07ae16a18a6c.1722949379.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
References: <cover.1722949379.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 6 Aug 2024 20:55:13 +0800
Subject: [PATCH 2/2] gnu: libtorrent-rasterbar: Use gexps and new input style.

* gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]: Use gexps.
[native-inputs]: Drop labels.
---
gnu/packages/bittorrent.scm | 75 +++++++++++++++++++------------------
1 file changed, 38 insertions(+), 37 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index abc598f7fa..fa2765da5b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -433,33 +433,34 @@ (define-public libtorrent-rasterbar
(base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-Dpython-bindings=ON"
- "-Dbuild_tests=ON")
- ;; Tests do not reliably work when executed in parallel.
- #:parallel-tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
- (let* ((disabled-tests
- '(
- ;; Requires a non-localhost IPv4 interface.
- "test_upnp"
- ;; test_ssl needs to be run separately.
- "test_ssl"))
- (exclude-regex (string-append "^("
- (string-join disabled-tests "|")
- ")$"))
- (timeout "600")
- (jobs (if parallel-tests?
- (number->string (parallel-job-count))
- "1")))
- (when tests?
- (invoke "ctest"
- "-E" exclude-regex
- "-j" jobs
- "--timeout" timeout
- "--output-on-failure")
+ (list
+ #:configure-flags
+ #~'("-Dpython-bindings=ON"
+ "-Dbuild_tests=ON")
+ ;; Tests do not reliably work when executed in parallel.
+ #:parallel-tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (let* ((disabled-tests
+ '(;; Requires a non-localhost IPv4 interface.
+ "test_upnp"
+ ;; test_ssl needs to be run separately.
+ "test_ssl"))
+ (exclude-regex (string-append "^("
+ (string-join disabled-tests "|")
+ ")$"))
+ (timeout "600")
+ (jobs (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))
+ (when tests?
+ (invoke "ctest"
+ "-E" exclude-regex
+ "-j" jobs
+ "--timeout" timeout
+ "--output-on-failure")
;; test_ssl relies on bundled TLS certificates with a fixed
;; expiry date. To ensure succesful builds in the future,
;; fake the time to be roughly that of the release.
@@ -471,17 +472,17 @@ (define-public libtorrent-rasterbar
;;
;; Note: The test_ssl test times out in the ci.
;; Temporarily disable it until that is resolved.
- ;; (invoke "faketime" "2022-10-24"
- ;; "ctest"
- ;; "-R" "^test_ssl$"
- ;; "-j" jobs
- ;; "--timeout" timeout
- ;; "--output-on-failure")
- )))))))
+ #;(invoke "faketime" "2022-10-24"
+ "ctest"
+ "-R" "^test_ssl$"
+ "-j" jobs
+ "--timeout" timeout
+ "--output-on-failure"))))))))
(inputs (list boost openssl))
- (native-inputs `(("libfaketime" ,libfaketime)
- ("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)))
+ (native-inputs
+ (list libfaketime
+ python-wrapper
+ pkg-config))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description
--
2.41.0
Z
Re: [bug#69276] [PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.
(name . Adam Faiz via Guix-patches via)(address . guix-patches@gnu.org)
87cykdsigu.fsf@iscas.ac.cn
Adam Faiz via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (80 lines)
> From 4af05095ca922bb6d0335a6e946a404d4764ac1f Mon Sep 17 00:00:00 2001
> Message-ID: <4af05095ca922bb6d0335a6e946a404d4764ac1f.1722949379.git.adam.faiz@disroot.org>
> In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
> References: <cover.1722949379.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Tue, 6 Aug 2024 19:57:47 +0800
> Subject: [PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.
>
> * gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.
> [source]<snippet>: Remove test/test_copy_file.cpp patch since it's resolved.
> [native-inputs]: Remove no longer needed file (v2_empty_file.torrent).
> [arguments]<#:phases>: And remove a phase copying it into the correct place.
> ---
> gnu/packages/bittorrent.scm | 28 +++-------------------------
> 1 file changed, 3 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index 5c2fa9c688..abc598f7fa 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -418,16 +418,10 @@ (define-public mktorrent
> (license (list l:public-domain ; sha1.*, used to build without OpenSSL
> l:gpl2+)))) ; with permission to link with OpenSSL
>
> -(define %v2_empty_file.torrent
> - (origin (method url-fetch)
> - (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
> - (sha256
> - (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
> -
> (define-public libtorrent-rasterbar
> (package
> (name "libtorrent-rasterbar")
> - (version "2.0.9")
> + (version "2.0.10")
> (source
> (origin
> (method url-fetch)
> @@ -436,14 +430,7 @@ (define-public libtorrent-rasterbar
> "releases/download/v" version "/"
> "libtorrent-rasterbar-" version ".tar.gz"))
> (sha256
> - (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
> - ;; https://github.com/arvidn/libtorrent/issues/7566
> - ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
> - (modules '((guix build utils)))
> - (snippet
> - #~(substitute* "test/test_copy_file.cpp"
> - (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
> - (string-append all ", TMPFS_MAGIC\n"))))))
> + (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
> (build-system cmake-build-system)
> (arguments
> `(#:configure-flags '("-Dpython-bindings=ON"
> @@ -452,14 +439,6 @@ (define-public libtorrent-rasterbar
> #:parallel-tests? #f
> #:phases
> (modify-phases %standard-phases
> - ;; https://github.com/arvidn/libtorrent/issues/7567
> - ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
> - ;; Do not forget to remove the %v2_empty_file.torrent variable.
> - (add-before 'configure 'copy-v2_empty_file.torrent
> - (lambda* (#:key native-inputs inputs #:allow-other-keys)
> - (copy-file (assoc-ref (or native-inputs inputs)
> - "%v2_empty_file.torrent")
> - "test/test_torrents/v2_empty_file.torrent")))
> (replace 'check
> (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
> (let* ((disabled-tests
> @@ -502,8 +481,7 @@ (define-public libtorrent-rasterbar
> (inputs (list boost openssl))
> (native-inputs `(("libfaketime" ,libfaketime)
> ("python-wrapper" ,python-wrapper)
> - ("pkg-config" ,pkg-config)
> - ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
> + ("pkg-config" ,pkg-config)))
> (home-page "https://www.libtorrent.org/")
> (synopsis "Feature-complete BitTorrent implementation")
> (description

adjust message, not use #; , push and close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcCVIEACgkQO1qpk+Gi
3/DZ4w/9HgHuVaeFoZWGIZI5pXHXuYKQSgTcu1dxFZplPAjyzyaTCpoCtumx/2WH
C4M0u2VUc7XapaNgDBG+FIcdOgsp2uKzE2LAg1ZDX7ruvcoY0b47q8nvVnmvHPli
w7481djWWDwWix7Z1zEus3jF93je7Zummofe2tCGX5/ljqdNk1G4O0NVspKH46H4
GH6OgRptA1QCC387S1ttUbZzVSmd7ssM4Kyg9rotTR5UhoUH4ShKCRrhkpvhScpc
RzFsyxLuNhhZuCA+RaZtQUDDfWH/s8jvdE0CgHGPDSJp51sVIAyhsLYO/TWEKhfn
dFLmXOHJ1Z/3Dl6edMFIverUa7/hV0L4mCeoYOvN2J0v35rhNtBSl4sAYP0x6pJa
vjhPxcRPlKFnArafgokmkd1bsT1n7s/6Xq0MMLDimxuDDAMfcEE2xWJnTZVAWzgq
GCLbJzqKn7pwlGX9Yum+JecuXqR5lNaA2TyfmfND5hjy+yTYnjn9qn8xjT6ZRwGt
pdnT9jnKfI9izi5fZmLZqvQQbsXUmpG0DB3ZxUtA8ABg2A3sLJNL4+94k3js8HYk
9FXOPb7VoNUoSC/N6RTG3usjyv8zu6/kPl894wdfsbOvHjejwqrgXC5g3+kkJOJv
7TQR+EevHnduHhiM1w84yejsLhSo1C8/OeblxB7i55IKEgndl/4=
=/km3
-----END PGP SIGNATURE-----

J
J
John Kehayias wrote on 6 Oct 2024 21:15
Re: 01/04: gnu: libtorrent-rasterbar: Update to 2.0.10.
87iku53uwy.fsf@protonmail.com
Dear Tomas (and CC'ing the debbugs number, co-author, and committer Z572),

On Sun, Oct 06, 2024 at 07:52 PM, Tomas Volf wrote:

Toggle quote (16 lines)
> guix-commits@gnu.org writes:
>
>> z572 pushed a commit to branch master
>> in repository guix.
>>
>> commit 37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f
>> Author: Adam Faiz via Guix-patches via <guix-patches@gnu.org>
>> AuthorDate: Tue Aug 6 21:07:40 2024 +0800
>
> I have to admit I am not very happy regarding the change in the commit
> author. While I understand the change itself might have been somewhat
> trivial, I did work with upstream to merge the required changes for
> 2.0.10, so having the authorship stolen like this leaves somewhat
> unpleasant feeling.
>

I understand your frustration and while I thank you for bringing this to attention (we care about attribution here!), I do think this was escalated a tiny bit in the heat of the moment. I don't see this message in the original patch thread with the other author (Adam) and committer (Z572, still relatively new), so it is quite possible they didn't see this message you sent until now.

I should say, I do think it is good to raise awareness so we can all do better, but I think we should try to give some benefit of the doubt and look for the best way forward. Mistakes happen! I had accidentally lost the author of some commits and realized after I had pushed them, raising this after with guix-devel and the original authors for what remedy they would like. Though everything was okay, I felt bad, and still do, but at least it has made me more vigilant. Let's remember we are all trying our best here and imagine ourselves on the other side.

(Side note that upstream work to help out Guix and packaging is always welcome, so thank you for that! Though that is separate from authorship of commits on the Guix side, of course.)

Toggle quote (7 lines)
> Especially since applying for commit access has a number of commits as
> one of prerequisites, having your address visible in `git log --author'
> goes from "collecting internet points" into "actually somewhat
> important". But even without that, I would still consider it not a nice
> thing to do.
>

Part of having commit access is also accepting that mistakes will happen and you are expected to remedy, learn, and help us all do better (e.g. see https://guix.gnu.org/manual/devel/en/html_node/Commit-Access.html). This quality I would say is much more important than just number of contributions, though that experience is a more quantifiable prerequisite.

As I hope a neutral third party, in this case I would suggest reverting the commits and then reapplying them with author/co-author set appropriately. I think this issue should have been brought up more directly with the parties involved, whether or not cc-ing guix-devel helps here I can't say. As I said, I at least take it as a reminder of our responsibilities and potential mistakes when we have commit access. While I could of course take this action myself, in following the link above, I leave it to those involved first.

Toggle quote (3 lines)
> Have a nice day,
> Tomas

Let me also thank you for your contributions! I look forward to one day seeing you announced as a new committer as you continue to contribute. But I hope when you are on that side and make a mistake, as we all do, that you are given the benefit of the doubt, a chance to rectify, and help us all do better.

John

PS: I know tone is hard and easily (wrongly) assumed in written communication. Let me stress that all I wrote was meant to be understanding to your perspective and feelings (which I'm sure many would share in the same circumstances!) while also helping us reach a mutually beneficial remedy.
T
T
Tomas Volf wrote on 7 Oct 2024 00:02
(name . John Kehayias)(address . john.kehayias@protonmail.com)
87plocyjn9.fsf@wolfsden.cz
Hello John,

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (39 lines)
> Dear Tomas (and CC'ing the debbugs number, co-author, and committer Z572),
>
> On Sun, Oct 06, 2024 at 07:52 PM, Tomas Volf wrote:
>
>> guix-commits@gnu.org writes:
>>
>>> z572 pushed a commit to branch master
>>> in repository guix.
>>>
>>> commit 37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f
>>> Author: Adam Faiz via Guix-patches via <guix-patches@gnu.org>
>>> AuthorDate: Tue Aug 6 21:07:40 2024 +0800
>>
>> I have to admit I am not very happy regarding the change in the commit
>> author. While I understand the change itself might have been somewhat
>> trivial, I did work with upstream to merge the required changes for
>> 2.0.10, so having the authorship stolen like this leaves somewhat
>> unpleasant feeling.
>>
>
> I understand your frustration and while I thank you for bringing this to
> attention (we care about attribution here!), I do think this was escalated a
> tiny bit in the heat of the moment. I don't see this message in the original
> patch thread with the other author (Adam) and committer (Z572, still relatively
> new), so it is quite possible they didn't see this message you sent until now.
>
> I should say, I do think it is good to raise awareness so we can all do better,
> but I think we should try to give some benefit of the doubt and look for the
> best way forward. Mistakes happen! I had accidentally lost the author of some
> commits and realized after I had pushed them, raising this after with guix-devel
> and the original authors for what remedy they would like. Though everything was
> okay, I felt bad, and still do, but at least it has made me more vigilant. Let's
> remember we are all trying our best here and imagine ourselves on the other
> side.
>
> (Side note that upstream work to help out Guix and packaging is always
> welcome, so thank you for that! Though that is separate from
> authorship of commits on the Guix side, of course.)

Hm, there is probably little bit of misunderstanding here. Yes, I was
(am) a bit sad about this happening, but I did not really meant the
email as an "escalation". And I did not send it to the debbugs bug
first.

I was just reacting to the commit I saw in guix-commits mailing list.
It explicitly has guix-devel set as Reply-To (instead of, for example,
the commit author), so I assumed here (guix-devel) is where should I
raise the issue.

I fully understand people (me included) make mistakes and I did not (and
do not) assume ill intentions here.

However, re-reading my original message I do think I should have taken a
second breath and tune it down a notch (or two), for failing to do that
I apologize.

Toggle quote (18 lines)
>
>> Especially since applying for commit access has a number of commits as
>> one of prerequisites, having your address visible in `git log --author'
>> goes from "collecting internet points" into "actually somewhat
>> important". But even without that, I would still consider it not a nice
>> thing to do.
>>
>
> Part of having commit access is also accepting that mistakes will happen and you
> are expected to remedy, learn, and help us all do better (e.g. see
> <https://guix.gnu.org/manual/devel/en/html_node/Commit-Access.html>). This
> quality I would say is much more important than just number of contributions,
> though that experience is a more quantifiable prerequisite.
>
> As I hope a neutral third party, in this case I would suggest reverting the
> commits and then reapplying them with author/co-author set
> appropriately.

While I appreciate the suggestion from a neutral party, I do not insist
on that. This is just one patch of many that I have sent (and hopefully
will send). I would very much prefer z572 to spent time on merging new
patches instead of redoing this one. Many of my patches were applied by
z572, and I am grateful for their work.

Toggle quote (4 lines)
> I think this issue should have been brought up more directly with the
> parties involved, whether or not cc-ing guix-devel helps here I can't
> say.

I reacted on this above already, but I will put up an explicit
suggestion: Maybe the Reply-To on guix-commits should be the committer.

Toggle quote (13 lines)
> As I said, I at least take it as a reminder of our responsibilities
> and potential mistakes when we have commit access. While I could of
> course take this action myself, in following the link above, I leave
> it to those involved first.
>
>> Have a nice day,
>> Tomas
>
> Let me also thank you for your contributions! I look forward to one day seeing
> you announced as a new committer as you continue to contribute. But I hope when
> you are on that side and make a mistake, as we all do, that you are given the
> benefit of the doubt, a chance to rectify, and help us all do better.

As do I :)

Toggle quote (9 lines)
>
> John
>
> PS: I know tone is hard and easily (wrongly) assumed in written
> communication. Let me stress that all I wrote was meant to be understanding to
> your perspective and feelings (which I'm sure many would share in the same
> circumstances!) while also helping us reach a mutually beneficial
> remedy.

I appreciate your reply and calm, neutral view point trying to find a
common way forward. Thank you for weighing in.

Have a nice day,
Tomas

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmcDCQoOHH5Ad29sZnNk
ZW4uY3oACgkQL7/ufbZ/wamSSQ/9FTHSPHAI1sXRUwSSfCuNtnabi7BhKUtsgbpP
KGBCK4o5KktfLgQB0TIt9M/iLDqUXeeXboQZ4129wxp4n5aYCs1ddsT5LKAMeFrL
IUaeSnpzpDnDnouT6QG5rABFcMD4qPXl6XbHdYqH7VT2B9riHDlF3SPmgKv3sVi/
OKKxuRKSHqCK+Ime8TTuiWfYkALed75X6bwqYAqo7uOThmRbM2AsXAW3ys0FVlEK
BWSVHEDKgLPNKup6ysE7wJ4ffRs2fU3/MnidRQRcJftCSDIdMiReIpZ4cMgqLHmy
046FqRWmXwbIuVk2j15tXItPxeGham7E7bJhn90eLwqyvp103BaVMxyLNqVs+z6v
svT8ICpkmnd+GOiY1BTwCF1iJ5QHTezusyeRgtvAfP0hgC1PStSYrWQaBGyLKnK8
n965J2QjBHxfqHF62tMGFIVFCw64zIgG+bbZVmWNxlR/+TeCZqnGCiaCnNDt7UhT
bDckFbLhXht/AV6JH7f/wHqqBdNTUPBKZl94T3fOjMKc6wRooL7JpRLFIrWomahp
z/Ov7gi8IhumUOrw37222/K/803jAM/KkFFhtJ6vGTGBjj9OrgUElBvwXEK391pL
65uw/MtEWIqtcvJFCSkem/WfV56SVe0hz4JfuMxbO0TQef/vIY9mt60e/7VxhgKW
GPmmyX4=
=L4m1
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 69276@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69276
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch