nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (python-ega-download-client): Update to 5.1.0.
Change-Id: I010c3a0e7cb69184b72e8b13bad04ff2fd364f5a
---
gnu/packages/bioinformatics.scm | 26 ++++++++++++++------------
1 file changed, 14 insertions(+), 12 deletions(-)
Toggle diff (41 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 85507b6c15..00a20aa4fc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2541,18 +2541,20 @@ (define-public python-ega-download-client
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags
- '(list "-k"
- ;; These tests fail because they require internet access.
- (string-append "not test_download.py"
- " and not test_htsget.py"
- " and not test_commands.py"))
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- (("==") ">=")))))))
+ #:test-flags '(list "-k"
+ ;; These tests fail because they require internet access.
+ (string-append "not test_download.py"
+ " and not test_htsget.py"
+ " and not test_commands.py"
+ ;; The following 2 tests are failing with MaxRetriesReachedError
+ " and not test_download_file.py"
+ " and not test_download_file.py"))
+ #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("==")
+ ">=")))))))
(propagated-inputs (list python-htsget python-psutil python-requests
python-tqdm python-urllib3))
(native-inputs (list python-coverage python-pytest python-pyfakefs
base-commit: 052ef145215d45e1fe0e179df3b8c9626e021c2b
--
2.34.1