[PATCH 0/2] Add python-heatwave.

  • Open
  • quality assurance status badge
Details
One participant
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 19 Feb 10:50 +0100
(address . guix-patches@gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
cover.1708336084.git.w@wmeyer.eu
Hi Guix,

this small patchset adds python-heatwave as well as its dependency
python-monthdelta to python-xyz.py.

Kind regards,

Wilko

Wilko Meyer (2):
gnu: Add python-monthdelta.
gnu: Add python-heatwave.

gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)


base-commit: 07ecdb99b6c4b6b3e993d08034138bf69414020b
--
2.41.0
W
W
Wilko Meyer wrote on 19 Feb 10:53 +0100
[PATCH 1/2] gnu: Add python-monthdelta.
(address . 69268@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
91fbfef8fb19b6e1f56109be8961f03b2ee0ffad.1708336084.git.w@wmeyer.eu
* gnu/packages/python-xyz.scm (python-monthdelta): New variable.

Change-Id: I0e651f41252ec50cd2d7063e37d428265b17d8c2
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c3dfb9603c..c8fc5e1f7c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17727,6 +17727,23 @@ (define-public python-colorama-for-awscli
(sha256
(base32 "189n8hpijy14jfan4ha9f5n06mnl33cxz7ay92wjqgkr639s0vg9"))))))
+(define-public python-monthdelta
+ (package
+ (name "python-monthdelta")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "MonthDelta" version))
+ (sha256
+ (base32 "0iwcsk7ryjw5h1wp10ykwd01f3am8gdlga6461q1v1njsk0rxh41"))))
+ (build-system pyproject-build-system)
+ (home-page "http://packages.python.org/MonthDelta")
+ (synopsis "Date computations with months")
+ (description "MonthDelta provides functionality to do date computations
+with months.")
+ (license license:expat)))
+
(define-public python-moto
(package
(name "python-moto")
--
2.41.0
W
W
Wilko Meyer wrote on 19 Feb 10:53 +0100
[PATCH 2/2] gnu: Add python-heatwave.
(address . 69268@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
25eca894b682613e3dcb9eda707547e7c73bc3d1.1708336084.git.w@wmeyer.eu
* gnu/packages/python-xyz.scm (python-heatwave): New variable.
* gnu/packages/python-xyz.scm: Add my copyright header.

Change-Id: I640aecb3a0d9c454333a3913c039c637d24d9f79
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8fc5e1f7c..e318438c94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -147,6 +147,7 @@
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31533,6 +31534,24 @@ (define-public python-roundrobin
distribution in Python.")
(license license:expat)))
+(define-public python-heatwave
+ (package
+ (name "python-heatwave")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "heatwave" version))
+ (sha256
+ (base32 "1zzwmb9hvbyswzjgap02rrq8p44hb6xlzk1wd8w01mh2vva0xlx7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-click python-gitpython python-monthdelta))
+ (home-page "https://github.com/james-stoup/heatwave")
+ (synopsis "A way of visualizing a heat map of a git repo")
+ (description
+ "This package provides a way of visualizing a heat map of a git repo.")
+ (license license:gpl3)))
+
(define-public python-helpdev
(package
(name "python-helpdev")
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69268@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69268
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch