* gnu/packages/databases.scm (python-mysqlclient)
[build-system]: Change to pyproject-build-system.
[arguments]
<#:phases>: Add 'fix-test phase.
<#:test-flags>: Specify tests to run.
[native-inputs]: Add python-pytest.
[homepage]: Updated.
Change-Id: I5ae0873155f9a7cc90a318762b77864665fadc01
---
gnu/packages/databases.scm | 27 ++++++++++++++++++---------
1 file changed, 18 insertions(+), 9 deletions(-)
Toggle diff (40 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5169795404..4bb992c97c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4155,15 +4155,24 @@ (define-public python-mysqlclient
(method url-fetch)
(uri (pypi-uri "mysqlclient" version))
(sha256
- (base32
- "1rf5l8hazs3v18hmcrm90z3hi9wxv553ipwd5l6kj8j7l6p7abzv"))))
- (build-system python-build-system)
- (arguments '(#:tests? #f)) ;XXX: requires a live database
- (inputs
- `(("mysql-dev" ,mariadb "dev")))
- (home-page "https://github.com/PyMySQL/mysqlclient-python")
- (synopsis "MySQLdb is an interface to the popular MySQL database server for Python")
- (description "MySQLdb is an interface to the popular MySQL database server
+ (base32 "1rf5l8hazs3v18hmcrm90z3hi9wxv553ipwd5l6kj8j7l6p7abzv"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ (lambda _
+ (substitute* "tests/test_MySQLdb_times.py"
+ (("^import mock")
+ "from unittest import mock")))))
+ #:test-flags '("tests/test__mysql.py" ;tests not needing a live db
+ "tests/test_MySQLdb_times.py")))
+ (native-inputs (list python-pytest))
+ (inputs `(("mysql-dev" ,mariadb "dev")))
+ (home-page "https://github.com/PyMySQL/mysqlclient")
+ (synopsis
+ "MySQLdb is an interface to the popular MySQL database server for Python")
+ (description
+ "MySQLdb is an interface to the popular MySQL database server
for Python. The design goals are:
@enumerate
@item Compliance with Python database API version 2.0 [PEP-0249],
--
2.41.0