[PATCH] gnu: Add sandbar.

  • Done
  • quality assurance status badge
Details
2 participants
  • Erik Eduardo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Erik Eduardo
Severity
normal
E
E
Erik Eduardo wrote on 16 Feb 20:04 +0100
(address . guix-patches@gnu.org)(name . Erik Eduardo)(address . erik@erikeduardo.xyz)
e394c3d876c0e64c9694020bd1e283bb0b5609c3.1708110256.git.erik@erikeduardo.xyz
* gnu/packages/wm.scm(sandbar): New package definition.

Change-Id: I81e109dc72a18adf8bfbb29632397fe4160b4489
---
gnu/packages/wm.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4efd98f11c..550d58e7c0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1383,6 +1383,34 @@ (define-public keybinder
(define-public keybinder-3.0
(deprecated-package "keybinder-3.0" keybinder))
+(define-public sandbar
+ (package
+ (name "sandbar")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kolunmi/sandbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0912cr2q2kg4nqdwy978kpmdcj2cjz3gnlcb28ny9z3cprxvyvxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fcft wayland))
+ (native-inputs (list pkg-config wayland-protocols))
+ (synopsis "dwm-like bar for the river wayland compositor")
+ (description "A simple statusbar designed for the river window manager.")
+ (license (list license:gpl3 license:expat))
+ (home-page "https://github.com/kolunmi/sandbar")))
+
(define-public spectrwm
(package
(name "spectrwm")

base-commit: 96a2357a8a19bd4a796fdf1a875f7f3e0c91030c
--
2.41.0
E
E
Erik Eduardo wrote on 19 Feb 08:02 +0100
[PATCH v1] gnu: Add sandbar.
(address . 69219@debbugs.gnu.org)(name . Erik Eduardo)(address . erik@erikeduardo.xyz)
67f3bffb81657ee365efdd4bd791cc9034432b52.1708326175.git.erik@erikeduardo.xyz
* gnu/packages/wm.scm(sandbar): New package definition.

Change-Id: I81e109dc72a18adf8bfbb29632397fe4160b4489
---
gnu/packages/wm.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4efd98f11c..216745bed0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2024 Erik Eduardo <erik@erikeduardo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1383,6 +1384,34 @@ (define-public keybinder
(define-public keybinder-3.0
(deprecated-package "keybinder-3.0" keybinder))
+(define-public sandbar
+ (package
+ (name "sandbar")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kolunmi/sandbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0912cr2q2kg4nqdwy978kpmdcj2cjz3gnlcb28ny9z3cprxvyvxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fcft wayland))
+ (native-inputs (list pkg-config wayland-protocols))
+ (synopsis "dwm-like bar for the river wayland compositor")
+ (description "A simple statusbar designed for the river window manager.")
+ (license (list license:gpl3 license:expat))
+ (home-page "https://github.com/kolunmi/sandbar")))
+
(define-public spectrwm
(package
(name "spectrwm")

base-commit: 96a2357a8a19bd4a796fdf1a875f7f3e0c91030c
--
2.41.0
E
E
Erik Eduardo wrote on 31 Mar 13:33 +0200
[PATCH v2] gnu/packages/wm.scm(sandbar): New package definition.
(address . 69219@debbugs.gnu.org)(name . Erik Eduardo)(address . erik@erikeduardo.xyz)
9cc6d22f07c41b69297791b8cee40d688b688daa.1711884784.git.erik@erikeduardo.xyz
Change-Id: I93f91436420a733a3b74d9b88ed5d69a9369ee38
---
gnu/packages/wm.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2aaf9b0f66..75a862fbe8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -69,6 +69,7 @@
;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2024 chris <chris@bumblehead.com>
+;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1384,6 +1385,42 @@ (define-public keybinder
(define-public keybinder-3.0
(deprecated-package "keybinder-3.0" keybinder))
+(define-public sandbar
+ (package
+ (name "sandbar")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kolunmi/sandbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0912cr2q2kg4nqdwy978kpmdcj2cjz3gnlcb28ny9z3cprxvyvxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)) ;; no configure script
+ #:tests? #f ;; no check target
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))))
+ (inputs (list fcft wayland))
+ (native-inputs (list pkg-config wayland-protocols))
+ (synopsis "DWM-like bar for the River Wayland compositor")
+ (description "@command{sandbar} is a minimalist DWM-like bar designed for River,
+ a Wayland compositor. It is triggered through commands sent via
+ standard input, providing extensive customization options. This
+ behavior allows users to dynamically adjust status text, visibility,
+ and bar location, making @command{sandbar} an ideal choice for those
+ seeking a lightweight and hackable bar solution in their Wayland
+ environment.")
+ ;; LICENSE LICENSE.dtao
+ (license (list license:gpl3 license:expat))
+ (home-page "https://github.com/kolunmi/sandbar")))
+
(define-public spectrwm
(package
(name "spectrwm")

base-commit: 0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d
--
2.41.0
N
N
Nicolas Goaziou wrote on 15 Apr 12:19 +0200
(name . Erik Eduardo)(address . eduarskate8@gmail.com)
874jc3lyi1.fsf@nicolasgoaziou.fr
Hello,

Erik Eduardo <eduarskate8@gmail.com> writes:

Toggle quote (2 lines)
> +(define-public sandbar

I normalized the commit message and applied your patch. Thank you.

Toggle quote (8 lines)
> + (description "@command{sandbar} is a minimalist DWM-like bar designed for River,
> + a Wayland compositor. It is triggered through commands sent via
> + standard input, providing extensive customization options. This
> + behavior allows users to dynamically adjust status text, visibility,
> + and bar location, making @command{sandbar} an ideal choice for those
> + seeking a lightweight and hackable bar solution in their Wayland
> + environment.")

I fixed indentation and separated sentences with two spaces.

Nitpick: I also used capitalization for Sandbar (the project name)
instead of @command{sandbar} (the command), as reducing markup is always
better for readability.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69219@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69219
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch