[PATCH] gnu: Add go-github-com-coocood-freecache.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87y1bi9btr.fsf@troyfigiel.com
* gnu/packages/golang-xyz.scm (go-github-com-coocood-freecache): New variable.
---
gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b0a5955405..ab9127f588 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -264,6 +264,33 @@ (define-public go-github-com-burntsushi-toml
similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
+(define-public go-github-com-coocood-freecache
+ (package
+ (name "go-github-com-coocood-freecache")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coocood/freecache")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iw0s07qy8g1lncwl524c524wh56djl0vn6i3bm91cnwzav7ihjl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/coocood/freecache"))
+ (propagated-inputs (list go-github-com-cespare-xxhash))
+ (home-page "https://github.com/coocood/freecache")
+ (synopsis "Caching library for Go")
+ (description
+ "This library provides caching capabilities for Go with no garbage
+collection overhead and high concurrent performance. An unlimited number of
+objects can be cached in memory without increased latency or degraded
+throughput.")
+ (license license:expat)))
+
(define-public go-github-com-coreos-go-systemd-activation
(package
(name "go-github-com-coreos-go-systemd-activation")

base-commit: 2f1ed825afa535693f7fe32b9e3e9128cc8f99c9
--
2.42.0
Sharlatan Hellseher wrote 1 years ago
(address . 69216-done@debbugs.gnu.org)
874je4j9p3.fsf@gmail.com
Hi,

Pushed as f5de1f96ed46c427b67d78304977884ff7165538 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXT6SgACgkQdtcnv/Ys
0rVNaA/+Mm2vrvqqNccyojtudh8VLszNmzA3BNkFCIZW8F4rt8SDpB0fMj7oLtlz
aJFvtlf7QgghK6hmUoBlgBNOpJmXl/nOUWzuKHd3LfwbVPXl5xjpL8Pca94Vxsnb
SizGc1VvqqA256K8jNDzMtmHnBsPoVKz3iGviSf84qqX3KrVK7l3YR60QB6aGCbF
h6SO0y0C2AkBcfcLF3vVhlM7UZ/zVNKClVraXrG4h13ZXM1lAOXxa8ogDQyazorX
quIIzzpMcKEdNL1pWd5L9MWIq10v1DxdXqVMDfyka1MjxM2Qfoudgz51wGpxdR5Q
pjaaVVCVxFc1aGEmzWlAAFZB+9G1Al5buE/W0MHn/7VAtkHKJDkfRBmwH6uJYtIG
ohegxqW9XWkZIfvpdWkPVgUKqFw/zKO0cmvAd1VFw9QDmkRWyoZiI68huoMrRFka
2Yfo7qL9JmUNn/9INXrut/Gc2gMh2PAdxJgfL1Ls4omn0F6QJD3uWaOgBn3U3uM4
ca7qXpF0Ot64InelPpUv+8irE3Y5y8SllVA3VAGf5jXdC3oRlDDLx5CV+XEr/N8E
KtBAC49iIV2t+uRFOukEwWS3E9960CyTdqOmw0WkrH89vsrbXmG29asKPMMOZcTY
UUQBJSezBkjWcrjkHSkTCFnae13xeF2+xU1YS2h5jnv1xYwc9Vg=
=HnYO
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69216@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69216
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help