[PATCH] gnu: mariadb: Disable slow query test on aarch64-linux.

  • Open
  • quality assurance status badge
Details
One participant
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 18 Feb 18:53 +0100
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
6f053c5c37cb4bf350438cab5b7c9683c1b873f2.1708278381.git.roman@burningswell.com
* gnu/packages/databases.scm (mariadb): Disable slow query test on aarch64-linux.

Change-Id: Iacaf80fed6a859d6ed3d107a663254ba3d50f1bf
---
gnu/packages/databases.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5169795404..dcba464714 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1096,6 +1096,11 @@ (define-public mariadb
;; <https://jira.mariadb.org/browse/MDEV-24458>
,@(if (string-prefix? "i686" (%current-system))
'("main.myisampack")
+ '())
+
+ ;; This test fails on aarch64-linux (Apple M1).
+ ,@(if (string-prefix? "aarch64-linux" (%current-system))
+ '("main.analyze_stmt_slow_query_log")
'())))
;; This file contains a list of known-flaky tests for this

base-commit: 3cf199dbcf85a44fa8370e786e568fc3feb7067c
prerequisite-patch-id: 0250f6d992ee74e81797cb1266771a825226fa0b
prerequisite-patch-id: e03a4f63a64eda0c1f229e0b92d130a9beadefa5
prerequisite-patch-id: 09e6b4e8c70f5eb7996f78194c59245f38d3241b
prerequisite-patch-id: a12882ccf5bbef1edbd1110f128cd107f84a1377
prerequisite-patch-id: 2c83a46f3bcf9d3e153e2543fe9a57e5f33af286
prerequisite-patch-id: 3c1ca4618ff254748694208007768994f8f3f180
prerequisite-patch-id: a73addaa13a85a92272dd21e0edae93f60f7b55c
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69175@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69175
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch