[PATCH 00/46] Add netavark

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
cover.1708028223.git.~@wolfsden.cz
This series adds netavark, which will be required for next major version of
podman.

It also adds new #:cargo-native-inputs argument to the build system in order
to support crates that call native tooling during a build (prost-build)
without the need to have (native-inputs) on all user.

Tomas Volf (46):
build-system: cargo: Add #:cargo-native-inputs argument.
gnu: Add rust-pulldown-cmark-to-cmark-10.
gnu: Add rust-sync-wrapper-0.1.
gnu: Add rust-multer-2.
gnu: Add rust-iri-string-0.7.
gnu: Add rust-tower-http-0.4.
gnu: Add rust-axum-macros-0.3.
gnu: Add rust-axum-core-0.3.
gnu: Add rust-axum-0.6.
gnu: rust-async-stream-impl-0.3: Update to 0.3.5.
gnu: rust-async-stream-0.3: Update to 0.3.5.
gnu: Add rust-sysctl-0.5.
gnu: Add rust-prost-derive-0.12.
gnu: Add rust-prost-0.12.
gnu: Add rust-prost-types-0.12.
gnu: Add rust-prost-build-0.12.
gnu: Add rust-tonic-build-0.10.
gnu: Add rust-tonic-0.10.
gnu: Add rust-nftables-0.3.
gnu: Add rust-netlink-sys-0.8.
gnu: Add rust-netlink-packet-utils-0.5.
gnu: Add rust-netlink-packet-core-0.7.
gnu: Add rust-netlink-packet-generic-0.3.
gnu: Add rust-netlink-packet-route-0.18.
gnu: Add rust-netlink-packet-route-0.19.
gnu: Add rust-netlink-proto-0.11.
gnu: Add rust-genetlink-0.2.
gnu: Add rust-mptcp-pm-0.1.
gnu: Add rust-rtnetlink-0.14.
gnu: Add rust-ethtool-0.2.
gnu: Add rust-nispor-1.
gnu: Add rust-etherparse-0.13.
gnu: Add rust-dhcproto-macros-0.1.
gnu: Add rust-dhcproto-0.9.
gnu: Add rust-mozim-0.2.
gnu: Add rust-iptables-0.5.
gnu: Add rust-env-filter-0.1.
gnu: rust-anstyle-1: Update to 1.0.6.
gnu: Add rust-env-logger-0.11.
gnu: rust-rkyv-derive-0.7: Update to 0.7.44.
gnu: rust-rkyv-0.7: Update to 0.7.44.
gnu: Add rust-pure-rust-locales-0.8.
gnu: Add rust-windows-metadata-0.52.
gnu: Add rust-windows-bindgen-0.52.
gnu: rust-chrono-0.4: Update to 0.4.34.
gnu: Add netavark.

doc/guix.texi | 4 +-
gnu/packages/crates-io.scm | 881 +++++++++++++++++++++++++++++++-
gnu/packages/crates-web.scm | 218 ++++++++
gnu/packages/crates-windows.scm | 41 ++
gnu/packages/rust-apps.scm | 57 +++
guix/build-system/cargo.scm | 17 +-
6 files changed, 1194 insertions(+), 24 deletions(-)


base-commit: c5a716a965ca8881a9fb150c2cee8da4c1e62d10
--
2.41.0
Tomas Volf wrote 1 years ago
control message for bug #69169
(address . control@debbugs.gnu.org)
16db24e96692f6d6f8fc2335c527dd52@wolfsden.cz
close 69169
quit
Efraim Flashner wrote 1 years ago
Re: [bug#69170] [PATCH rust-team 00/46] Add netavark
(name . Tomas Volf)(address . ~@wolfsden.cz)
ZdH6e8kq4U0o_-iK@3900XT
I pushed the patches to the rust-team branch without the change for
cargo-native-inputs and without the snippet for prost-build. I also
adjusted some of the patches so that the packages built.

On Thu, Feb 15, 2024 at 09:25:48PM +0100, Tomas Volf wrote:
Toggle quote (70 lines)
> This series adds netavark, which will be required for next major version of
> podman.
>
> It also adds new #:cargo-native-inputs argument to the build system in order
> to support crates that call native tooling during a build (prost-build)
> without the need to have (native-inputs) on all user.
>
> Tomas Volf (46):
> build-system: cargo: Add #:cargo-native-inputs argument.
> gnu: Add rust-pulldown-cmark-to-cmark-10.
> gnu: Add rust-sync-wrapper-0.1.
> gnu: Add rust-multer-2.
> gnu: Add rust-iri-string-0.7.
> gnu: Add rust-tower-http-0.4.
> gnu: Add rust-axum-macros-0.3.
> gnu: Add rust-axum-core-0.3.
> gnu: Add rust-axum-0.6.
> gnu: rust-async-stream-impl-0.3: Update to 0.3.5.
> gnu: rust-async-stream-0.3: Update to 0.3.5.
> gnu: Add rust-sysctl-0.5.
> gnu: Add rust-prost-derive-0.12.
> gnu: Add rust-prost-0.12.
> gnu: Add rust-prost-types-0.12.
> gnu: Add rust-prost-build-0.12.
> gnu: Add rust-tonic-build-0.10.
> gnu: Add rust-tonic-0.10.
> gnu: Add rust-nftables-0.3.
> gnu: Add rust-netlink-sys-0.8.
> gnu: Add rust-netlink-packet-utils-0.5.
> gnu: Add rust-netlink-packet-core-0.7.
> gnu: Add rust-netlink-packet-generic-0.3.
> gnu: Add rust-netlink-packet-route-0.18.
> gnu: Add rust-netlink-packet-route-0.19.
> gnu: Add rust-netlink-proto-0.11.
> gnu: Add rust-genetlink-0.2.
> gnu: Add rust-mptcp-pm-0.1.
> gnu: Add rust-rtnetlink-0.14.
> gnu: Add rust-ethtool-0.2.
> gnu: Add rust-nispor-1.
> gnu: Add rust-etherparse-0.13.
> gnu: Add rust-dhcproto-macros-0.1.
> gnu: Add rust-dhcproto-0.9.
> gnu: Add rust-mozim-0.2.
> gnu: Add rust-iptables-0.5.
> gnu: Add rust-env-filter-0.1.
> gnu: rust-anstyle-1: Update to 1.0.6.
> gnu: Add rust-env-logger-0.11.
> gnu: rust-rkyv-derive-0.7: Update to 0.7.44.
> gnu: rust-rkyv-0.7: Update to 0.7.44.
> gnu: Add rust-pure-rust-locales-0.8.
> gnu: Add rust-windows-metadata-0.52.
> gnu: Add rust-windows-bindgen-0.52.
> gnu: rust-chrono-0.4: Update to 0.4.34.
> gnu: Add netavark.
>
> doc/guix.texi | 4 +-
> gnu/packages/crates-io.scm | 881 +++++++++++++++++++++++++++++++-
> gnu/packages/crates-web.scm | 218 ++++++++
> gnu/packages/crates-windows.scm | 41 ++
> gnu/packages/rust-apps.scm | 57 +++
> guix/build-system/cargo.scm | 17 +-
> 6 files changed, 1194 insertions(+), 24 deletions(-)
>
>
> base-commit: c5a716a965ca8881a9fb150c2cee8da4c1e62d10
> --
> 2.41.0
>
>

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmXR+ngACgkQQarn3Mo9
g1EimQ//XfxTQDOjMgXi6PhrCOyGdpe1aNJiRD0onToqmyNaA5DIYmPwbL7TD8vT
KGcwEzgi1x9JA39NjsaGGQeL2fD9DXV4Oi6ArIMA7LfhIGUImqa82W3o8nDfR4Ma
3LAQ5PfOVMVh4JnO45dmLhmNCbZD88lB6X3mu8HHpMFhsO+KQRAH7Ipo1HxYAZUy
NbJpNAQz4t4w1//ae1x8JvHKGGDWqCqhHAnmTBbwUXnmA+V32E7PY6wCOhnMt4hD
STXl7YK8S9N7w5eAGnSJazp54aOpHM4EIjfOcuF2nWezzEsYehCsoC3jdIZPCHXh
hlQDTJSsFPRYTclLWRk5Vlo+fqmPxp6QKdamrgtaro7SfIUXlIs7a+u4kA0KXNE5
DbVvHAY96Z9s8daKzL41hxRc3TD5EoB/YTbj51KiHKfYGX5D4o7c9yhfzWFyrbdj
3huzltEf6JDH2cffvFkU7yCmghB9rXf3K7RMwHY+eAruTRwTj2KctxV57ht2pLFY
dnMahzPbGthH+aW4DtWzC2ldkphIP9pD2VlGOPtXpT07I3dcNUiiGzy3ig9Xd6A+
oHguNfJiYgXo3cw6HBJzF0wFNt+PkT4fz8i/mFvr6muXvSws75CQ7mUqYxp8fdsj
WZI/jysbyW12bcxufNxOXeC+QErM3IlVM9TomjW4urg4ozsZZaw=
=9jrQ
-----END PGP SIGNATURE-----


Closed
Tomas Volf wrote 1 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
ZdIOXAXbLi7-6FiE@ws
On 2024-02-18 14:39:23 +0200, Efraim Flashner wrote:
Toggle quote (4 lines)
> I pushed the patches to the rust-team branch without the change for
> cargo-native-inputs and without the snippet for prost-build. I also
> adjusted some of the patches so that the packages built.

Well I am just happy it was merged, so no complains here, but I have to admit I
am curious. Is it really expected that every user of prost-build will need to
add protobuf into native-inputs?

What if, in some new version, it starts requiring some-other-package instead of
protobuf? All the downstream users will need to be adjusted as well. That
seems somewhat sub-optimal. So I am trying to understand the reasoning here.

Thanks and have a nice day,
Tomas Volf

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmXSDlwACgkQL7/ufbZ/
wal44xAAkFTukPCekWqFrn0N2dMZlD9hKvW1pF21IUsJpjUZuLsmDWl/tlaUhpOq
tOlXvN3WA+yCwC89vdpmgYySiQlOKmCiGfTG8Vb8itsBjL7c0r9og/azR1dyTKOm
4NYBhafR/ECySUxCPkXYKqzZ+5CUrRfNloQUeTFxHAvk5z0Fv0xBJW/ECu45ME6V
sDl++5W8z32RhoLnIrkGB4XHIOTnrQvWkseQt9gazbmgAuY8yh5MFJUiH8iDgE8W
84TrTWY5y8QM2EWKM+hCQY9RTye6QO6gxAjwGkAMKO07AFZ1aR7fj0ehFZNLYhBX
kVtIPQQgs5ldcKoJjQvLwjBjHbHfzdL9XZSY0j3bEELfMDbCE2th0ErDeqsZw48C
17GviUt50uCLMfG7jUtq6h45dTiZVg7d+cvmx/S098L2lbKJma77kKV1vJY+CDS9
P2aC8w8PnSXnTTRb/8G+uI66ljRNCSnEIaXwkTeZQWFokSAnnarmuu+zO4RRq2Qx
yKbEsCOKx2Hj2lDWJ/CDZ7+G/vjoDncfvD7cZJ3rl30zMhSG1LxV+tbD2TFQsac0
6N6LXUe1DVm7cdBEWh9D5qAgHdXhvnUmSG04h/DCZlxWIWhlMxsXgCuqgjWrOFoi
AfaFBiCqDgZvnI4PPos7RuKqKPWYZFDQk329Eq/T3dcT5DY9lBU=
=s2VG
-----END PGP SIGNATURE-----


Efraim Flashner wrote 1 years ago
(name . Tomas Volf)(address . ~@wolfsden.cz)
ZdRZvwsyr2DXgNdw@3900XT
On Sun, Feb 18, 2024 at 03:04:12PM +0100, Tomas Volf wrote:
Toggle quote (9 lines)
> On 2024-02-18 14:39:23 +0200, Efraim Flashner wrote:
> > I pushed the patches to the rust-team branch without the change for
> > cargo-native-inputs and without the snippet for prost-build. I also
> > adjusted some of the patches so that the packages built.
>
> Well I am just happy it was merged, so no complains here, but I have to admit I
> am curious. Is it really expected that every user of prost-build will need to
> add protobuf into native-inputs?

Only in situations where it is needed. In actuality we only needed it
in prost-build itself and in netavark.

Toggle quote (4 lines)
> What if, in some new version, it starts requiring some-other-package instead of
> protobuf? All the downstream users will need to be adjusted as well. That
> seems somewhat sub-optimal. So I am trying to understand the reasoning here.

The patch you sent hardcoded the path to protobuf into the source of
prost-build, which we try not to do. Also, using something like
cargo-native-inputs is (to me) a little "too magical" to make sure that
we have the required native-inputs in future builds. However! Don't let
me nay-say it, if you feel strongly about it then do continue to push
for it. Ideally we'd have a true graph of the dependencies among the
rust packages rather than cargo-inputs and cargo-development-inputs, but
we still don't have anything like the antioxidant-build-system yet.

Another package which had to have an included perl dependency everywhere
was the rust-ring packages. In the end I ended up going and rebuilding
nearly all the pre-generated files in the sources so that we would have
a ready-to-use source tarball without the need for perl everywhere.
Seeing that protobuf was only needed in these two packages I don't think
prost-build needs that currently, but it's also an option.

Toggle quote (9 lines)
> Thanks and have a nice day,
> Tomas Volf
>
> --
> There are only two hard things in Computer Science:
> cache invalidation, naming things and off-by-one errors.



--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmXUWb0ACgkQQarn3Mo9
g1HEshAAr/IVSYxWrdaQt3YQpibBL1rHSghteijZ0aijZviFUeFmZANfkBbQ9w2B
XLfThD8sZGPdzMa7DZOVlregtS/Kpy+qNgqst/9/3fMqS3JUSRRRYqt6ipp6UIML
MPpb+boP3PQkUu9nj5LvOohYooNWxUymIY3BoMdfGyCbwyNA0qJsuwohTMn9SCn/
0jZTNztfsBHCeod6b3VxD5i5DxWwj0wSsVgG8VHxMdSMy0hZZz7s+3WgNf8tJhQ0
OK1QZfyPeWknKwr1jV0eSkCDyQNF6Q1FCJYA0YKyurCTDhbdYx4WvC+6SelTr1mF
2nyJPBYTPz1mYMGluzgXFAf+4s8lXK3RguaQlXfY2HSMXe4RjxL3ILM8bMKaVwlM
WiB2A28jgZX5J1Dy0L8HIkkOZUO2z6WGjEYaRcKRuAzklIgr05ZGtbisJqxsnLgk
YKlQveJCTgpXls3UuC7mlaxODWKQDAFUhihYEuIIOHWWwoQCW2INQ101Y5u+C8rv
GHrwjx0QMwtOeAypE+gYIFq7X6UlR2vQlWGQo1dI8M+8I2ZwOgJCipPBbCtmMkAL
0jycmUNd+H7lcnSXqKujQ1chDsRsqW2wmIgNUGVhrX2zyaK1UM8dPn9ZXfwliCgw
ke0kgEuV1Vuaew4A7/Okco8k9Tf6yRJm61zZrS+EZjliRVi6EHk=
=vjmC
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 69169@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69169
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help