[PATCH 0/2] Fix random test failures and update leptonica

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal
A
A
Ahmad Draidi wrote on 15 Feb 13:44 +0100
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1708001019.git.a.r.draidi@redscript.org
Hello Guix,

This series fixes random test failures I observed while building leptonica,
and updates it to the latest version while we're at it.

I observed, on Debian and Guix (guix shell -D ...), that running the tests in
parallel (e.g. "make check -j16") fails sometimes. And building leptonica using
"guix build leptonica --check --rounds=10 --no-grafts" fails for me every
time. It doesn't fail anymore when disabling parallel tests.

This fixes #65441.

Ahmad Draidi (2):
gnu: leptonica: Fix random test failures.
gnu: leptonica: Update to 1.84.1.

gnu/packages/image.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: 06014750338159a03a6374d7ebdd783c210b3715
--
2.41.0
A
A
Ahmad Draidi wrote on 15 Feb 13:55 +0100
[PATCH 1/2] gnu: leptonica: Fix random test failures.
(address . 69166@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
ecfe6083e657a4074c9d746ddadde7c97b243344.1708001019.git.a.r.draidi@redscript.org

Running tests in parallel (e.g. "make check -j16") causes random test
failures. Same behavior observed on Debian.

* gnu/packages/image.scm (leptonica)[arguments]: Disable parallel tests.

Change-Id: I629c6c8be626a704be046dc79ea4480896cd11cc
---
gnu/packages/image.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1f434667f8..8ca928c616 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -779,6 +779,8 @@ (define-public leptonica
zlib))
(arguments
(list
+ ;; Parallel tests cause some tests to fail randomly. Same thing observed on Debian.
+ #:parallel-tests? #f
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-reg-wrapper
--
2.41.0
A
A
Ahmad Draidi wrote on 15 Feb 13:55 +0100
[PATCH 2/2] gnu: leptonica: Update to 1.84.1.
(address . 69166@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
32461fc92def1447c6091923aa15ebbe805a8ed4.1708001019.git.a.r.draidi@redscript.org
* gnu/packages/image.scm (leptonica): Update to 1.84.1.

Change-Id: I9070ca7f08c0c3114fa7a5a414695051b587f00b
---
gnu/packages/image.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 8ca928c616..4eeedeed59 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -752,7 +752,7 @@ (define-public libtiff
(define-public leptonica
(package
(name "leptonica")
- (version "1.83.1")
+ (version "1.84.1")
(source
(origin
(method git-fetch)
@@ -761,7 +761,7 @@ (define-public leptonica
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1j7qf9flb48q0aymf0yx9rypy3bs6hfjcln08zmy8qn2qcjzrmvi"))))
+ (base32 "0b4ikf1p2ll4310n4dg5lg0b79wys71fb6nj22i7pz17wjdma0j8"))))
(build-system gnu-build-system)
(native-inputs
(list gnuplot ;needed for test suite
--
2.41.0
G
G
Guillaume Le Vaillant wrote on 24 Feb 11:24 +0100
Re: [bug#69166] [PATCH 0/2] Fix random test failures and update leptonica
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 69166-done@debbugs.gnu.org)
87y1bajh0y.fsf@kitej
Patches applied as df5653adcbd1f9799f810f46d514b2ca4112af97 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZdnEDQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j++RgEAjAPAJBOvkVcgl0Tu31tM71vC0hsCPJawOM3m
ZU2GDKsBAJggS8J/dOH/UZ+t5mwEOqlabcbw8e+Wo6FegA6JVi2E
=w+OF
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69166@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69166
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch