[PATCH v2 13/23] gnu: Add ghc-nats-bootstrap-for-9.6

  • Done
  • quality assurance status badge
Details
One participant
  • Saku Laesvuori
Owner
unassigned
Submitted by
Saku Laesvuori
Severity
normal
Merged with
S
S
Saku Laesvuori wrote on 15 Feb 09:49 +0100
(name . Saku Laesvuori)(address . saku@laesvuori.fi)
d0a32bbcd0352a5c68b749f0d284e26bc4e5992e.1707827100.git.saku@laesvuori.fi
* gnu/packages/haskell.scm (ghc-nats-bootstrap-for-9.6): New variable.

Change-Id: I57351e88ba0bc52e7fd5fefc5c3006f63925fd86
---
gnu/packages/haskell.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 88c7278168..604b38cce6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1655,6 +1655,28 @@ (define ghc-random-bootstrap-for-9.6
library, including the ability to split random number generators.")
(license license:bsd-3)))
+(define ghc-nats-bootstrap-for-9.6
+ (package
+ (name "ghc-nats-bootstrap")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "nats" version))
+ (sha256
+ (base32
+ "1v40drmhixck3pz3mdfghamh73l4rp71mzcviipv1y8jhrfxilmr"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "nats")))
+ (arguments `(#:haddock? #f
+ #:haskell ,ghc-bootstrap-for-9.6))
+ (inputs
+ (list ghc-hashable-bootstrap-for-9.6))
+ (home-page "https://hackage.haskell.org/package/nats")
+ (synopsis "Natural numbers")
+ (description "This library provides the natural numbers for Haskell.")
+ (license license:bsd-3)))
+
(define ghc-js-dgtable-bootstrap-for-9.6
(package
(name "ghc-js-dgtable-bootstrap")
--
2.41.0
S
S
Saku Laesvuori wrote on 15 Feb 19:06 +0100
Closing accidental issues v2
(address . control@debbugs.gnu.org)
7tu3ticiwsglsw74rwk22ukyrc3erpafdhh6scbycgoeqsl6kq@nefea4eac2nd
reopen 69154
merge 69154 69142 69143 69144 69145 69146 69147 69148 69149 69150 69151 69152 69153 69155 69156 69157 69158 69159 69160 69161 69162 69163 69164 69165
close 69154
quit
?