[PATCH] gnu: vpn-slice: Fix substitution paths for "ip" and "iptables".

  • Open
  • quality assurance status badge
Details
One participant
  • Allan Adair
Owner
unassigned
Submitted by
Allan Adair
Severity
normal
A
A
Allan Adair wrote on 14 Feb 12:29 +0100
(address . guix-patches@gnu.org)(name . Allan Adair)(address . allan@adair.no)
49af58fd668de419521436b4c9e6e181be57d2dc.1707910165.git.allan@adair.no
vpn-slice expects commands "ip" and "iptables" to be found according to FHS
paths. A previous patch introduced an incorrect path for iptables because of
overlapping matches for "/sbin/ip" and "/sbin/iptables".

* gnu/packages/vpn.scm (vpn-slice)[arguments]: Fix substitution paths in
"vpn_slice/linux.py" for "ip" and "iptables" commands.

Change-Id: I68ffc002a3aa5ebcdff2fa6ecc64b6b1231a17e7
---
gnu/packages/vpn.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 7823ef19eb..758356f404 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1261,10 +1261,10 @@ (define-public vpn-slice
(add-after 'unpack 'patch-FHS-file-names
(lambda _
(substitute* "vpn_slice/linux.py"
- (("/sbin/iptables")
- (which "iptables"))
- (("/sbin/ip")
- (which "ip"))))))))
+ (("'/sbin/iptables'")
+ (string-append "'" (which "iptables") "'"))
+ (("'/sbin/ip'")
+ (string-append "'" (which "ip") "'"))))))))
(inputs (list python-dnspython python-setproctitle iproute iptables))
(home-page "https://github.com/dlenski/vpn-slice")
(synopsis "Split tunneling replacement for vpnc-script")

base-commit: 2ba2875dbda4b080fcad4e6d672bb4104d59dd0c
--
2.41.0
?