[PATCH] gnu: Add gsl-lite.

  • Open
  • quality assurance status badge
Details
One participant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 13 Feb 17:08 +0100
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
507f007a64c6d919adb902205ab5cdf4f4152dfb.1707840452.git.paul@apatience.com
* gnu/packages/cpp.scm (gsl-lite): New variable.

Change-Id: Ieabc719b09a3ef2d7eb89d3bacfdf8e873b2030c
---
gnu/packages/cpp.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 62a1923571..dd12a02859 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
-;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2023-2024 Paul A. Patience <paul@apatience.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -274,6 +274,30 @@ (define-public c++-gsl
(home-page "https://github.com/microsoft/GSL/")
(license license:expat)))
+(define-public gsl-lite
+ (package
+ (name "gsl-lite")
+ (version "0.41.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gsl-lite/gsl-lite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aj2ck2jdiy05f83bknjb9zjvsi766d11fv6flxm0v9ngp3s5svj"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DGSL_LITE_OPT_BUILD_TESTS=ON")))
+ (home-page "https://github.com/gsl-lite/gsl-lite")
+ (synopsis "Guidelines Support Library for C++98 and later")
+ (description "@i{gsl-lite} is a single-file header-only implementation of
+the C++ Core Guidelines Support Library, originally based on Microsoft GSL and
+adapted for C++98 and C++03. It is also compatible with C++11, C++14, C++17
+and C++20.")
+ (license license:expat)))
+
(define-public c2ffi
(package
(name "c2ffi")

base-commit: 570ef13a87bb54d3410c431700ba78316a2641e2
--
2.41.0
?