Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
Since upstream does provide properly packaged source archives, the fetch
method was switched from git to url.
* gnu/packages/containers.scm (crun): Update to 1.14.1.
Change-Id: I566d8742b1a3db75aefaa51032e09130a8307a61
---
gnu/packages/containers.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a3aa9ac1db..e9d2b0f71a 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -53,20 +53,20 @@ (define-module (gnu packages containers)
#:use-module (gnu packages wget))
(define-public crun
- (let ((commit "c381048530aa750495cf502ddb7181f2ded5b400"))
+ (let ((commit "de537a7965bfbe9992e2cfae0baeb56a08128171"))
(package
(name "crun")
- (version "1.4.5")
+ (version "1.14.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/containers/crun")
- (commit commit)
- (recursive? #t)))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/containers/crun/releases/download/"
+ version
+ "/crun-" version ".tar.gz"))
(sha256
- (base32 "0x2xmr5sv9ivvcv5fl5jjk4kq9b3n97s5hsqiqfwl4rz8qcz4xk1"))
- (file-name (git-file-name name version))))
+ (base32
+ "02lplc2asyllb58mvy7l8b9gsk7fxs95g928xk28yzmf592ay33x"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-systemd")
base-commit: e257de4365b24a84f39813aea2e8b4ab6259f283
--
2.41.0