Simon South wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/embedded.scm (sdcc): Update to 4.4.0.
* gnu/packages/patches/sdcc-disable-non-free-code.patch: Update to match new
version.
Change-Id: Ie35c590a7f3004bc9f081d99b7ce019ac66cf3c0
---
gnu/packages/embedded.scm | 4 +-
.../patches/sdcc-disable-non-free-code.patch | 244 +++++++++---------
2 files changed, 124 insertions(+), 124 deletions(-)
Toggle diff (452 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 313675814a..b758e445af 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1637,7 +1637,7 @@ (define-public ucsim
(define-public sdcc
(package
(name "sdcc")
- (version "4.3.0")
+ (version "4.4.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1645,7 +1645,7 @@ (define-public sdcc
"/" version "/sdcc-src-" version ".tar.bz2"))
(sha256
(base32
- "1kckr20jqa4rp4qcw38lwagmw3yfm3z0xb4kygd0608847qc0vra"))
+ "0xbaj3vx5cp3na1kmyhy4jvhcqwrg648scjbykgq0xmibqb1535f"))
(modules '((guix build utils)))
(snippet
#~(begin
diff --git a/gnu/packages/patches/sdcc-disable-non-free-code.patch b/gnu/packages/patches/sdcc-disable-non-free-code.patch
index 7602ead9af..6dcfbee1ab 100644
--- a/gnu/packages/patches/sdcc-disable-non-free-code.patch
+++ b/gnu/packages/patches/sdcc-disable-non-free-code.patch
@@ -15,10 +15,10 @@ remove instructions that encourage the use of SDCC with non-free
software.
diff --git a/Makefile.common.in b/Makefile.common.in
-index 9cd116c..6bbe9fb 100644
+index 8469079..174ed91 100644
--- a/Makefile.common.in
+++ b/Makefile.common.in
-@@ -77,7 +77,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
+@@ -78,7 +78,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
OPT_DISABLE_SDBINUTILS = @OPT_DISABLE_SDBINUTILS@
OPT_DISABLE_SDCPP = @OPT_DISABLE_SDCPP@
OPT_DISABLE_UCSIM = @OPT_DISABLE_UCSIM@
@@ -27,10 +27,10 @@ index 9cd116c..6bbe9fb 100644
SLIB = $(top_builddir)/support/util
diff --git a/Makefile.in b/Makefile.in
-index 6d035ec..12f1fad 100644
+index 3287e30..69511e1 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -105,9 +105,6 @@ endif
+@@ -104,9 +104,6 @@ endif
ifeq ($(OPT_DISABLE_DEVICE_LIB), 0)
TARGETS += sdcc-device-lib
PKGS += device/lib
@@ -40,7 +40,7 @@ index 6d035ec..12f1fad 100644
endif
ifeq ($(OPT_DISABLE_PACKIHX), 0)
-@@ -128,9 +125,6 @@ endif
+@@ -127,9 +124,6 @@ endif
TARGETS += sdcc-libs sdcc-cc sdcc-device-inc sdcc-as sdcc-ld sdcc-scripts
PKGS += $(SDCC_LIBS) src device/include
@@ -50,7 +50,7 @@ index 6d035ec..12f1fad 100644
PKGS += $(SDCC_AS) sdas/linksrc $(SDCC_SCRIPTS)
PORTS = $(shell cat ports.build)
-@@ -168,21 +162,12 @@ sdcc-sdbinutils:
+@@ -167,21 +161,12 @@ sdcc-sdbinutils:
sdcc-device-inc:
$(MAKE) -C device/include
@@ -73,7 +73,7 @@ index 6d035ec..12f1fad 100644
# doc depends on latex and latex2html
diff --git a/configure b/configure
-index 9de81c6..2620e3c 100755
+index b509c84..c7ce7fc 100755
--- a/configure
+++ b/configure
@@ -659,7 +659,6 @@ LATEX
@@ -84,7 +84,7 @@ index 9de81c6..2620e3c 100755
OPT_DISABLE_SDBINUTILS
OPT_DISABLE_SDCDB
OPT_DISABLE_SDCPP
-@@ -692,10 +691,7 @@ OPT_DISABLE_Z80
+@@ -693,10 +692,7 @@ OPT_DISABLE_Z80
OPT_DISABLE_MCS51
SVN_REVISION
GIT_REVISION
@@ -95,7 +95,7 @@ index 9de81c6..2620e3c 100755
include_dir_suffix
inclib_dir_suffix
LIB_TYPE
-@@ -824,7 +820,6 @@ enable_packihx
+@@ -828,7 +824,6 @@ enable_packihx
enable_sdcpp
enable_sdcdb
enable_sdbinutils
@@ -103,7 +103,7 @@ index 9de81c6..2620e3c 100755
enable_doc
enable_libgc
'
-@@ -845,10 +840,7 @@ sdccconf_h_dir_separator
+@@ -849,10 +844,7 @@ sdccconf_h_dir_separator
LIB_TYPE
inclib_dir_suffix
include_dir_suffix
@@ -114,7 +114,7 @@ index 9de81c6..2620e3c 100755
docdir'
ac_subdirs_all='support/cpp
support/packihx
-@@ -856,9 +848,7 @@ sim/ucsim
+@@ -860,9 +852,7 @@ sim/ucsim
debugger/mcs51
support/sdbinutils
device/lib/pic14
@@ -125,7 +125,7 @@ index 9de81c6..2620e3c 100755
# Initialize some variables set by options.
ac_init_help=
-@@ -1512,7 +1502,6 @@ Optional Features:
+@@ -1517,7 +1507,6 @@ Optional Features:
--disable-sdcpp Disables building sdcpp
--disable-sdcdb Disables building sdcdb
--disable-sdbinutils Disables configuring and building of sdbinutils
@@ -133,7 +133,7 @@ index 9de81c6..2620e3c 100755
--enable-doc Enables building the documentation
--enable-libgc Use the Bohem memory allocator. Lower runtime
footprint.
-@@ -1541,16 +1530,8 @@ Some influential environment variables:
+@@ -1551,16 +1540,8 @@ Some influential environment variables:
appended to datadir to define SDCC's include/lib directory
include_dir_suffix
appended to datadir to define SDCC's include directory
@@ -150,7 +150,7 @@ index 9de81c6..2620e3c 100755
docdir documentation installation directory
Use these variables to override the choices made by `configure' or to help
-@@ -7426,19 +7407,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -7869,19 +7850,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -170,7 +170,7 @@ index 9de81c6..2620e3c 100755
# lib_dir_suffix:
# *nix default: "sdcc/lib"
-@@ -7446,13 +7414,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -7889,13 +7857,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -184,7 +184,7 @@ index 9de81c6..2620e3c 100755
# docdir:
# *nix default: "${datadir}/sdcc/doc"
-@@ -7605,22 +7566,6 @@ esac
+@@ -8048,22 +8009,6 @@ esac
printf "%s\n" "#define INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_inc_dir_suffix}\"" >>confdefs.h
@@ -207,7 +207,7 @@ index 9de81c6..2620e3c 100755
norm_lib_dir_suffix=${lib_dir_suffix}
case ":$norm_lib_dir_suffix:" in
-@@ -7638,22 +7583,6 @@ esac
+@@ -8081,22 +8026,6 @@ esac
printf "%s\n" "#define LIB_DIR_SUFFIX DIR_SEPARATOR_STRING \"${norm_lib_dir_suffix}\"" >>confdefs.h
@@ -230,7 +230,7 @@ index 9de81c6..2620e3c 100755
# relative paths
for _lcl_i in expanded_bindir:expanded_datadir:bin2data_dir; do
-@@ -8769,27 +8698,6 @@ printf "%s\n" "#define OPT_DISABLE_SDBINUTILS $OPT_DISABLE_SDBINUTILS" >>confdef
+@@ -9237,27 +9166,6 @@ printf "%s\n" "#define OPT_DISABLE_SDBINUTILS $OPT_DISABLE_SDBINUTILS" >>confdef
@@ -258,7 +258,7 @@ index 9de81c6..2620e3c 100755
# Check whether --enable-doc was given.
if test ${enable_doc+y}
-@@ -9217,20 +9125,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -9685,20 +9593,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
test $OPT_DISABLE_DEVICE_LIB = 0 && subdirs="$subdirs device/lib/pic14"
@@ -278,8 +278,8 @@ index 9de81c6..2620e3c 100755
-
fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
-@@ -9307,8 +9207,6 @@ fi
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0 || test $OPT_DISABLE_R800 = 0; then
+@@ -9775,8 +9675,6 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && ac_config_files="$ac_config_files device/lib/Makefile"
@@ -288,7 +288,7 @@ index 9de81c6..2620e3c 100755
ac_config_files="$ac_config_files main.mk:main_in.mk bin/Makefile src/Makefile device/include/Makefile sdas/linksrc/Makefile support/makebin/Makefile support/regression/Makefile support/regression/cases/Makefile support/valdiag/Makefile support/scripts/Makefile support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in Makefile Makefile.common:Makefile.common.in"
-@@ -9324,10 +9222,6 @@ ac_config_files="$ac_config_files bin/sdranlib"
+@@ -9792,10 +9690,6 @@ ac_config_files="$ac_config_files bin/sdranlib"
ac_config_files="$ac_config_files bin/sdobjcopy"
@@ -299,7 +299,7 @@ index 9de81c6..2620e3c 100755
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
-@@ -10068,7 +9962,6 @@ do
+@@ -10538,7 +10432,6 @@ do
"device/lib/pdk15-stack-auto/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/pdk15-stack-auto/Makefile" ;;
"sdas/aspdk16/Makefile") CONFIG_FILES="$CONFIG_FILES sdas/aspdk16/Makefile" ;;
"device/lib/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/Makefile" ;;
@@ -307,7 +307,7 @@ index 9de81c6..2620e3c 100755
"main.mk") CONFIG_FILES="$CONFIG_FILES main.mk:main_in.mk" ;;
"bin/Makefile") CONFIG_FILES="$CONFIG_FILES bin/Makefile" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
-@@ -10088,7 +9981,6 @@ do
+@@ -10558,7 +10451,6 @@ do
"bin/sdnm") CONFIG_FILES="$CONFIG_FILES bin/sdnm" ;;
"bin/sdranlib") CONFIG_FILES="$CONFIG_FILES bin/sdranlib" ;;
"bin/sdobjcopy") CONFIG_FILES="$CONFIG_FILES bin/sdobjcopy" ;;
@@ -315,7 +315,7 @@ index 9de81c6..2620e3c 100755
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac
-@@ -10905,54 +10797,6 @@ esac
+@@ -11375,54 +11267,6 @@ esac
incPath3=`echo "$incPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -370,7 +370,7 @@ index 9de81c6..2620e3c 100755
libPath1=`echo "/${prefix2data_dir}/${norm_lib_dir_suffix}" | sed 's,/\./,/,g'`
case ":$libPath1:" in
-@@ -11002,54 +10846,6 @@ esac
+@@ -11472,54 +11316,6 @@ esac
libPath3=`echo "$libPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -425,7 +425,7 @@ index 9de81c6..2620e3c 100755
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result:
sdcc ${VERSION} is now configured for
-@@ -11091,7 +10887,6 @@ sdcc ${VERSION} is now configured for
+@@ -11562,7 +11358,6 @@ sdcc ${VERSION} is now configured for
mos6502 ${enable_mos6502_port}
mos65c02 ${enable_mos65c02_port}
@@ -433,7 +433,7 @@ index 9de81c6..2620e3c 100755
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -11106,9 +10901,6 @@ sdcc ${VERSION} is now configured for
+@@ -11577,9 +11372,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -443,7 +443,7 @@ index 9de81c6..2620e3c 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -11120,15 +10912,9 @@ sdcc ${VERSION} is now configured for
+@@ -11591,15 +11383,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -459,7 +459,7 @@ index 9de81c6..2620e3c 100755
" >&5
printf "%s\n" "
sdcc ${VERSION} is now configured for
-@@ -11171,7 +10957,6 @@ sdcc ${VERSION} is now configured for
+@@ -11643,7 +11429,6 @@ sdcc ${VERSION} is now configured for
mos6502 ${enable_mos6502_port}
mos65c02 ${enable_mos65c02_port}
@@ -467,7 +467,7 @@ index 9de81c6..2620e3c 100755
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -11186,9 +10971,6 @@ sdcc ${VERSION} is now configured for
+@@ -11658,9 +11443,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -477,7 +477,7 @@ index 9de81c6..2620e3c 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -11200,15 +10982,9 @@ sdcc ${VERSION} is now configured for
+@@ -11672,15 +11454,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -494,10 +494,10 @@ index 9de81c6..2620e3c 100755
# End of configure/configure.in
diff --git a/configure.ac b/configure.ac
-index ead779c..a3578fe 100644
+index adf5060..bd5a036 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -564,19 +564,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -542,19 +542,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -517,7 +517,7 @@ index ead779c..a3578fe 100644
# lib_dir_suffix:
# *nix default: "sdcc/lib"
AC_ARG_VAR([lib_dir_suffix], [appended to datadir to define SDCC's library root directory])
-@@ -584,13 +571,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -562,13 +549,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -531,7 +531,7 @@ index ead779c..a3578fe 100644
# docdir:
# *nix default: "${datadir}/sdcc/doc"
AC_ARG_VAR([docdir], [documentation installation directory])
-@@ -631,19 +611,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
+@@ -609,19 +589,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
adl_NORMALIZE_PATH([norm_inc_dir_suffix], [$sdccconf_h_dir_separator])
AC_DEFINE_UNQUOTED(INCLUDE_DIR_SUFFIX,
DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}", [XXX])
@@ -551,7 +551,7 @@ index ead779c..a3578fe 100644
# relative paths
adl_COMPUTE_RELATIVE_PATHS([expanded_bindir:expanded_datadir:bin2data_dir])
-@@ -836,7 +808,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
+@@ -815,7 +787,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
AC_DO_DISABLER(sdcpp, SDCPP, [Disables building sdcpp])
AC_DO_DISABLER(sdcdb, SDCDB, [Disables building sdcdb])
AC_DO_DISABLER(sdbinutils, SDBINUTILS, [Disables configuring and building of sdbinutils])
@@ -559,7 +559,7 @@ index ead779c..a3578fe 100644
AC_DO_ENABLER(doc, DOC, [Enables building the documentation])
AC_CHECK_PROG([LYX], [lyx], [lyx], [:])
-@@ -915,16 +886,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -895,16 +866,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
AC_CONFIG_FILES(src/pic14/Makefile)
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/lib/pic14)
fi
@@ -574,9 +574,9 @@ index ead779c..a3578fe 100644
- test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/non-free/lib/pic16)
-fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0; then
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R2KA = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_SM83 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0 || test $OPT_DISABLE_Z80N = 0 || test $OPT_DISABLE_R800 = 0; then
AC_CONFIG_FILES([src/z80/Makefile])
-@@ -988,7 +953,6 @@ fi
+@@ -969,7 +934,6 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/Makefile])
@@ -584,7 +584,7 @@ index ead779c..a3578fe 100644
AC_CONFIG_FILES([main.mk:main_in.mk
bin/Makefile
-@@ -1010,9 +974,6 @@ AC_CONFIG_FILES([bin/sdar], [chmod +x bin/sdar])
+@@ -991,9 +955,6 @@ AC_CONFIG_FILES([bin/sdar], [chmod +x bin/sdar])
AC_CONFIG_FILES([bin/sdnm], [chmod +x bin/sdnm])
AC_CONFIG_FILES([bin/sdranlib], [chmod +x bin/sdranlib])
AC_CONFIG_FILES([bin/sdobjcopy], [chmod +x bin/sdobjcopy])
@@ -594,7 +594,7 @@ index ead779c..a3578fe 100644
AC_OUTPUT
# I found no better place
-@@ -1030,16 +991,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
+@@ -1011,16 +972,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
adl_NORMALIZE_PATH_MSG(/${prefix2data_dir}/${norm_inc_dir_suffix}, [incPath1], [$dirch])
adl_NORMALIZE_PATH_MSG(/${bin2data_dir}/${norm_inc_dir_suffix}, [incPath2], [$dirch])
adl_NORMALIZE_PATH_MSG(${expanded_datadir}/${norm_inc_dir_suffix}, [incPath3], [$dirch])
@@ -611,7 +611,7 @@ index ead779c..a3578fe 100644
AC_MSG_RESULT([
sdcc ${VERSION} is now configured for
-@@ -1082,7 +1037,6 @@ sdcc ${VERSION} is now configured for
+@@ -1064,7 +1019,6 @@ sdcc ${VERSION} is now configured for
mos6502 ${enable_mos6502_port}
mos65c02 ${enable_mos65c02_port}
@@ -619,7 +619,7 @@ index ead779c..a3578fe 100644
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -1097,9 +1051,6 @@ sdcc ${VERSION} is now configured for
+@@ -1079,9 +1033,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -629,7 +629,7 @@ index ead779c..a3578fe 100644
documentation: ${docdir}
prefix: ${prefix}
-@@ -1111,14 +1062,8 @@ sdcc ${VERSION} is now configured for
+@@ -1093,14 +1044,8 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[[0]])${incPath2}
${incPath3}
@@ -1003,7 +1003,7 @@ index db0d421..9e90d7a 100644
.SUFFIXES:
diff --git a/device/lib/pic16/libc/Makefile.in b/device/lib/pic16/libc/Makefile.in
-index ae76fdd..75fc04a 100644
+index 74147d2..bed548b 100644
--- a/device/lib/pic16/libc/Makefile.in
+++ b/device/lib/pic16/libc/Makefile.in
@@ -88,10 +88,7 @@ PRE_UNINSTALL = :
@@ -1018,7 +1018,7 @@ index ae76fdd..75fc04a 100644
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
DIST_COMMON = $(srcdir)/Makefile.am $(am__DIST_COMMON)
-@@ -383,8 +380,7 @@ libc18f_a_SOURCES = ctype/iscntrl.c ctype/isdigit.c ctype/isgraph.c \
+@@ -384,8 +381,7 @@ libc18f_a_SOURCES = ctype/iscntrl.c ctype/isdigit.c ctype/isgraph.c \
string/strpbrk.c string/strrchr.c string/strspn.c \
string/strstr.c string/strtok.c string/strupr.c \
utils/cnvfrac.S utils/cnvint.S utils/cvtdec.S
@@ -1028,7 +1028,7 @@ index ae76fdd..75fc04a 100644
#AM_CFLAGS += --no-optimize-goto
#AM_CFLAGS += --debug-ralloc
-@@ -398,11 +394,10 @@ AM_CPPFLAGS = -I. -I$(top_srcdir)/../../include/pic16 \
+@@ -399,11 +395,10 @@ AM_CPPFLAGS = -I. -I$(top_srcdir)/../../include/pic16 \
#AM_CFLAGS += --noinduction
#AM_CFLAGS += --nojtbound
#AM_CFLAGS += --noloopreverse
@@ -1248,7 +1248,7 @@ index 5c2fce7..8d70807 100644
.SUFFIXES:
diff --git a/doc/INSTALL.txt b/doc/INSTALL.txt
-index 3711c71..9e500a2 100644
+index 8dfadb6..dd17528 100644
--- a/doc/INSTALL.txt
+++ b/doc/INSTALL.txt
@@ -18,9 +18,7 @@ To install:
@@ -1282,7 +1282,7 @@ index 3711c71..9e500a2 100644
You can test the install by entering:
diff --git a/doc/README.txt b/doc/README.txt
-index cd1ef3f..5a0d0a8 100644
+index e62177b..4d09afb 100644
--- a/doc/README.txt
+++ b/doc/README.txt
@@ -37,10 +37,9 @@ Exception are pic device libraries and header files which are derived
@@ -1300,10 +1300,10 @@ index cd1ef3f..5a0d0a8 100644
However: Many think that the Microchip requirement is not legally enforceable,
arguing that the header files only contain noncopyrightable facts.
diff --git a/doc/sdccman.lyx b/doc/sdccman.l
This message was truncated. Download the full message here.