[PATCH] gnu: go-github-com-goccy-yaml: Remove benchmarks.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 11 Feb 11:44 +0100
(address . guix-patches@gnu.org)
87r0hj9t1g.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-goccy-yaml)[source]: Remove benchmarks.
---
gnu/packages/golang.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..6084175e88 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9626,7 +9626,9 @@ (define-public go-github-com-goccy-yaml
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
+ (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "benchmarks"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/goccy/go-yaml"))

base-commit: 9edbb2d7a40c9da7583a1046e39b87633459f656
--
2.42.0
T
T
Troy Figiel wrote on 11 Feb 11:44 +0100
[PATCH v2] gnu: go-github-com-goccy-yaml: Remove benchmarks.
(address . 69046@debbugs.gnu.org)
871q9hcrh4.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-goccy-yaml): Remove benchmarks.
[arguments]<#:phases>: Add remove-benchmarks phase.
---
gnu/packages/golang.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..42450fbc4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9629,7 +9629,13 @@ (define-public go-github-com-goccy-yaml
(base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/goccy/go-yaml"))
+ (list
+ #:import-path "github.com/goccy/go-yaml"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmarks")))))))
(propagated-inputs
(list go-github-com-fatih-color go-golang-org-x-xerrors))
(native-inputs

base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
--
2.42.0
S
S
Sharlatan Hellseher wrote on 13 Feb 22:38 +0100
[PATCH] gnu: go-github-com-goccy-yaml: Remove benchmarks.
(address . 69046-done@debbugs.gnu.org)
87bk8koxih.fsf@gmail.com
Hi,

Pushed as 0f19437ab8c1c4b6e26cdd78ba89f1a0cd18b86b to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXL4VYACgkQdtcnv/Ys
0rWGZBAAmnZBkJyt7hAGUOXw8QOlaNH9ux3oIOKIKwDLSQywfWT750E8xVRsMyqb
HTRhK9q9RL+fRqhSzYa3TpL8vs4q+8KjHuB4VMFJSZscc+i6SG6cBYp7l+HlVRES
TrLnIBlgX1Ls3ieAq79a30/IgeOzMFzSDms+mn7G6KEWuMsV7y9mensZ5lvzJh6v
vQvX0N0z4jh7P7XrM68APRGWARGWwsGuVliKOBux9nBD5ISEcIeWW4PbbE8uZPFi
Nw2K/BbdXsaalyT+ASnI8OeXx/JujTSNaE5Lbx7WTgHPTkLFGvKoFROXTfxbdqfB
FRE3EJccSqPr9+00EpHjZFGK/V/5PaTnbBZCjPdi8pukYnPqpbMqpSOMxBgBqrjE
h/tlfwEUpJf1dFl5Vkeuqv6wl8RCfLmSIynfhadoNMiMiNveXjoJUYPU/0aSUtqc
WaYZNQ98X9lr1WrmYH5vMrIKQhQrJU7EkSFUUB+EVqyjJrbLYwikVqe8NoxPJiKh
s4Okh945QSXBvMefr/jWaETA1eH2KD5MZxT9rzMuqh4vI8mMPsjKavqe2/zIjQ1C
rAQc57JT/wYHU9BrultVpEFIIvX5biaSgd+rPMFmurDVtcWT/sA1getRKG8Dkut3
0Xsnc+jArtQLAI7k0YOiNYvIUJcoXZj3BbZXLmLD6cKhZ2Q0iTg=
=8Afv
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69046@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69046
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch