[PATCH] gnu: go-github-com-avast-retry-go: Remove examples.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 11 Feb 12:03 +0100
(address . guix-patches@gnu.org)
87plx39s11.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-avast-retry-go)[source]: Remove examples.
---
gnu/packages/golang.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..888dacde2e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1259,7 +1259,9 @@ (define-public go-github-com-avast-retry-go
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
+ (base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "examples"))))
(build-system go-build-system)
(arguments `(#:import-path "github.com/avast/retry-go"))
(propagated-inputs (list go-github-com-stretchr-testify))

base-commit: b6439fc5f800b5d22d48192bc347be794f050329
--
2.42.0
T
T
Troy Figiel wrote on 11 Feb 12:03 +0100
[PATCH v2] gnu: go-github-com-avast-retry-go: Remove examples.
(address . 69045@debbugs.gnu.org)
8734txcrwk.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-avast-retry-go): Remove examples.
[arguments]<#:phases>: Add remove-examples phase.
---
gnu/packages/golang.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..7a89afb27a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1261,7 +1261,14 @@ (define-public go-github-com-avast-retry-go
(sha256
(base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
(build-system go-build-system)
- (arguments `(#:import-path "github.com/avast/retry-go"))
+ (arguments
+ (list
+ #:import-path "github.com/avast/retry-go"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
(propagated-inputs (list go-github-com-stretchr-testify))
(home-page "https://github.com/avast/retry-go")
(synopsis "Simple golang library for retry mechanism")

base-commit: 16d2be641424815a1779119bb64bc6ba1be1161b
--
2.42.0
S
S
Sharlatan Hellseher wrote on 13 Feb 22:39 +0100
[PATCH] gnu: go-github-com-avast-retry-go: Remove examples.
(address . 69045-done@debbugs.gnu.org)
878r3ooxgu.fsf@gmail.com
Hi,

Pushed as 2525b168f98066c1400783c1f350c90ec1259a76 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXL4ZEACgkQdtcnv/Ys
0rWWlA//dsALNARoIHgMQfyPro2RJOfI/h7nypu+o5sdNzT/4zTyMENAtCtCtYOg
Tyl/2myNuCrIMkfTLjGal5T1CPF+r/zTNLSYEveT5t1KwAtHC6xGdOTYLSwlfy0W
yttOUDgy/g31177EWauJ6SNwJH/NJ/k4d0yz4xBRZ8uRtLYB/MfeV1sHCE4VqYCd
/Lp2e+QG7TD1jMGcCeYMYp6H91DrU/y8J+1FkTEv9MIqK6m4tk34M22Qha9+JBp3
EH71KuZJRcIHthNe2kYpW8wkyNEb82kYitxCsIWs8fUAvACoXpfnZahLKLDYJdwW
GzyIy1Vdcq6DIWjp+P9fi8YY3rzwIbsjmaPZ7EhudHqfLDniDKf3R+j0pQlNHms9
eL4lHG6Se5+u2kAQpBGblict54vRY1YUbFZCDtSTvXtOd74dKvrN3PWwH5mJx8Br
LEJzoQmdC2jF4UrCn2uysiAXFSCtymwPNQWmxpDJ2XXKwgD+g0c4qm6BX/585vCh
dbdllpbGZuUfZBHIfQKcj/FMpeg1dbwQLKjaIRplixzDVgQ8ASdV3RY0EZ0vG/gt
xD8mUqLVo0u3M9TMR0DceC4zCpLJeJDizrADMmT8xm6STKL+yn32muhKjLRfykvL
03heRrlSz94yB2O6WTlPMYQhTRS7DKKlpsLdsU3gkbRnZWQIbPw=
=o8Qs
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch