[PATCH] gnu: Add m8c.

  • Done
  • quality assurance status badge
Details
3 participants
  • Juliana Sims
  • Christopher Baines
  • Nicolas Graves
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 11 Feb 06:24 +0100
(address . guix-patches@gnu.org)(name . Juliana Sims)(address . juli@incana.org)
13eb74857c4ae1b1b610836972e7709e7fa4752d.1707629082.git.juli@incana.org
* gnu/packages/electronics.scm (m8c): New symbol.

Change-Id: Ibfc2e9364211e24c59d4d9015ab144f0c4ee972c
---

Hello,

This patch adds m8c, a GUI client for the M8 Headless firmware installed on a
standalone Teensy microcontroller. I've done all the regular stuff of linting,
styling, testing building on multiple platforms, and testing running the actual
software. Everything works!

Thanks,
Juli
gnu/packages/electronics.scm | 42 ++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 83a92abc4e..ff21ffe732 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -424,6 +425,47 @@ (define-public xoscope
(home-page "https://xoscope.sourceforge.net/")
(license license:gpl2+)))
+(define-public m8c
+ (package
+ (name "m8c")
+ (version "1.5.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/laamaa/m8c")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04rn7b18xy5z03mlsb55nm1kn1k0ynqycs0km9w1yzrlq6rwrcn5"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config))
+ (inputs (list libserialport
+ sdl2))
+ (home-page "https://github.com/laamaa/m8c")
+ (synopsis "Cross-platform M8 tracker headless client")
+ (description
+ "The @url{https://dirtywave.com/products/m8-tracker,Dirtywave M8 Tracker}
+is a portable sequencer and synthesizer, featuring 8 tracks of assignable
+instruments such as FM, waveform synthesis, virtual analog, sample playback, and
+MIDI output. It is powered by a @url{https://www.pjrc.com/teensy/,Teensy}
+micro-controller and inspired by the Gameboy tracker
+@url{https://www.littlesounddj.com/lsd/index.php,Little Sound DJ}. m8c is a
+client for @url{https://github.com/Dirtywave/M8HeadlessFirmware,M8 Headless}
+which allows one to install the M8 firmware on any Teensy.")
+ (license (list license:cc-by-sa3.0
+ license:expat
+ license:public-domain
+ license:zlib))))
+
(define-public minipro
;; Information needed to fix Makefile
(let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")

base-commit: 9edbb2d7a40c9da7583a1046e39b87633459f656
--
2.41.0
J
J
Juliana Sims wrote on 20 Apr 17:09 +0200
[PATCH v2] gnu: Add m8c.
(address . 69041@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
3c5a808e8410f3cd218ded2b70c4768781204dfa.1713625750.git.juli@incana.org
Hello,

Since initially submitting this patch, m8c has seen some updates. This new patch
updates the package to the most recent version.

Thanks,
Juli

* gnu/packages/electronics.scm (m8c): New symbol.

Change-Id: Ibfc2e9364211e24c59d4d9015ab144f0c4ee972c
---
gnu/packages/electronics.scm | 42 ++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index aaf762b02b..e1451538c3 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -424,6 +425,47 @@ (define-public xoscope
(home-page "https://xoscope.sourceforge.net/")
(license license:gpl2+)))
+(define-public m8c
+ (package
+ (name "m8c")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/laamaa/m8c")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wsknqgya2vkalbjq6rvmknsdk4lrqkn0z5rpjf4pd5vxgr8qryb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config))
+ (inputs (list libserialport
+ sdl2))
+ (home-page "https://github.com/laamaa/m8c")
+ (synopsis "Cross-platform M8 tracker headless client")
+ (description
+ "The @url{https://dirtywave.com/products/m8-tracker,Dirtywave M8 Tracker}
+is a portable sequencer and synthesizer, featuring 8 tracks of assignable
+instruments such as FM, waveform synthesis, virtual analog, sample playback, and
+MIDI output. It is powered by a @url{https://www.pjrc.com/teensy/,Teensy}
+micro-controller and inspired by the Gameboy tracker
+@url{https://www.littlesounddj.com/lsd/index.php,Little Sound DJ}. m8c is a
+client for @url{https://github.com/Dirtywave/M8HeadlessFirmware,M8 Headless}
+which allows one to install the M8 firmware on any Teensy.")
+ (license (list license:cc-by-sa3.0
+ license:expat
+ license:public-domain
+ license:zlib))))
+
(define-public minipro
;; Information needed to fix Makefile
(let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")

base-commit: 0f68306268773f0eaa4327e1f6fdcb39442e4a34
--
2.41.0
N
N
Nicolas Graves wrote on 10 May 12:46 +0200
QA review for 69041
87cypueyg1.fsf@ngraves.fr
user guix
usertag 69041 + reviewed-looks-good
thanks

Guix QA review form submission:
lint complains about possible update to 1.7.1, but that shouldn&apos;t hinder this patch from being merged.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions

--
Best regards,
Nicolas Graves
C
C
Christopher Baines wrote on 12 May 20:08 +0200
Re: [bug#69041] [PATCH v2] gnu: Add m8c.
(name . Juliana Sims)(address . juli@incana.org)(address . 69041-done@debbugs.gnu.org)
875xvi9a3d.fsf@cbaines.net
Juliana Sims via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (15 lines)
> Hello,
>
> Since initially submitting this patch, m8c has seen some updates. This new patch
> updates the package to the most recent version.
>
> Thanks,
> Juli
>
> * gnu/packages/electronics.scm (m8c): New symbol.
>
> Change-Id: Ibfc2e9364211e24c59d4d9015ab144f0c4ee972c
> ---
> gnu/packages/electronics.scm | 42 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)

Thanks, I've pushed this to master as
0eaae8e4d442b0337b62d38a0b20649fd5fbbc61.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZBBaZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdbLw//bYy0aEd9ZsgVx6bxVwUyGu9QmioLbH3y
O8QczZnxcQhhYkAnqxPtPnrCupeNflKLyhCBA5Kt8W8p5r0JCKCj7U0F4/hPsIPJ
Y27JMwELOgAuV7qU/YGH+ijfNrkDGB9WjR6jGZeEueMbTNxAGbmrfqgDCq9/64ZB
udGwXBZ47FsJdyvg0w6L7CvWfXjTDY0w2qtbeE1mwIFRccvAfFpnBq2qK6VOR+iY
1PDAUCoyQDxWtObU2MqO2Wmfe45wZOSPa8MT80Q7PtY3notefnqBr9MXYn4pCoy/
15bDReuskXofzIOclGpry7PrdJJvYkzRz4Ev/+gxpOiuS2V+0u7P80YRihdXFLFn
q31PixLw3nkEwHooXV7tiOvKtPzcJDnDRAm/CLpKYEsY9qxyUTWDcM4wjeNXzqWA
BJbqfBMhW3nFwpjNssqppNYPCm4H7/s6a/PsoeIarA41tkR6MeDkCfCWZYlHo9ei
q8nltHRtIebcYFUbnlTm+eD/U3NvjBsEqFHFLiD00p88o3ZTH52xGW2124ntXTRU
qkLpL+Ql0h8B2XGCwSi2ZRmfBIVuZUmmI9O4bf3tYiIrGfHV+h71PofLlGwtjDZp
BZHDmIp2aY+DUuqQ6pGC5mhWn4ZwAIWDBV9Q/PXOU/0LBsxzQVohRYwMYNrr8Fb8
v0Ivc/dunN0=
=WkSo
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69041@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69041
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch