[PATCH] gnu: httpie: Update to 3.2.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 11 Feb 05:35 +0100
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
ec36146d3f9fcbd36799ab81bc2f349742e71b02.1707012538.git.kiasoc5@disroot.org
* gnu/packages/python-web.scm (httpie): Update to 3.2.2.
[propagated-inputs]: Remove python-pysocks; add python-importlib-metadata, python-pip,
and python-setuptools.

Change-Id: If767947e836bdee6bf145fc5290113d79e99fe89
---
gnu/packages/python-web.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c0cc46e5f..2f2682bc78 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1280,28 +1280,30 @@ (define-public python-httplib2
(define-public httpie
(package
(name "httpie")
- (version "3.2.1")
+ (version "3.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
+ "140w4mr0w7scpf4j5qm4h475vbwrgxzkdwyygwcmql1r1cgngywb"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
'(#:tests? #f))
(propagated-inputs
- (list python-colorama
+ (list python-charset-normalizer
+ python-colorama
+ python-defusedxml
+ python-importlib-metadata
+ python-multidict
+ python-pip
python-pygments
python-requests
python-requests-toolbelt
- python-pysocks
- python-charset-normalizer
- python-defusedxml
python-rich
- python-multidict))
+ python-setuptools))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description

base-commit: f45d05133472a9da13eae20ba4a676c696682c90
--
2.41.0
J
J
John Kehayias wrote on 14 Feb 22:24 +0100
(name . kiasoc5)(address . kiasoc5@disroot.org)
87jzn6loxb.fsf@protonmail.com
On Sat, Feb 10, 2024 at 11:35 PM, kiasoc5 wrote:

Toggle quote (54 lines)
> * gnu/packages/python-web.scm (httpie): Update to 3.2.2.
> [propagated-inputs]: Remove python-pysocks; add python-importlib-metadata, python-pip,
> and python-setuptools.
>
> Change-Id: If767947e836bdee6bf145fc5290113d79e99fe89
> ---
> gnu/packages/python-web.scm | 16 +++++++++-------
> 1 file changed, 9 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 0c0cc46e5f..2f2682bc78 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -1280,28 +1280,30 @@ (define-public python-httplib2
> (define-public httpie
> (package
> (name "httpie")
> - (version "3.2.1")
> + (version "3.2.2")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "httpie" version))
> (sha256
> (base32
> - "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
> + "140w4mr0w7scpf4j5qm4h475vbwrgxzkdwyygwcmql1r1cgngywb"))))
> (build-system python-build-system)
> (arguments
> ;; The tests attempt to access external web servers, so we cannot run them.
> '(#:tests? #f))
> (propagated-inputs
> - (list python-colorama
> + (list python-charset-normalizer
> + python-colorama
> + python-defusedxml
> + python-importlib-metadata
> + python-multidict
> + python-pip
> python-pygments
> python-requests
> python-requests-toolbelt
> - python-pysocks
> - python-charset-normalizer
> - python-defusedxml
> python-rich
> - python-multidict))
> + python-setuptools))
> (home-page "https://httpie.io")
> (synopsis "cURL-like tool for humans")
> (description
>
> base-commit: f45d05133472a9da13eae20ba4a676c696682c90

Pushed as a1f0b15444e146e5bb5eddd86e86def7aac854bb thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 69035@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69035
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch