(address . guix-patches@gnu.org)(name . miro)(address . firat-23@hotmail.fr)
---
gnu/packages/build-tools.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 15d88ded80..b6869524f0 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Firat Yildirim <firat-23@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1013,3 +1014,24 @@ (define-public pdpmake
;; pdpmake is distributed under the public domain, but the sources include
;; tests under the GPL license version 2.
(license (list license:gpl2 license:public-domain))))
+
+(define-public xmake
+ (package
+ (name "xmake")
+ (version "2.8.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xmake-io/xmake.git")
+ (recursive? #t)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 "1rz7f37rps5s81mylxrn04jpd4q17dfbmz0rrdxg1wybxnpgb8il")))
+ (arguments
+ `(#:tests? #f))
+ (build-system gnu-build-system)
+ (home-page "https://xmake.io/")
+ (synopsis "Cross-platform build utility based on Lua")
+ (description "Xmake is a cross-platform build utility based on Lua.")
+ (license gpl3+)))
base-commit: a903558577d249354aa74bbd6aab897235a7602b
--
2.34.1