[PATCH] adding xmake

  • Open
  • quality assurance status badge
Details
2 participants
  • miro
  • Mathieu Othacehe
Owner
unassigned
Submitted by
miro
Severity
normal
M
(address . guix-patches@gnu.org)(name . miro)(address . firat-23@hotmail.fr)
GV1PR10MB6707DF43EFED065AE3C48439FE442@GV1PR10MB6707.EURPRD10.PROD.OUTLOOK.COM
---
gnu/packages/build-tools.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 15d88ded80..b6869524f0 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Firat Yildirim <firat-23@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1013,3 +1014,24 @@ (define-public pdpmake
;; pdpmake is distributed under the public domain, but the sources include
;; tests under the GPL license version 2.
(license (list license:gpl2 license:public-domain))))
+
+(define-public xmake
+ (package
+ (name "xmake")
+ (version "2.8.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xmake-io/xmake.git")
+ (recursive? #t)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 "1rz7f37rps5s81mylxrn04jpd4q17dfbmz0rrdxg1wybxnpgb8il")))
+ (arguments
+ `(#:tests? #f))
+ (build-system gnu-build-system)
+ (home-page "https://xmake.io/")
+ (synopsis "Cross-platform build utility based on Lua")
+ (description "Xmake is a cross-platform build utility based on Lua.")
+ (license gpl3+)))

base-commit: a903558577d249354aa74bbd6aab897235a7602b
--
2.34.1
M
M
Mathieu Othacehe wrote on 9 Feb 16:42 +0100
(name . miro)(address . firat-23@hotmail.fr)(address . 68994@debbugs.gnu.org)
871q9lzlti.fsf@gnu.org
Hello,

Thanks for this patch.

Toggle quote (4 lines)
> ---
> gnu/packages/build-tools.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)

You are missing a commit message here. The commit message should follow
the conventions explained here:

You can also have a look the `git log` for examples.

Toggle quote (11 lines)
> +(define-public xmake
> + (package
> + (name "xmake")
> + (version "2.8.6")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/xmake-io/xmake.git")
> + (recursive? #t)

^
that's a tabulation

Reported by `guix lint`:

gnu/packages/build-tools.scm:1027:0: xmake@2.8.6: tabulation on line 1027, column 0

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

There is a test directory so the tests should not be disabled.

Toggle quote (2 lines)
> + (home-page "https://xmake.io/")

`guix lint` reports that:

gnu/packages/build-tools.scm:1023:5: xmake@2.8.6: permanent redirect

Toggle quote (3 lines)
> + (synopsis "Cross-platform build utility based on Lua")
> + (description "Xmake is a cross-platform build utility based on Lua.")

Please expand a bit on that description. What are the features of xmake
for instance?

Toggle quote (2 lines)
> + (license gpl3+)))

There's an issue preventing this from compiling. You should use
licence:gpl3+. By the way, it seems to be license:asl2.0 rather than
license:gplv3+.

Please make sure that `make` reports no error on your package.

Don't hesitate to ask if some remarks are unclear :)

Thanks,

Mathieu
?