[PATCH 0/2] update moonfish

  • Done
  • quality assurance status badge
Details
4 participants
  • Andreas Enge
  • Liliana Marie Prikler
  • Christopher Baines
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Z
Z
zamfofex wrote on 8 Feb 01:31 +0100
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
cover.1707351995.git.zamfofex@twdb.moe
I made various improvements since I packaged it for Guix, so I decided it was time to update the package.

zamfofex (2):
gnu: moonfish: Update to 0-2.2118580.
gnu: moonfish: Improve description.

gnu/packages/games.scm | 56 +++++++++++++++---------------------------
1 file changed, 20 insertions(+), 36 deletions(-)


base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Z
Z
zamfofex wrote on 8 Feb 01:34 +0100
[PATCH 1/2] gnu: moonfish: Update to 0-2.2118580.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
e64550fd3c8b6b0ba39c7484fc5a679787f99643.1707351996.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Update to 0-2.2118580.

Change-Id: I0c5b0e61f6818d29165a1371da717bb8695db834
---
gnu/packages/games.scm | 50 ++++++++++++++----------------------------
1 file changed, 17 insertions(+), 33 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06ba868f35..16e2ee828a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10557,46 +10557,30 @@ (define-public stockfish
(license license:gpl3+))))
(define-public moonfish
- (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
- (revision "1"))
+ (let ((commit "2118580d6ab454e165c7a84de6a604f96bc73850")
+ (revision "2"))
(package
(name "moonfish")
(version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~zamfofex/moonfish")
- (commit commit)))
- (sha256
- (base32
- "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
- (file-name (git-file-name name version))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~zamfofex/moonfish")
+ (commit commit)))
+ (sha256
+ (base32 "1vqnmk2mpqd9nfchrirj5g3v3nqyhj3204d6fn3sihc2iqp4zyrk"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
(list
- #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target)))
- #:tests? #f ;no check target
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (replace 'install ;no 'install' target
- (lambda _
- (let* ((out-bin (string-append #$output "/bin"))
- (tools-bin (string-append #$output:tools "/bin"))
- (tool (string-append tools-bin "/moonfish-")))
- (mkdir-p out-bin)
- (mkdir-p tools-bin)
- (copy-file "moonfish"
- (string-append out-bin "/moonfish"))
- (copy-file "play"
- (string-append tool "play"))
- (copy-file "lichess"
- (string-append tool "lichess"))
- (copy-file "analyse"
- (string-append tool "analyse"))))))))
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:tests? #f ;no check target
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
(inputs (list bearssl cjson))
- (outputs '("out" "tools"))
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description
--
2.41.0
Z
Z
zamfofex wrote on 8 Feb 01:34 +0100
[PATCH 2/2] gnu: moonfish: Improve description.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
faa111b557a94466cfd81905332517a4b58670f6.1707351996.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Reword description.

Change-Id: I1641cedc34f28dc47b021be6bcfc2943b9abcc0d
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 16e2ee828a..45851ada0f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10584,9 +10584,9 @@ (define-public moonfish
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description
- "moonfish is a toy UCI chess engine made for fun. It is inspired by
-sunfish, but is written in C rather than Python. It also has TUI tools for
-using any UCI engine and also to connect UCI engines to Lichess.")
+ "moonfish is a toy UCI chess engine written in C for fun. It has TUI/CLI
+tools for using any UCI engine and also to connect UCI engines to Lichess, as
+well as for converting engines between UCI and UGI.")
(license license:agpl3+))))
(define-public morris
--
2.41.0
L
L
Liliana Marie Prikler wrote on 8 Feb 18:50 +0100
Re: [bug#68987] [PATCH 1/2] gnu: moonfish: Update to 0-2.2118580.
(name . ???)(address . iyzsong@envs.net)
efce36d9ba2954914522d43aa6efddef14619c5a.camel@gmail.com
Am Mittwoch, dem 07.02.2024 um 21:34 -0300 schrieb zamfofex:
Toggle quote (43 lines)
> * gnu/packages/games.scm (moonfish): Update to 0-2.2118580.
>
> Change-Id: I0c5b0e61f6818d29165a1371da717bb8695db834
> ---
>  gnu/packages/games.scm | 50 ++++++++++++++--------------------------
> --
>  1 file changed, 17 insertions(+), 33 deletions(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 06ba868f35..16e2ee828a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -10557,46 +10557,30 @@ (define-public stockfish
>        (license license:gpl3+))))
>  
>  (define-public moonfish
> -  (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
> -        (revision "1"))
> +  (let ((commit "2118580d6ab454e165c7a84de6a604f96bc73850")
> +        (revision "2"))
>      (package
>        (name "moonfish")
>        (version (git-version "0" revision commit))
> -      (source (origin
> -                (method git-fetch)
> -                (uri (git-reference
> -                      (url "https://git.sr.ht/~zamfofex/moonfish")
> -                      (commit commit)))
> -                (sha256
> -                 (base32
> -                 
> "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
> -                (file-name (git-file-name name version))))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://git.sr.ht/~zamfofex/moonfish")
> +               (commit commit)))
> +         (sha256
> +          (base32
> "1vqnmk2mpqd9nfchrirj5g3v3nqyhj3204d6fn3sihc2iqp4zyrk"))
> +         (file-name (git-file-name name version))))
Please don't mix in cosmetic changes with semantic ones. IMHO the
indentation is fine as-is.
Toggle quote (32 lines)
>        (build-system gnu-build-system)
>        (arguments
>         (list
> -        #:make-flags
> -        #~(list (string-append "CC=" #$(cc-for-target)))
> -        #:tests? #f                     ;no check target
> -        #:phases
> -        #~(modify-phases %standard-phases
> -            (delete 'configure)         ;no configure script
> -            (replace 'install           ;no 'install' target
> -              (lambda _
> -                (let* ((out-bin (string-append #$output "/bin"))
> -                       (tools-bin (string-append #$output:tools
> "/bin"))
> -                       (tool (string-append tools-bin "/moonfish-
> ")))
> -                  (mkdir-p out-bin)
> -                  (mkdir-p tools-bin)
> -                  (copy-file "moonfish"
> -                             (string-append out-bin "/moonfish"))
> -                  (copy-file "play"
> -                             (string-append tool "play"))
> -                  (copy-file "lichess"
> -                             (string-append tool "lichess"))
> -                  (copy-file "analyse"
> -                             (string-append tool "analyse"))))))))
> +        #:make-flags #~(list (string-append "CC="
> +                                            #$(cc-for-target))
> +                             (string-append "PREFIX=" %output))
> +        #:tests? #f ;no check target
> +        #:phases #~(modify-phases %standard-phases
> +                     (delete 'configure)))) ;no configure script
You forgot to document this change…
Toggle quote (2 lines)
>        (inputs (list bearssl cjson))
> -      (outputs '("out" "tools"))
… as well as this.
Toggle quote (4 lines)
>        (home-page "https://git.sr.ht/~zamfofex/moonfish")
>        (synopsis "Simple chess engine written in C")
>        (description

Cheers
Z
Z
zamfofex wrote on 9 Feb 00:34 +0100
(name . ???)(address . iyzsong@envs.net)
446771014.2091784.1707435281696@privateemail.com
Toggle quote (3 lines)
> Please don't mix in cosmetic changes with semantic ones. IMHO the
> indentation is fine as-is.

Sure. I just ran ‘guix style’ on it before committing, I thought it would have been warranted. I can undo the changes it made, sure.

Toggle quote (5 lines)
> […]
> You forgot to document this change…
> […]
> … as well as this.

Sure, I’ll do that and send a new patch soon! Thanks for reviewing.
A
A
Andreas Enge wrote on 28 Feb 11:30 +0100
Ping
(address . 68987@debbugs.gnu.org)
Zd8LMd1xfelef9Qo@jurong
Ping?

Andreas
Z
Z
zamfofex wrote on 25 Mar 14:55 +0100
[PATCH v2 2/2] gnu: moonfish: Improve description.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
752ec2c7810ab63ed12c52aeeabcf46b903c556b.1711374919.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Reword description.

Change-Id: I1641cedc34f28dc47b021be6bcfc2943b9abcc0d
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 783d172bc9..8898b90fe0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10583,9 +10583,9 @@ (define-public moonfish
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description
- "moonfish is a toy UCI chess engine made for fun. It is inspired by
-sunfish, but is written in C rather than Python. It also has TUI tools for
-using any UCI engine and also to connect UCI engines to Lichess.")
+ "moonfish is a toy UCI chess engine written in C for fun. It has TUI/CLI
+tools for using any UCI engine and also to connect UCI engines to Lichess, as
+well as for converting engines between UCI and UGI.")
(license license:agpl3+))))
(define-public morris
--
2.41.0
Z
Z
zamfofex wrote on 25 Mar 14:55 +0100
[PATCH v2 1/2] gnu: moonfish: Update to 0-2.fd3471d.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
937b8b5757191beea6183e646513bb1645269a93.1711374919.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Update to 0-2.fd3471d.
[arguments]: Use upstream's makefile for building and installing.
Install tools into the "out" output instead of the "tools" output.
[outputs]: Remove "tools".

Change-Id: I1325550afb05f897006b9f2bd01040f52fee703a
---
gnu/packages/games.scm | 33 ++++++++-------------------------
1 file changed, 8 insertions(+), 25 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06ba868f35..783d172bc9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10557,8 +10557,8 @@ (define-public stockfish
(license license:gpl3+))))
(define-public moonfish
- (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
- (revision "1"))
+ (let ((commit "fd3471d59daa333b1ee112f2fd9b7a51c50cf25b")
+ (revision "2"))
(package
(name "moonfish")
(version (git-version "0" revision commit))
@@ -10569,34 +10569,17 @@ (define-public moonfish
(commit commit)))
(sha256
(base32
- "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
+ "1snjym2crs8c2lwvy8laag25wwqw3q7yml3mqcsqb2jfhanb62qc"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
(list
- #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target)))
- #:tests? #f ;no check target
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (replace 'install ;no 'install' target
- (lambda _
- (let* ((out-bin (string-append #$output "/bin"))
- (tools-bin (string-append #$output:tools "/bin"))
- (tool (string-append tools-bin "/moonfish-")))
- (mkdir-p out-bin)
- (mkdir-p tools-bin)
- (copy-file "moonfish"
- (string-append out-bin "/moonfish"))
- (copy-file "play"
- (string-append tool "play"))
- (copy-file "lichess"
- (string-append tool "lichess"))
- (copy-file "analyse"
- (string-append tool "analyse"))))))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:tests? #f ;no check target
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
(inputs (list bearssl cjson))
- (outputs '("out" "tools"))
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description

base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Z
Z
zamfofex wrote on 26 Mar 21:01 +0100
[PATCH v3 1/2] gnu: moonfish: Update to 0-2.fb2cb4f.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
2cf88f5f3d316ab3d48be949c3d4a073239e3ec1.1711483265.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Update to 0-2.fb2cb4f.
[arguments]: Use upstream's makefile for building and installing.
Install tools into the "out" output instead of the "tools" output.
[outputs]: Remove "tools".

Change-Id: I0f098b02633d397fe1fef67863c3cd5b1db19214
---
gnu/packages/games.scm | 33 ++++++++-------------------------
1 file changed, 8 insertions(+), 25 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06ba868f35..50ddf53ef5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10557,8 +10557,8 @@ (define-public stockfish
(license license:gpl3+))))
(define-public moonfish
- (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
- (revision "1"))
+ (let ((commit "fb2cb4f53876b1b0c6060464e0dd5a05ab00e502")
+ (revision "2"))
(package
(name "moonfish")
(version (git-version "0" revision commit))
@@ -10569,34 +10569,17 @@ (define-public moonfish
(commit commit)))
(sha256
(base32
- "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
+ "1rbhdahp0s2qm1zi7lpr0bb6zq02y76fc9d9nc2k5n03zh2as97i"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
(list
- #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target)))
- #:tests? #f ;no check target
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure) ;no configure script
- (replace 'install ;no 'install' target
- (lambda _
- (let* ((out-bin (string-append #$output "/bin"))
- (tools-bin (string-append #$output:tools "/bin"))
- (tool (string-append tools-bin "/moonfish-")))
- (mkdir-p out-bin)
- (mkdir-p tools-bin)
- (copy-file "moonfish"
- (string-append out-bin "/moonfish"))
- (copy-file "play"
- (string-append tool "play"))
- (copy-file "lichess"
- (string-append tool "lichess"))
- (copy-file "analyse"
- (string-append tool "analyse"))))))))
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:tests? #f ;no check target
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
(inputs (list bearssl cjson))
- (outputs '("out" "tools"))
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description

base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Z
Z
zamfofex wrote on 26 Mar 21:01 +0100
[PATCH v3 2/2] gnu: moonfish: Improve description.
(address . 68987@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
37603a3a71342b38ea98aa93ffe9e43581781aab.1711483265.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Reword description.

Change-Id: I1641cedc34f28dc47b021be6bcfc2943b9abcc0d
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 50ddf53ef5..fab5ab5d7d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10583,9 +10583,9 @@ (define-public moonfish
(home-page "https://git.sr.ht/~zamfofex/moonfish")
(synopsis "Simple chess engine written in C")
(description
- "moonfish is a toy UCI chess engine made for fun. It is inspired by
-sunfish, but is written in C rather than Python. It also has TUI tools for
-using any UCI engine and also to connect UCI engines to Lichess.")
+ "moonfish is a toy UCI chess engine written in C for fun. It has TUI/CLI
+tools for using any UCI engine and also to connect UCI engines to Lichess, as
+well as for converting engines between UCI and UGI.")
(license license:agpl3+))))
(define-public morris
--
2.41.0
C
C
Christopher Baines wrote on 27 Mar 13:57 +0100
(name . zamfofex)(address . zamfofex@twdb.moe)
87wmpng7au.fsf@cbaines.net
Thanks all, I've pushed these patches to master as
560062aaeabb485e7f53f8f5e6449b9a35aa9ca2.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYEGAlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfnCxAAsrmr8N2JQ6ApNNZME/0qIHAJdgG0HRGg
ZxPE+OeopsmE36pF0S+ZvQ0wpjebzcUMez/92ccSjqhAgWPqAcBHg6v1ZhOs/Je1
WWF/SaMSnIfmUwyoS7COv04J/ZC560kHr+6tGBvFzmTmWjyCPAa3TZOrtih3/jzR
MN+mBd8PI9bRQtZj+ABLs341Jf7mXq2CU5OrOMH3s8P4le5Mdx1ee0ZZcinoSNT8
fWBiMjGOEJCjRXplNP0hAfByh9qQyM+0eyQHNM70Ig9q4qD5388/cFKf8iEC/kuJ
mD1PDgf0g1Geb+PHLTE8L5M9d1vyXnzAL1YMl6mN1Y3O9g5oIBr8hJn0gOCde1qr
hvAHxXhPdQMHI6/AisRINhqV3grMbhQuuU0tqhRC0KlLZmp2BCNNxjxbn4O1OtWt
ss2ZsXntJE76PzHbnwBYzpOmwS9nLu7mZitYDXNCP1rTlPQoqMq2KJ4DD0bm6dPG
PW+00qTmnNw0mGBQovFnL/e3ugEp+1LP8exOoex0Z6zxTc5qbXVfXL4gID/gbofz
CGpjRJZAuz/VM07YBGKfFpcWoSoExN6YL6oJmjVSPXQRtslYUSj4TGMhGvSkhqud
/MEWQjOMIF+8t/7FgMW8pBGy93BQBjO6uTMkOueMGcyPEPw3lCF8bV0aD5gwcPzm
NdOzENPbmDg=
=/jqG
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 68987@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68987
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch