[PATCH] gnu: Add tagainijisho.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
39103f77d7cfb80bad32f53e90d85257d9475314.1707315570.git.~@wolfsden.cz
* gnu/packages/education.scm (tagainijisho): New variable.

Change-Id: I85834c9e91a743540ef751e0c2bb3138b4c3b762
---
gnu/packages/education.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 7b72ed0349..c70f263335 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1161,3 +1161,38 @@ (define-public mazo
(description "Mazo is a learning application that helps you memorize
simple concepts using multimedia flash cards and spaced reviews.")
(license license:public-domain)))
+
+(define-public tagainijisho
+ (package
+ (name "tagainijisho")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Gnurou/tagainijisho/releases/download/"
+ version
+ "/tagainijisho-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "00whfcnpn42asxmafcfbcmpwfwyv40qaqdk28psa1vp0lainmyhh"))))
+ (build-system qt-build-system)
+ (arguments
+ '(#:tests? #f)) ; no test target
+ (native-inputs
+ (list qttools-5))
+ (synopsis "Japanese dictionary and learning assistant")
+ (description "Tagaini Jisho is a free, open-source Japanese dictionary and
+kanji lookup tool for Windows, MacOS X and Linux and aims at becoming your
+Japanese study assistant. It allows you to quickly search for entries and
+mark those that you wish to study, along with tags and personal notes. It
+also let you train entries you are studying and follows your progression in
+remembering them. Finally, it makes it easy to review entries you did not
+remember by listing them on screen or printing them on a small booklet.
+
+Tagaini Jisho also features complete stroke order animations for more than
+6000 kanji.")
+ (home-page "https://www.tagaini.net")
+ (license license:gpl3+)))

base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Nicolas Goaziou wrote 1 years ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 68972-done@debbugs.gnu.org)
87r0h4chnq.fsf@nicolasgoaziou.fr
Hello,

Tomas Volf <~@wolfsden.cz> writes:

Toggle quote (2 lines)
> * gnu/packages/education.scm (tagainijisho): New variable.

Thank you.

I tweaked the description and applied the patch.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68972@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68972
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help