[Patch]: gnu: Add r-mvnfast and r-imifa.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 1 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
7b22d6bf3f264770861f78df4a09c426@mdc-berlin.de
* gnu/packages/cran.scm (r-imifa, r-imifa): New variables.
Attachment: file
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 2/2] gnu: Add r-imifa.
(address . 68951@debbugs.gnu.org)
b4533b7f64955a88faaa2356fed859e37e2a95ef.1707234530.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-imifa): New variable.

Change-Id: I0046faadb9546ae1fa8437db72b784307deba241
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ef4f235e65..74ab2f78e5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11768,6 +11768,41 @@ (define-public r-cqrreg
and @dfn{alternating direction method of multipliers algorithms} (ADMM).")
(license license:gpl2+)))
+(define-public r-imifa
+ (package
+ (name "r-imifa")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "IMIFA" version))
+ (sha256
+ (base32 "08h53w1axvmvnd4z1nf5bsps5sr6g8a77q6pvg39ss7jcfqm800v"))))
+ (properties `((upstream-name . "IMIFA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-matrixstats
+ r-mvnfast
+ r-mclust
+ r-rfast
+ r-slam
+ r-viridislite))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=IMIFA")
+ (synopsis
+ "Infinite mixtures of infinite factor analysers and related models")
+ (description
+ "This package provides flexible Bayesian estimation of @acronym{IMIFA,
+infinite mixtures of infinite factor analysers} and related models, for
+nonparametrically clustering high-dimensional data. The IMIFA model conducts
+Bayesian nonparametric model-based clustering with factor analytic covariance
+structures without recourse to model selection criteria to choose the number of
+clusters or cluster-specific latent factors, mostly via efficient Gibbs updates.
+Model-specific diagnostic tools are also provided, as well as many options for
+plotting results, conducting posterior inference on parameters of interest,
+posterior predictive checking, and quantifying uncertainty.")
+ (license license:gpl3+)))
+
(define-public r-import
(package
(name "r-import")
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 1/2] gnu: Add r-mvnfast.
(address . 68951@debbugs.gnu.org)
d41f5b5dc2be14d4a9c43a7534d77042b4781e24.1707234530.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mvnfast): New variable.

Change-Id: I17b1d1da941248fde466aa90304481cae9ca60fe
---
gnu/packages/cran.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 842946e766..ef4f235e65 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018, 2020-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020-2024 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -17911,6 +17911,30 @@ (define-public r-mvabund
analysing multivariate abundance data in community ecology.")
(license license:lgpl2.1+)))
+(define-public r-mvnfast
+ (package
+ (name "r-mvnfast")
+ (version "0.2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mvnfast" version))
+ (sha256
+ (base32 "1869xqq2wd7yw23q4ma5qawcnbdp7myafk6rdxazqymqak7f0wc8"))))
+ (properties `((upstream-name . "mvnfast")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bh r-rcpp r-rcpparmadillo))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mfasiolo/mvnfast/")
+ (synopsis "Fast multivariate normal and Student's t methods")
+ (description
+ "This package provides computationally efficient tools related to the
+multivariate normal and Student's t distributions. The main functionalities
+are: simulating multivariate random vectors, evaluating multivariate normal or
+Student's t densities and Mahalanobis distances. These tools are developed
+using C++ code and of the OpenMP API.")
+ (license license:gpl2+)))
+
(define-public r-afex
(package
(name "r-afex")

base-commit: a4464bd0975c811f18af98f69032b29bddda5b81
--
2.41.0
Ricardo Wurmus wrote 1 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 68951-done@debbugs.gnu.org)
871q9p70zg.fsf@elephly.net
Hi Mădălin,

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-mvnfast): New variable.

Pushed this and the other patch with commit
b13d6c5715b71c4499ce37ef3968e4216125a5ed.

Thank you for the patches!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help