(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
This patch series introduces a solution for tiny packages. Instead of
writing packages, we can simply rely on the javascript code that is
behind such a package. Introduce two helpers to allow this.
Based on these two helpers, package all propagated direct dependencies
of the deep-equal package. This is a good choice both for illustrating
this solution and for further Node packages, a lot of which rely on
this intermediate package.
This patch series depends on 66180.
Nicolas Graves (44):
guix: build-system: node: Add node-trivial-package helper.
guix: build-system: node: Add node-is-type-object helper.
gnu: Add node-function-bind.
gnu: Add node-has-proto.
gnu: Add node-has.
gnu: Add node-has-symbols.
gnu: Add node-has-tostringtag.
gnu: Add node-is-callable.
gnu: Add node-get-intrinsic.
gnu: Add node-is-symbol.
gnu: Add node-for-each.
gnu: Add node-available-typed-arrays.
gnu: Add node-gopd.
gnu: Add node-call-bind.
gnu: Add node-object-inspect.
gnu: Add node-is-regex.
gnu: Add node-which-typed-array.
gnu: Add node-side-channel.
gnu: Add node-is-weakmap.
gnu: Add node-is-weakset.
gnu: Add node-is-typed-array.
gnu: Add node-is-shared-array-buffer.
gnu: Add node-internal-slot.
gnu: Add node-is-array-buffer.
gnu: Add node-define-properties.
gnu: Add node-is-arguments.
gnu: Add node-isarray.
gnu: Add node-stop-iteration-iterator.
gnu: Add node-is-map.
gnu: Add node-is-set.
gnu: Add node-is-string.
gnu: Add node-is-number-object.
gnu: Add node-is-bigint.
gnu: Add node-is-boolean-object.
gnu: Add node-object-is.
gnu: Add node-es-get-iterator.
gnu: Add node-which-boxed-primitive.
gnu: Add node-which-collection.
gnu: Add node-array-buffer-byte-length.
gnu: Add node-is-date-object.
gnu: Add node-object-assign.
gnu: Add node-object-keys.
gnu: Add node-regexp-prototype-flags.
gnu: Add node-deep-equal.
gnu/packages/node-xyz.scm | 1123 +++++++++++++++++++++++++++++++++++-
guix/build-system/node.scm | 66 ++-
2 files changed, 1187 insertions(+), 2 deletions(-)
--
2.41.0