[PATCH] gnu: Add r-rpresto.

  • Done
  • quality assurance status badge
Details
3 participants
  • nafkhamdc
  • Ricardo Wurmus
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
c43fc214bf734eb3014eca4c8d3ac4e3ed40443a.1707127447.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-rpresto): New variable.

Change-Id: I81b0e43ca75ab2df36f67367bfc73c4893be1a30
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 842946e766..fecf77580c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1411,6 +1411,43 @@ (define-public r-pma
canonical correlation analysis.")
(license license:gpl2+)))
+(define-public r-rpresto
+ (package
+ (name "r-rpresto")
+ (version "1.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RPresto" version))
+ (sha256
+ (base32 "1q8c3h328iwscnayxj8qc71s2hkqdqwnpf38kn3zz3ks66qzjf8c"))))
+ (properties `((upstream-name . "RPresto")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bit64
+ r-dbi
+ r-dbplyr
+ r-dplyr
+ r-httr
+ r-jsonlite
+ r-lifecycle
+ r-lubridate
+ r-openssl
+ r-progress
+ r-purrr
+ r-rlang
+ r-stringi
+ r-tibble
+ r-vctrs))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/prestodb/RPresto")
+ (synopsis "DBI connector to Presto")
+ (description
+ "This package implements a DBI compliant interface to Presto.
+Presto is an open source distributed SQL query engine for running
+interactive analytic queries against data sources of all sizes
+ranging from gigabytes to petabytes.")
+ (license license:bsd-3)))
+
(define-public r-prettydoc
(package
(name "r-prettydoc")

base-commit: 5a806face508cdfcd91e1eb1afb3ec38c002ec92
--
2.34.1
Sharlatan Hellseher wrote 1 years ago
[PATCH v2 1/1] gnu: Add r-rpresto.
(address . 68932@debbugs.gnu.org)
255cc6c0f0d1895b0053c296483bd570aed1eaed.1708767269.git.sharlatanus@gmail.com
From: nafkhamdc <navid.afkhami@mdc-berlin.de>

* gnu/packages/cran.scm (r-rpresto): New variable.

Change-Id: I81b0e43ca75ab2df36f67367bfc73c4893be1a30
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
---
gnu/packages/cran.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fb053074a1..23cf64ee36 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022, 2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 nafkhamdc <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1495,6 +1496,44 @@ (define-public r-pma
canonical correlation analysis.")
(license license:gpl2+)))
+(define-public r-rpresto
+ (package
+ (name "r-rpresto")
+ (version "1.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RPresto" version))
+ (sha256
+ (base32 "1q8c3h328iwscnayxj8qc71s2hkqdqwnpf38kn3zz3ks66qzjf8c"))))
+ (properties `((upstream-name . "RPresto")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-bit64
+ r-dbi
+ r-dbplyr
+ r-dplyr
+ r-httr
+ r-jsonlite
+ r-lifecycle
+ r-lubridate
+ r-openssl
+ r-progress
+ r-purrr
+ r-rlang
+ r-stringi
+ r-tibble
+ r-vctrs))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/prestodb/RPresto")
+ (synopsis "DBI connector to Presto")
+ (description
+ "This package implements a DBI compliant interface to
+@url{https://prestodb.io/, Presto} - a distributed SQL query engine for
+running interactive analytic queries against data sources of all sizes ranging
+from gigabytes to petabytes.")
+ (license license:bsd-3)))
+
(define-public r-prettydoc
(package
(name "r-prettydoc")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH] gnu: Add r-rpresto.
(address . 68932@debbugs.gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
87h6hy89q3.fsf@gmail.com
Hi,

CC'd Ricardo to check license acceptance.

I've checked the package for lint/build, add copyright header, slightly
adjust description and re-indent propagated inputs. When I've been
checking license on CRAN and project's VCS page I noticed this
statement:

Toggle snippet (4 lines)
License: BSD_3_clause + file LICENSE
Copyright: Meta Platforms, Inc. 2015-present.

Toggle snippet (5 lines)
YEAR: 2015-present
COPYRIGHT HOLDER: Meta Platforms, Inc. and affiliates. All rights reserved.
ORGANIZATION: Meta Platforms, Inc. and affiliates

Sending v2 of the patch with minor modifications.

nafkhamdc (1):
gnu: Add r-rpresto.

gnu/packages/cran.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)


base-commit: c0f88cd18649c31c75bcddf8247b14ef3e3a66a5
--
2.41.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXZvcQACgkQdtcnv/Ys
0rXJOw/+MGJw4+yPmwwOiAF11B/b15PB4uxXOWYCYWANzOR71KOcm0d6yr58o5Mi
DRwg+pD+j66POC1w31OBGHtUVHJ+yI6nR8+gxYrnMGpqSnPQyP4Vt53LSmL6QEe7
zapf2gVSHiqrtkAhsGLwBAwrZ13W5fUuAO0kQVxfOd1gTvoNhvdCRNpMMgtiPUqM
eMpdmju9ij/+IkPwNFMJoSbbfjPjHt74sdJJ9hBIYAMGm1E+7fNJAjtL06o/NU2n
QLD29hsH94Rjy9PyMnLqEtvoNqfKm6aj2Nd8k9cRsApIWFqtxWKbJp4iXjJ2cNRD
SphUaSDxwPckBcRagJQiN2xMQWJvG81tG9RlQCTx80GUCOasMfgT5L/EVXU5MPYZ
DNEMyxv59JWTGoq+Z4ExcOheRIyEdNCy7EC8ni1aqk6if9o9CA/N4j9ETVnwXG/C
PsopTzd1Eq511uk04D8jOR+XsfeDdhUCbolM/Xos+fRP3WuBjSvDelkIf6tOcqkP
Ai6O86q/6o62p/DF3LDIGSQ7lw0LlHVwDON8aEver0gJvPGAVP+ekbo9m/yvO4We
VTHj6dz+Ul5JFwz43/m05LzSl/w9k6o+wf5oAw/RbAQrV5c8sZ5OsIknuWd9pOK1
0/PF2YRXySpwKAJGHgSR6616w0ldFXa/5Wrbu9UvLJ9WhCTO9Qs=
=Qqc0
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87a5no28u5.fsf@elephly.net
Thanks for the review. I applied it.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help