nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/cran.scm (r-rpresto): New variable.
Change-Id: I81b0e43ca75ab2df36f67367bfc73c4893be1a30
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 842946e766..fecf77580c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1411,6 +1411,43 @@ (define-public r-pma
canonical correlation analysis.")
(license license:gpl2+)))
+(define-public r-rpresto
+ (package
+ (name "r-rpresto")
+ (version "1.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RPresto" version))
+ (sha256
+ (base32 "1q8c3h328iwscnayxj8qc71s2hkqdqwnpf38kn3zz3ks66qzjf8c"))))
+ (properties `((upstream-name . "RPresto")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bit64
+ r-dbi
+ r-dbplyr
+ r-dplyr
+ r-httr
+ r-jsonlite
+ r-lifecycle
+ r-lubridate
+ r-openssl
+ r-progress
+ r-purrr
+ r-rlang
+ r-stringi
+ r-tibble
+ r-vctrs))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/prestodb/RPresto")
+ (synopsis "DBI connector to Presto")
+ (description
+ "This package implements a DBI compliant interface to Presto.
+Presto is an open source distributed SQL query engine for running
+interactive analytic queries against data sources of all sizes
+ranging from gigabytes to petabytes.")
+ (license license:bsd-3)))
+
(define-public r-prettydoc
(package
(name "r-prettydoc")
base-commit: 5a806face508cdfcd91e1eb1afb3ec38c002ec92
--
2.34.1