(address . bug-guix@gnu.org)
Hi,
On my machine the order of search paths are:
$ echo $PATH | tr : '\n'
/home/cdo/.guix-home/profile/bin
/home/cdo/.guix-home/profile/sbin
/run/setuid-programs
/home/cdo/.config/guix/current/bin
/home/cdo/.guix-profile/bin
/run/current-system/profile/bin
/run/current-system/profile/sbin
/gnu/store/gjsxzcc0gqpz4lpbsrbidlnn5ij1lfm1-gzip-1.12/bin
/gnu/store/z81jl0pb4ppkci4im6n856dkhi2ki2d3-coreutils-9.1/bin
This leads to unexpected results if you have Guix inside your home
package list. (Which you might desire if you wanted to use Guix in a
home container.)
The Guix you interact with stays stuck on the version that you had when
you first `guix home reconfigured` a configuration with guix as a
package. Then `guix pull` appears to succeed but `guix describe` is
still stuck at the original version. And even a `guix home reconfigure`
doesn't update the version because it's using the `guix` from the
original `guix home reconfigure`.
The way out of this situation is to use
`~/.config/guix/current/bin/guix` directly, setting $PATH manually, or
simply removing `guix` from your home package list. However, the
situation is preventable and undesirable and there's several possible
solutions:
1. Reorder the paths by default, keeping ~/.config/guix in front of
~/.guix-home
2. Have `guix home` warn when 'guix' is included as a package
3. Have `guix pull` warn when Guix is shadowed and unable to be updated
My preference would be at least 1 and 3.
(Incidentally, how did gzip and coreutils get in there? I didn't put it
there.)
I'm happy to contribute a patch if others agree that it's worth fixing.
Excited to contribute more!
- Christina
----------------
Supplementary output:
$ guix describe
guix aeb4943
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: aeb494322ca9dec4a4d66a7d063239c8536bd538
$ guix pull
Updating channel 'guix' from Git repository at
Updating channel 'nonguix' from Git repository at
Building from these channels:
guix https://git.savannah.gnu.org/git/guix.git 9389070
nonguix https://gitlab.com/nonguix/nonguix fe2fcf1
Computing Guix derivation for 'x86_64-linux'... \
nothing to be done
hint: After setting `PATH', run `hash guix' to make sure your shell
refers to `/home/cdo/.config/guix/current/bin/guix'.
$ hash guix
$ which guix
/home/cdo/.guix-home/profile/bin/guix
$ guix describe
guix aeb4943
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: aeb494322ca9dec4a4d66a7d063239c8536bd538