[PATCH] gnu: go-github-com-docker-go-connections: Update to 0.5.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87r0ht7e59.fsf@troyfigiel.com
* gnu/packages/golang.scm (go-github-com-docker-go-connections): Update to 0.5.0.
---
gnu/packages/golang.scm | 45 +++++++++++++++++++----------------------
1 file changed, 21 insertions(+), 24 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 014ca01602..16074ae0fa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4776,31 +4776,28 @@ (define-public go-github-com-docker-distribution
(license license:asl2.0))))
(define-public go-github-com-docker-go-connections
- (let ((commit "3ede32e2033de7505e6500d6c868c2b9ed9f169d")
- (revision "0"))
- (package
- (name "go-github-com-docker-go-connections")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/docker/go-connections")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0v1pkr8apwmhyzbjfriwdrs1ihlk6pw7izm57r24mf9jdmg3fyb0"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/docker/go-connections"))
- (home-page "https://github.com/docker/go-connections")
- (synopsis "Networking library for Go")
- (description
- "This package provides a library to work with network connections in
-the Go language. In particular it provides tools to deal with network address
+ (package
+ (name "go-github-com-docker-go-connections")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-connections")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0svfa9g4xvbn87l5kiww1jkijmci9g5821wjp81xz1rfp13cqrk8"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/docker/go-connections"))
+ (home-page "https://github.com/docker/go-connections")
+ (synopsis "Networking library for Go")
+ (description
+ "This package provides a library to work with network connections in the
+Go language. In particular it provides tools to deal with network address
translation (NAT), proxies, sockets, and transport layer security (TLS).")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public go-github-com-docker-go-units
(package

base-commit: 179bb57d2532ee6b81791e078b0f782cbf88cb84
--
2.42.0
Hilton Chain wrote 1 years ago
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 68909-done@debbugs.gnu.org)
87sf2773ua.wl-hako@ultrarare.space
Hi Troy,

On Sat, 03 Feb 2024 23:31:47 +0800,
Troy Figiel wrote:
Toggle quote (6 lines)
>
> * gnu/packages/golang.scm (go-github-com-docker-go-connections): Update to 0.5.0.
> ---
> gnu/packages/golang.scm | 45 +++++++++++++++++++----------------------
> 1 file changed, 21 insertions(+), 24 deletions(-)

Applied as b0d7e4923e0acb3099d4343dceeeb23c5204aeff, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68909@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68909
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help