Boot fails when symlink exists

  • Open
  • quality assurance status badge
Details
One participant
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 2 Feb 18:55 +0100
(address . bug-guix@gnu.org)
87bk8yeonl.fsf@disroot.org
Today my Guix System crashed during the boot process for external
reasons.

Upon restart, booting a system would drop into the REPL right after the
following line:

Toggle snippet (3 lines)
making '/var/...' the current system...

complaining that the symlink already exists.

I checked gnu/build/activation.scm (activate-current-system), and there
is this:

Toggle snippet (6 lines)
;; Atomically make SYSTEM current.
(let ((new (string-append %current-system ".new")))
(symlink system new)
(rename-file new %current-system)))

And indeed, there was a dangling /run/current-system.new file on my
disk.
After removing it (from a live USB, didn't know how to do this from the
Guile REPL), the system succeeded to boot.

The fix should be easy: ensure that (symlink system new) overwrites any
potentially existing file.

Cheers!
Pierre
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68905@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68905
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch