Difference between trace behavior in guix repl and guile

  • Open
  • quality assurance status badge
Details
One participant
  • Adriel Dumas--Jondeau
Owner
unassigned
Submitted by
Adriel Dumas--Jondeau
Severity
normal
A
A
Adriel Dumas--Jondeau wrote on 2 Feb 17:21 +0100
(address . bug-guix@gnu.org)
8734uaq1cb.fsf@disroot.org
Here's what's happening in a guix repl:

```
(guix-user)> ,use (guix scripts build)
(guix-user)> ,trace (guix-build "hello") ; doesn't output any trace for some reason
```

And here'the same for a guile repl:

```
(guile-user)> ,use (guix scripts build)
(guile-user)> ,trace (guix-build "hello") ; however it does work
trace: | (guix-build "hello")
trace: | | (_ (guix scripts) #:ensure #f)
trace: | | (_ #<procedure 7ff4802c5000 at ice-9/boot-9.scm:3241:7 ()>)
trace: | | | (lock-mutex #<mutex 7ff487d01fc0>)
...
```

This was observed during a working group on profiling during the Guix Days.

--
Adriel
-----BEGIN PGP SIGNATURE-----

iQHHBAEBCAAxFiEEdTo3gYfn+XlCL0s3vM4s3nSoxFIFAmW9F7QTHGxlaXJkYUBk
aXNyb290Lm9yZwAKCRC8zizedKjEUvNtDACU4O0UIu5YuMLDIOCmmlWjBaFxOIHX
rm3E2BlN4Ty3go35eKLcKbGH6tbhtcAhvu+aaV4M0qb0vx/Kqe63+0RwKYEHi2Cg
z41hvAOPawxZGoo4oohTkL7XoqaNYW736LcFEDuPRK2b5/RgXvw4PqrxwFa4ycb0
uAteuEOQCBGwfqoa9iJnn6lOQ3/F5HhX5zGSDumZOifK5naEhAA/RZiZp5W+qrlh
6P1BM2oGSy4rMLWNUY7lh4RJs25MrG+/YzT32yG+b7G/GSaqtRfONdal/NGi2H0p
fbDsQnjkYOGUqvXrrdBJjuYfj8y3gem8rvLeKdzRy9cc5ZLMvD7HtswVfw7cy6Vl
QbNtl7AyhD8ygFBrL0pSAwvAj7dQpV7uU/Yz0zqgQCQpVP4iZf0spgdmUGTgSf4N
5f+Vja1pLcyksfMukJ8D2HRu4YprENDRQ7MYKPum3/rcuNphLsTAPMETcgAwrdEE
bubolPT0njiz8rx5qsfnInej8eY3d+7Vv/w=
=nD7m
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68895@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68895
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch