[PATCH] gnu: Include company icons and documentation images

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Tom Willemse
Owner
unassigned
Submitted by
Tom Willemse
Severity
normal
T
T
Tom Willemse wrote on 31 Jan 07:28 +0100
(address . guix-patches@gnu.org)(name . Tom Willemse)(address . tom@ryuslash.org)
61f61e5ddfa4e623eda547ea9545ca4cae3350dd.1706682512.git.tom@ryuslash.org
* gnu/packages/emacs-xyz.scm (emacs-company): Include icons and documentation
images.

Change-Id: I8b7515141fa71fcb4b199bfaa268ddd4ab117743
---
gnu/packages/emacs-xyz.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4514bd1b25..61174f03ac 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9261,6 +9261,18 @@ (define-public emacs-company
(sha256
(base32 "0j2qrnx2w2al4f2n37b89q0pkabh5ccv00gsknvgaylhy0za5gq9"))))
(build-system emacs-build-system)
+ (arguments
+ (list
+ #:include #~(cons* "icons/" %default-include)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'move-doc 'install-doc-images
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((images (find-files "./images/small/" ".*\\.png$")))
+ (for-each (lambda (image)
+ (install-file image
+ (string-append #$output "/share/info/images/small")))
+ images)))))))
(home-page "https://company-mode.github.io/")
(synopsis "Modular text completion framework")
(description

base-commit: c4687f5437ad89a7e87deed1933b60f6eac83176
--
2.43.0
A
A
Andrew Tropin wrote on 19 Feb 15:18 +0100
87le7gy1tl.fsf@trop.in
On 2024-01-30 22:28, Tom Willemse wrote:

Toggle quote (34 lines)
> * gnu/packages/emacs-xyz.scm (emacs-company): Include icons and documentation
> images.
>
> Change-Id: I8b7515141fa71fcb4b199bfaa268ddd4ab117743
> ---
> gnu/packages/emacs-xyz.scm | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 4514bd1b25..61174f03ac 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -9261,6 +9261,18 @@ (define-public emacs-company
> (sha256
> (base32 "0j2qrnx2w2al4f2n37b89q0pkabh5ccv00gsknvgaylhy0za5gq9"))))
> (build-system emacs-build-system)
> + (arguments
> + (list
> + #:include #~(cons* "icons/" %default-include)
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'move-doc 'install-doc-images
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((images (find-files "./images/small/" ".*\\.png$")))
> + (for-each (lambda (image)
> + (install-file image
> + (string-append #$output "/share/info/images/small")))
> + images)))))))
> (home-page "https://company-mode.github.io/")
> (synopsis "Modular text completion framework")
> (description
>
> base-commit: c4687f5437ad89a7e87deed1933b60f6eac83176

LGTM, thank you for the patch, slightly adjusted the code to fit 80
column, added a trailing dot to commit message, pushed as

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmXTY0YACgkQIgjSCVjB
3rDkSA//ZuT3oGMNGYb6BkVJMLeuqjOTprwuyO4GoTDJfG0ZnvXCFqQ/L1q7mJE0
/jEN6//bGolryIsBdOrMu2yDFDWq+N4Qo7ixBmRt7x2arthCJFm9lESSpPt6CSx1
xwDicUe5UTQDBIk23jxGWofTF5nNp2l3xfWAzEVfx7wqiQ1GYQz9nTsJ2vaIUFjs
2D/N8l87aLaMg9ebYtHeMdq9zimjQ31YggrVncDrvOgrCPeLxAeUyyGDX9uuDaKD
LneNmKQcammFeN5BxaPjBy4mhYJWu43YwEjFghfcLvLo9GLiPA7jk09nnULHTsZr
rMBfFUoW9CiZhd5t4/i28qbc/CeaYJI65KEiwWvZMEsuIsbRdobE+q5353g71Joi
zgMOFR67a24oAss+u1IgO9Sh6CV+kamAWXZIlH2xoc+kT+qUCALq3zFltyVx6mLk
CJBsd914m218sEoxjeTOyVCKpch0obEweg+xssoZ0A+gMLR3x3dW9URPdN15qR+h
N3t6sjy5R7hfVEiktQr9/QReSXlVW0kPjxcictVwhAtzyqJNYMLA3DM5/2pgLkcn
CSqBX82VRpWugaguITFAzptsihEkJOkoV3BeV9+CtcLEC6D6XPi6QLHROBNDrXt7
Kt69AgZZH7P2I/f7eRw39QFQjaIhZQVyJ3ArRITJVEbarGntsGg=
=Z/a/
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68839@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68839
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch