[PATCH 0/7] gnu: Improve go-honnef-co-go-tools definition.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 27 Jan 17:55 +0100
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240127165557.3580-1-ngraves@ngraves.fr
A few improvements to the go-honnef-co-go-tools package:
* remove a former archived dependency
* add binaries / executables provided in the source
* improve synopsis and description

Nicolas Graves (7):
gnu: Remove go-github-com-kisielk-gotool.
gnu: Add go-keyify.
gnu: Add go-staticcheck.
gnu: Add go-structlayout.
gnu: Add go-structlayout-optimize.
gnu: Add go-structlayout-pretty.
gnu: go-honnef-co-go-tools: Improve synopsis and description.

gnu/packages/golang-check.scm | 69 +++++++++++++++++++++++++++++++++--
gnu/packages/golang.scm | 24 ------------
2 files changed, 66 insertions(+), 27 deletions(-)

--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 2/7] gnu: Add go-keyify.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-2-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-keyify): New variable.

Change-Id: I99d41a18cb0e00dd35bef9c2c8fce12748f24ad4
---
gnu/packages/golang-check.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b8944b367e..6de21c7b5a 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -82,6 +82,18 @@ (define-public go-honnef-co-go-tools
simplifications, and enforces style rules.")
(license license:expat)))
+(define-public go-keyify
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-keyify")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/keyify"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Transform an unkeyed struct literal into a keyed one in Go.")
+ (description "This package turns unkeyed struct literals (@code{T{1, 2,
+3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 1/7] gnu: Remove go-github-com-kisielk-gotool.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-1-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-github-com-kisielk-gotool): Delete variable.

Change-Id: Ic99bba40f4cd66335656f27bf7dd97d1b90bb8f1
---
gnu/packages/golang-check.scm | 1 -
gnu/packages/golang.scm | 24 ------------------------
2 files changed, 25 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index ec886985d6..b8944b367e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -71,7 +71,6 @@ (define-public go-honnef-co-go-tools
(delete 'build))))
(propagated-inputs
(list go-github-com-burntsushi-toml
- go-github-com-kisielk-gotool
go-golang-org-x-exp
go-golang-org-x-mod
go-golang-org-x-tools))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8fea581248..f38684dc68 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10914,30 +10914,6 @@ (define-public go-mvdan-cc-xurls
(native-inputs '())
(inputs '())))
-(define-public go-github-com-kisielk-gotool
- (package
- (name "go-github-com-kisielk-gotool")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kisielk/gotool")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "14af2pa0ssyp8bp2mvdw184s5wcysk6akil3wzxmr05wwy951iwn"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/kisielk/gotool"))
- (home-page "https://github.com/kisielk/gotool")
- (synopsis "Go library of utility functions")
- (description
- "This package contains utility functions used to implement the standard
-@code{cmd/go} tool, provided as a convenience to developers who want to write
-tools with similar semantics.")
- (license license:expat)))
-
(define-public go-go-uber-org-zap
(package
(name "go-go-uber-org-zap")
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 3/7] gnu: Add go-staticcheck.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-3-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-staticcheck): New variable.

Change-Id: I82ce27df1bdbd79ae4740928e0661b585289d02b
---
gnu/packages/golang-check.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 6de21c7b5a..669e61ad36 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -94,6 +94,20 @@ (define-public go-keyify
(description "This package turns unkeyed struct literals (@code{T{1, 2,
3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+(define-public go-staticcheck
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-staticcheck")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/staticcheck"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Staticcheck advanced Go linter")
+ (description
+ "Staticcheck is a state of the art linter for the Go programming language.
+Using static analysis, it finds bugs and performance issues, offers
+simplifications, and enforces style rules.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 4/7] gnu: Add go-structlayout.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-4-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout): New variable.

Change-Id: I7440cdf75238fc73451cefc73b3ce3eb3d4da323
---
gnu/packages/golang-check.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 669e61ad36..e55520d52e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -108,6 +108,20 @@ (define-public go-staticcheck
Using static analysis, it finds bugs and performance issues, offers
simplifications, and enforces style rules.")))
+(define-public go-structlayout
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Display the layout (field sizes and padding) of structs in Go.")
+ (description "This package prints the layout of a struct in Go, which is
+the byte offset and size of each field, respecting padding. This information
+is printed in human-readable form by default, or as JSON with the @code{-json}
+flag.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 5/7] gnu: Add go-structlayout-optimize.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-5-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout-optimize): New variable.

Change-Id: I7e1ce9acbe3ec09cc8b441de4816b247a2742938
---
gnu/packages/golang-check.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index e55520d52e..3bfc7e679f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -122,6 +122,19 @@ (define-public go-structlayout
is printed in human-readable form by default, or as JSON with the @code{-json}
flag.")))
+(define-public go-structlayout-optimize
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout-optimize")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout-optimize"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Reorder struct fields to minimize the amount of padding in Go.")
+ (description "This package reads @code{go-structlayout} JSON on stdin and
+reorders fields to minimize the amount of padding. It can emit JSON to feed
+into @code{go-structlayout-pretty}.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 6/7] gnu: Add go-structlayout-pretty.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-6-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout-pretty): New variable.

Change-Id: I622a991b12708ee52eb412a3c6b3fbeeb512843d
---
gnu/packages/golang-check.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 3bfc7e679f..b767fc3254 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -135,6 +135,18 @@ (define-public go-structlayout-optimize
reorders fields to minimize the amount of padding. It can emit JSON to feed
into @code{go-structlayout-pretty}.")))
+(define-public go-structlayout-pretty
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout-pretty")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Format the output of go-structlayout with ASCII art in Go.")
+ (description "This package takes @code{go-structlayout}-like JSON and
+prints an ASCII fraphic representing the memory layout.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 18:24 +0100
[PATCH 7/7] gnu: go-honnef-co-go-tools: Improve synopsis and description.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127172428.18351-7-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-honnef-co-go-tools): Improve
synopsis and description.

Change-Id: I357626457418f8c6f1b05918226c33f7faa88d49
---
gnu/packages/golang-check.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b767fc3254..703aab8e33 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -75,11 +75,10 @@ (define-public go-honnef-co-go-tools
go-golang-org-x-mod
go-golang-org-x-tools))
(home-page "https://honnef.co/go/tools")
- (synopsis "Staticcheck advanced Go linter")
+ (synopsis "Staticcheck advanced Go linter library")
(description
- "Staticcheck is a state of the art linter for the Go programming language.
-Using static analysis, it finds bugs and performance issues, offers
-simplifications, and enforces style rules.")
+ "This package provides the Go source code for the @code{go-staticcheck}
+advanced Go linter.")
(license license:expat)))
(define-public go-keyify
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 1/7] gnu: Remove go-github-com-kisielk-gotool.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-1-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-github-com-kisielk-gotool): Delete variable.

Change-Id: Ic99bba40f4cd66335656f27bf7dd97d1b90bb8f1
---
gnu/packages/golang-check.scm | 1 -
gnu/packages/golang.scm | 24 ------------------------
2 files changed, 25 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index ec886985d6..b8944b367e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -71,7 +71,6 @@ (define-public go-honnef-co-go-tools
(delete 'build))))
(propagated-inputs
(list go-github-com-burntsushi-toml
- go-github-com-kisielk-gotool
go-golang-org-x-exp
go-golang-org-x-mod
go-golang-org-x-tools))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8fea581248..f38684dc68 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10914,30 +10914,6 @@ (define-public go-mvdan-cc-xurls
(native-inputs '())
(inputs '())))
-(define-public go-github-com-kisielk-gotool
- (package
- (name "go-github-com-kisielk-gotool")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kisielk/gotool")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "14af2pa0ssyp8bp2mvdw184s5wcysk6akil3wzxmr05wwy951iwn"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/kisielk/gotool"))
- (home-page "https://github.com/kisielk/gotool")
- (synopsis "Go library of utility functions")
- (description
- "This package contains utility functions used to implement the standard
-@code{cmd/go} tool, provided as a convenience to developers who want to write
-tools with similar semantics.")
- (license license:expat)))
-
(define-public go-go-uber-org-zap
(package
(name "go-go-uber-org-zap")
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 2/7] gnu: Add go-keyify.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-2-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-keyify): New variable.

Change-Id: I99d41a18cb0e00dd35bef9c2c8fce12748f24ad4
---
gnu/packages/golang-check.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b8944b367e..6de21c7b5a 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -82,6 +82,18 @@ (define-public go-honnef-co-go-tools
simplifications, and enforces style rules.")
(license license:expat)))
+(define-public go-keyify
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-keyify")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/keyify"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Transform an unkeyed struct literal into a keyed one in Go.")
+ (description "This package turns unkeyed struct literals (@code{T{1, 2,
+3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 3/7] gnu: Add go-staticcheck.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-3-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-staticcheck): New variable.

Change-Id: I82ce27df1bdbd79ae4740928e0661b585289d02b
---
gnu/packages/golang-check.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 6de21c7b5a..66114050f3 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -94,6 +94,21 @@ (define-public go-keyify
(description "This package turns unkeyed struct literals (@code{T{1, 2,
3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+(define-public go-staticcheck
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-staticcheck")
+ (arguments
+ `(#:go ,go-1.18
+ #:import-path "honnef.co/go/tools/cmd/staticcheck"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Staticcheck advanced Go linter")
+ (description
+ "Staticcheck is a state of the art linter for the Go programming language.
+Using static analysis, it finds bugs and performance issues, offers
+simplifications, and enforces style rules.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 5/7] gnu: Add go-structlayout-optimize.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-5-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout-optimize): New variable.

Change-Id: I7e1ce9acbe3ec09cc8b441de4816b247a2742938
---
gnu/packages/golang-check.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 13f38dc249..2621d6b95b 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -123,6 +123,19 @@ (define-public go-structlayout
is printed in human-readable form by default, or as JSON with the @code{-json}
flag.")))
+(define-public go-structlayout-optimize
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout-optimize")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout-optimize"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Reorder struct fields to minimize the amount of padding in Go.")
+ (description "This package reads @code{go-structlayout} JSON on stdin and
+reorders fields to minimize the amount of padding. It can emit JSON to feed
+into @code{go-structlayout-pretty}.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 4/7] gnu: Add go-structlayout.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-4-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout): New variable.

Change-Id: I7440cdf75238fc73451cefc73b3ce3eb3d4da323
---
gnu/packages/golang-check.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 66114050f3..13f38dc249 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -109,6 +109,20 @@ (define-public go-staticcheck
Using static analysis, it finds bugs and performance issues, offers
simplifications, and enforces style rules.")))
+(define-public go-structlayout
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Display the layout (field sizes and padding) of structs in Go.")
+ (description "This package prints the layout of a struct in Go, which is
+the byte offset and size of each field, respecting padding. This information
+is printed in human-readable form by default, or as JSON with the @code{-json}
+flag.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 6/7] gnu: Add go-structlayout-pretty.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-6-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-structlayout-pretty): New variable.

Change-Id: I622a991b12708ee52eb412a3c6b3fbeeb512843d
---
gnu/packages/golang-check.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 2621d6b95b..bf9730a636 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -136,6 +136,18 @@ (define-public go-structlayout-optimize
reorders fields to minimize the amount of padding. It can emit JSON to feed
into @code{go-structlayout-pretty}.")))
+(define-public go-structlayout-pretty
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout-pretty")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Format the output of go-structlayout with ASCII art in Go.")
+ (description "This package takes @code{go-structlayout}-like JSON and
+prints an ASCII fraphic representing the memory layout.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jan 19:21 +0100
[PATCH v2 7/7] gnu: go-honnef-co-go-tools: Improve synopsis and description.
(address . 68763@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240127182134.6393-7-ngraves@ngraves.fr
* gnu/packages/golang-check.scm (go-honnef-co-go-tools): Improve
synopsis and description.

Change-Id: I357626457418f8c6f1b05918226c33f7faa88d49
---
gnu/packages/golang-check.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index bf9730a636..fc73462f94 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -75,11 +75,10 @@ (define-public go-honnef-co-go-tools
go-golang-org-x-mod
go-golang-org-x-tools))
(home-page "https://honnef.co/go/tools")
- (synopsis "Staticcheck advanced Go linter")
+ (synopsis "Staticcheck advanced Go linter library")
(description
- "Staticcheck is a state of the art linter for the Go programming language.
-Using static analysis, it finds bugs and performance issues, offers
-simplifications, and enforces style rules.")
+ "This package provides the Go source code for the @code{go-staticcheck}
+advanced Go linter.")
(license license:expat)))
(define-public go-keyify
--
2.41.0
S
S
Sharlatan Hellseher wrote on 30 Jan 00:17 +0100
[PATCH 0/7] gnu: Improve go-honnef-co-go-tools definition.
(address . 68763@debbugs.gnu.org)
87y1c7sp99.fsf@gmail.com
Hi Nicolas,

Thank you for the patches.


I started reviewing them, and I've faced with this naming puzzle I
could resolved. Do we need 'go-' prefix for the packages providing end
user executables e.g. 'go-structlayout-optimize'?

Some rational for not using 'go-' prefix for final command: there are
some examples like 'kubo', 'nsq' or 'docker' which are not prefixed. How
about to drop it and keep 'go-<module-name>' convention for the
module/library package which the final one inherited from?

Regards,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW4MiIACgkQdtcnv/Ys
0rXbyRAAgHJNd2jVzhj2hFAm2pMNMtSG5BReATzp9bqkhqx98yP9kmyKTbmBNrps
TSzgW9OdV0OJa1LHk96LsZmynxJ1zVc7UakVXLq5tNhP2I5qkriTFCIrkSeG1Mxm
a5tSyetaZh+9qIrzNw8kxvV5zB/X2A97h33jDUxRPPKQW5VXJf0kHbiPfzVrnOWv
2SfiQI294ww4s4R0HJrndwQs2P+CVSxyQjNUb10qT3Dkj+IMXXYSkD0hpjwrcCRf
fMm6B4xWnJzDLKJnINl44nC7QMeH23zOS5sx3QNPr5AslUwWGwHfvXyFWUOlSwSB
V0bP52lCTvLS1KMAYOsDJEslAt6rsHCjQ/OxM/zmScx4PJzH5c0LKDWFw9qyBdsu
LyNlUstCPSwATQIR777ZAxz6e5uRGkNdvgLu/UAIpocBiMj20WveLBK3tCze8/Lw
fVauSKDGtzynPgfSC16qvHE4WxtgeVXcAMFwx59MVmWk54GPjgFhehPf9UMJyIzl
pVHSy+4zhqH7f1EzD32QZx3B12alulCu39Jp81kqn1/wdnsBH5TQ6uXFICgjXewC
WMWLkZkP25op3ML0e9Y2Ol44AvvqLl/hByFLabO6r6zxaWWPDH3aaveUEJqbAQ5Q
e6a18kJ0zjoAdbQcY12ugA8xVyNOI0DuKCj33q/s8hA/Rpqlu4k=
=4Ie8
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 31 Jan 23:08 +0100
(address . 68763-done@debbugs.gnu.org)
87jznprw98.fsf@gmail.com
Hi Nicolas,

I've applied some fixes higlighted by guix lint, and pushed as
eab88f2e45..6d5fe89e8e to master

- go-honnef-co-go-tool [1/1]
- [X] URI https://honnef.co/go/toolsreturned suspiciously small file (333 bytes)

- no period allowed at the end of the synopsis [4/4]
- [X] go-structlayout-pretty
- [X] go-structlayout-optimize
- [X] go-structlayout
- [X] go-keyify

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW6xPMACgkQdtcnv/Ys
0rUrRRAAgtRthHKiThlq8uK6ygV0ElBJIK8Fb2kB9sr5HswTIPVHTd5rDM0YJgxg
Egw7IL/2WJNW3pMV6MQelHMC7hMVHYdkrsUzpzV1dzv1slNoPH0XAky4kmx+/Nos
0XR4O1D8dHtBgsAFBMRKELx0UtFcbB3i064UcY6y4zAZyxKqJX6+Ph0+d/mTulW3
uaMWMkTMy1tOWtDDxuGTm0/RzaS0w9slJrvTyoki9WdriErrSfkqHt726KBxpyHq
xieghEGDPPjy9HGneeJqp5jy06ApVSDZ8lFm0gZ36asJJ7/2maeat2jAVVkyRsEp
1bujo7w+bLGVbyNDjnD6AZjYThVkPOZ4zVl5jD7LIIU57IlPwYoLGZQVCsgiAAJ7
uRDcC8Zkx0lboqcoE3Uha3es/HENVgLtSxMPmDOn4QSfKXbl2/UJjBqcFMrs41fF
6Xen8YRWmid45v3Uynjf7UUAEnhHFIRZY5+l8ziQMBmCXE3h26xIz7Ch5rMzWYpi
COmLrDAm9eEE9gslqK3eJtXHPmKqDxSTlaoty/+SQOFaTrLUSt5gHmY6EE0CRpcA
9hLFp8c2e22rWWZkcOZFXkaKXmEk4lomzk0dQGvsrezng/Zt6xYIEGFuv7uofZGk
w/VHB1BneoVo32aBFMAsjUpjF+WNaNIpP+BHsE+86EFsGesHtUY=
=1Od6
-----END PGP SIGNATURE-----

Closed
?