[PATCH] gnu: river: add river.desktop on wayland-sessions

  • Done
  • quality assurance status badge
Details
3 participants
  • Erik Eduardo
  • Ekaitz Zarraga
  • Christopher Baines
Owner
unassigned
Submitted by
Erik Eduardo
Severity
normal

Debbugs page

Erik Eduardo wrote 1 years ago
(address . guix-patches@gnu.org)(name . Erik Eduardo)(address . erikeah@protonmail.com)
f2f2742f98cc9d7b54c371b5c7221d93ef0dcdf2.1706288949.git.eduarskate8@gmail.com
From: Erik Eduardo <erikeah@protonmail.com>

This patch will allow to login from login managers or display managers
to River.

Changes:

- Creates a directory at share named wayland-sessions
- Install a desktop file from repo inside share/wayland-sessions

This is my first patch, please be patient and give me feedback, I will
do my best.

Change-Id: Iea8999cf97bedc8fb7ede4dd22b8f0f9529d2fa1
---
gnu/packages/zig-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..ca73c6bad8 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -52,7 +52,16 @@ (define-public river
(build-system zig-build-system)
(arguments
(list
- #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (wayland-sessions (string-append out
+ "/share/wayland-sessions")))
+ (mkdir-p wayland-sessions)
+ (install-file "contrib/river.desktop"
+ wayland-sessions)))))
+ #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
#:zig-release-type "safe"))
(native-inputs (list libevdev
libxkbcommon

base-commit: 2266754382bce43789976aec65181cb5085c8bc4
--
2.41.0
Ekaitz Zarraga wrote 1 years ago
(name . Erik Eduardo)(address . eduarskate8@gmail.com)(address . 68742@debbugs.gnu.org)(name . Erik Eduardo)(address . erikeah@protonmail.com)
b3b2ad21-3927-97f7-d867-5054916213e4@elenq.tech
Hi

On 2024-01-26 18:09, Erik Eduardo wrote:
Toggle quote (44 lines)
> From: Erik Eduardo <erikeah@protonmail.com>
>
> This patch will allow to login from login managers or display managers
> to River.
>
> Changes:
>
> - Creates a directory at share named wayland-sessions
> - Install a desktop file from repo inside share/wayland-sessions
>
> This is my first patch, please be patient and give me feedback, I will
> do my best.
>
> Change-Id: Iea8999cf97bedc8fb7ede4dd22b8f0f9529d2fa1
> ---
> gnu/packages/zig-xyz.scm | 11 ++++++++++-
> 1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 200b5c9940..ca73c6bad8 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -52,7 +52,16 @@ (define-public river
> (build-system zig-build-system)
> (arguments
> (list
> - #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> + #:phases #~(modify-phases %standard-phases
> + (add-after 'install 'install-extra-files
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (wayland-sessions (string-append out
> + "/share/wayland-sessions")))
> + (mkdir-p wayland-sessions)
> + (install-file "contrib/river.desktop"
> + wayland-sessions)))))
> + #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> #:zig-release-type "safe"))
> (native-inputs (list libevdev
> libxkbcommon
>
> base-commit: 2266754382bce43789976aec65181cb5085c8bc4


Looks good to me, but guix commits follow changelog format:


The rest of it looks ok. Please resend with the message fixed and I'll
take a further look.

Thanks a lot for contributing to Guix.

Ekaitz
Erik Eduardo wrote 1 years ago
[PATCH] gnu: river: Add river.desktop file.
(address . 68742@debbugs.gnu.org)(name . Erik Eduardo)(address . erikeah@protonmail.com)
9c8ceac6e513f6c71f93c949db7db70788d3ae56.1706689939.git.eduarskate8@gmail.com
From: Erik Eduardo <erikeah@protonmail.com>

* gnu/packages/zig-xyz.scm (river)[arguments]: Add 'install-extra-files
phase after 'install phase to install the river.desktop file inside
share/wayland-sessions directory.

Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
---
gnu/packages/zig-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..ca73c6bad8 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -52,7 +52,16 @@ (define-public river
(build-system zig-build-system)
(arguments
(list
- #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (wayland-sessions (string-append out
+ "/share/wayland-sessions")))
+ (mkdir-p wayland-sessions)
+ (install-file "contrib/river.desktop"
+ wayland-sessions)))))
+ #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
#:zig-release-type "safe"))
(native-inputs (list libevdev
libxkbcommon

base-commit: 66dd088d3c3404f5cbe2d4d4c5e8f93d184703b0
--
2.41.0

Thanks a lot for the welcoming! Here it's the patch with commit message fixed.
Erik Eduardo wrote 1 years ago
[PATCH v3] gnu: river: Add river.desktop file.
(address . 68742@debbugs.gnu.org)(name . Erik Eduardo)(address . erikeah@protonmail.com)
53bd1ea6e9a06df4f89c8caf394f5cfac9fc1a75.1707413520.git.erikeah@protonmail.com
* gnu/packages/zig-xyz.scm (river)[arguments]: Add
'install-wayland-session phase after 'install phase to install the
river.desktop file inside share/wayland-sessions directory

Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
---
gnu/packages/zig-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..8343555660 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -52,7 +52,16 @@ (define-public river
(build-system zig-build-system)
(arguments
(list
- #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-wayland-session
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (wayland-sessions (string-append out
+ "/share/wayland-sessions")))
+ (mkdir-p wayland-sessions)
+ (install-file "contrib/river.desktop"
+ wayland-sessions)))))
+ #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
#:zig-release-type "safe"))
(native-inputs (list libevdev
libxkbcommon

base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Ekaitz Zarraga wrote 1 years ago
(name . Erik Eduardo)(address . eduarskate8@gmail.com)(address . 68742@debbugs.gnu.org)
6033984d-30b0-1109-968b-5adeda61417c@elenq.tech
Hi,

On 2024-02-08 18:32, Erik Eduardo wrote:
Toggle quote (35 lines)
> * gnu/packages/zig-xyz.scm (river)[arguments]: Add
> 'install-wayland-session phase after 'install phase to install the
> river.desktop file inside share/wayland-sessions directory
>
> Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
> ---
> gnu/packages/zig-xyz.scm | 11 ++++++++++-
> 1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 200b5c9940..8343555660 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -52,7 +52,16 @@ (define-public river
> (build-system zig-build-system)
> (arguments
> (list
> - #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> + #:phases #~(modify-phases %standard-phases
> + (add-after 'install 'install-wayland-session
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (wayland-sessions (string-append out
> + "/share/wayland-sessions")))
> + (mkdir-p wayland-sessions)
> + (install-file "contrib/river.desktop"
> + wayland-sessions)))))
> + #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> #:zig-release-type "safe"))
> (native-inputs (list libevdev
> libxkbcommon
>
> base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d


Looks good to me. But I don't have commit access.

If I get access I'll push. Also if someone wants to push this, I'll be
grateful.

Let's hope it is pushed soon.

Thanks!
Ekaitz Zarraga wrote 1 years ago
(name . Erik Eduardo)(address . eduarskate8@gmail.com)(address . 68742@debbugs.gnu.org)(name . Erik Eduardo)(address . erikeah@protonmail.com)
2f0279dd-725d-22fe-09c6-034c6f1f96b5@elenq.tech
On 2024-02-08 18:32, Erik Eduardo wrote:
Toggle quote (34 lines)
> * gnu/packages/zig-xyz.scm (river)[arguments]: Add
> 'install-wayland-session phase after 'install phase to install the
> river.desktop file inside share/wayland-sessions directory
>
> Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
> ---
> gnu/packages/zig-xyz.scm | 11 ++++++++++-
> 1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 200b5c9940..8343555660 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -52,7 +52,16 @@ (define-public river
> (build-system zig-build-system)
> (arguments
> (list
> - #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> + #:phases #~(modify-phases %standard-phases
> + (add-after 'install 'install-wayland-session
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (wayland-sessions (string-append out
> + "/share/wayland-sessions")))
> + (mkdir-p wayland-sessions)
> + (install-file "contrib/river.desktop"
> + wayland-sessions)))))
> + #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
> #:zig-release-type "safe"))
> (native-inputs (list libevdev
> libxkbcommon
>
> base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d

Oh Erik!
But we are missing something very important here!

Add your copyright header to the top of the file, the rest of us feel
alone there in the top. We need some company.

You can also use `#$output` instead of `(assoc-ref outputs "out")`,
which might be cool to use, as you are already using a gexp in the
phases for example.

Please send a new version and I'll mark it as reviewed (now I learned
how to do it :) )

Best,
Ekaitz
Erik Eduardo wrote 1 years ago
[PATCH v4] gnu: river: Add river.desktop file.
(address . 68742@debbugs.gnu.org)(name . Erik Eduardo)(address . erik@erikeduardo.xyz)
9e331205853e508c520247aeb8b1c601b1aa1517.1707913195.git.erik@erikeduardo.xyz
* gnu/packages/zig-xyz.scm (river)[arguments]: Add
'install-wayland-session phase after 'install phase to install the
river.desktop file inside share/wayland-sessions directory

Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
---
gnu/packages/zig-xyz.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..0e2053b931 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2024 Erik Eduardo <erik@erikeduardo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,7 +53,16 @@ (define-public river
(build-system zig-build-system)
(arguments
(list
- #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-wayland-session
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (wayland-sessions (string-append out
+ "/share/wayland-sessions")))
+ (mkdir-p wayland-sessions)
+ (install-file "contrib/river.desktop"
+ wayland-sessions)))))
+ #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
#:zig-release-type "safe"))
(native-inputs (list libevdev
libxkbcommon

base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d
--
2.41.0
Ekaitz Zarraga wrote 1 years ago
QA review for 68742
(address . control@debbugs.gnu.org)(address . 68742@debbugs.gnu.org)
18af450b-4585-c935-487f-7d3c59b80822@elenq.tech
user guix
usertag 68742 + reviewed-looks-good
thanks

Guix QA review form submission:
It's a simple addition. I think it's ok.
I linted, and I also built, and things the author expected work.

Items marked as checked: Lint warnings, Package builds, Commit messages
Christopher Baines wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)(name . Erik Eduardo)(address . eduarskate8@gmail.com)(address . 68742-done@debbugs.gnu.org)(address . guix-patches@gnu.org)
87jzn7891c.fsf@cbaines.net
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (10 lines)
> user guix
> usertag 68742 + reviewed-looks-good
> thanks
>
> Guix QA review form submission:
> It's a simple addition. I think it's ok.
> I linted, and I also built, and things the author expected work.
>
> Items marked as checked: Lint warnings, Package builds, Commit messages

Thanks both, I've tweaked the indentation a little and pushed this to
master as 8d4c3032416c69f883d074f4f6d7bcc9741be75c.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmXMwT9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcnTRAAuXFtl47iIx1mUwdiSl+pRiNWE/8uTyuf
Ctj4Bg6qCFyie9TfwP5oKvNTFdIr2PenBWywFVVpptiOX0FoIBL0lTP71ReNAJ+2
aoab+opnwLNzXSY4PUhICBoVhPYiDZgIJQ2L/6goJh2ytCE/te2yrta67XvV8+Ld
cJKxBC7S4dP1HcJjDtK63etu787Dhrckq4k4PiPzil61bts5ziJJRKK98MCZzY7S
BCiRVGWJFZQpn5SRDXa2ga/WOIEearUmGH8aVayN1+0X210LBitUCbS3fIzGbF+3
igfSit5U9iMlLgeGKUOpSai8Pz2NvN06PfaXmfvStuRzhnrOOstBvR7IGju99/tU
DYWrtipz+CxvwT0mqpqaZ637lzxnyJjP/WZFkJ6GaVZ4q8lc/u48gFpWK9+lcuGx
IA2yyDMwtcJmeLumKU0RUJ68wj7XMI+Xza4blRiMtkSTr9AhVPnAX3BJgLhSL11Y
Lw6tp8T/KF9EEjpDAUSb3c/Gu7OzbmxOW2rPkgADu7j6QfZ9eZlJ6nkAZT15xaer
k8slrqIL9k97amUsl2EVSP2LsoMSQohzge488fywEhXBu4KjR7sQFNB58RcM44UM
i4VhfH660/2osylWAevG3pqBU26IKNcDfAMaIA5PPSsjqT01V9GGgpgj4sIP468u
5cfj1gDuPFM=
=50AG
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 68742@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68742
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help