[PATCH 0/2]gnu: python-trimesh: Update to 4.0.10 and enable tests.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 1 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1706010234.git.sharlatanus@gmail.com
Hi Guix,

I tried to enable tests witch are shipped with PyPI tarball but for some reason
all tests failed, switching to Git checkout helped to pass all of them.

Some tests are disabled, they need some optional, not packed, Python modules.

Thanks,
Oleg

Sharlatan Hellseher (2):
gnu: python-trimesh: Update to 4.0.10.
gnu: python-trimesh: Enable tests.

gnu/packages/python-science.scm | 72 +++++++++++++++++++++++++--------
1 file changed, 55 insertions(+), 17 deletions(-)


base-commit: ffc5fefce370f5fc01091869e13fdf525be1e0c0
prerequisite-patch-id: b6e4f31e6b902a12637454cc1e8e758dccbb880b
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 1/2] gnu: python-trimesh: Update to 4.0.10.
(address . 68672@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
d45987e15c1fe85b11869edcbce06c66b5548ba1.1706010234.git.sharlatanus@gmail.com
* gnu/packages/python-science.scm (python-trimesh): Update to 4.0.10.
[build-system]: Swap to pyproject-build-system.

Change-Id: I757b4c27db9969d42021434883a057debbbc83fd
---
gnu/packages/python-science.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ef65ed537a..7212cafe16 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -393,14 +393,14 @@ (define-public python-tdda
(define-public python-trimesh
(package
(name "python-trimesh")
- (version "3.23.5")
+ (version "4.0.10")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trimesh" version))
(sha256
- (base32 "08967axlnmfv98n05dhrkynyrmcc814hl8184gzzmcy4rjg6dzdx"))))
- (build-system python-build-system)
+ (base32 "1p3cnkajh2zmp6zwn23q3c73jcjlkq61h3r53ys0bmg58l8kpqrn"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-numpy))
(native-inputs
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 2/2] gnu: python-trimesh: Enable tests.
(address . 68672@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
0d36a93b30f85ad0e77ce00ab5b480b53e830a1a.1706010234.git.sharlatanus@gmail.com
* gnu/packages/python-science.scm (python-trimesh): Enable tests and
apply new package style.
[source]: Use git checkout which has working test suit.
[arguments]<#:test-flags>: Disable tests requiring optional Python
modules.
[propagated-inputs]: Add python-chardet, python-colorlog python-httpx
python-jsonschema python-lxml python-networkx python-pillow
python-requests python-rtree python-scipy python-setuptools
python-shapely python-sympy and python-xxhash.

Change-Id: I1aa363053c2d736bc44b8f9071c637256cc2d952
---
gnu/packages/python-science.scm | 68 +++++++++++++++++++++++++--------
1 file changed, 53 insertions(+), 15 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7212cafe16..50b59b7daa 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages python-science)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages gcc)
#:use-module (gnu packages geo)
#:use-module (gnu packages image)
@@ -396,28 +397,65 @@ (define-public python-trimesh
(version "4.0.10")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "trimesh" version))
+ (method git-fetch) ; no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/mikedh/trimesh")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1p3cnkajh2zmp6zwn23q3c73jcjlkq61h3r53ys0bmg58l8kpqrn"))))
+ (base32 "0ry04qaw0pb3hkxv4gmna87jwk97aqangd21wbr2dr4xshmkbyyb"))))
(build-system pyproject-build-system)
- (propagated-inputs
- (list python-numpy))
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" (string-append
+ ;; XXX: When more optional modules are available review
+ ;; disabled tests once again.
+ ;;
+ ;; Disable tests requiring optional, not packed modules.
+ "not test_material_round"
+ " and not test_bezier_example"
+ " and not test_discrete"
+ " and not test_dxf"
+ " and not test_layer"
+ " and not test_multi_nodupe"
+ " and not test_obj_roundtrip"
+ " and not test_roundtrip"
+ " and not test_scene"
+ " and not test_slice_onplane"
+ " and not test_svg"
+ " and not test_svg"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "trimesh/resources/templates/blender_boolean.py.tmpl"
+ (("\\$MESH_PRE")
+ "'$MESH_PRE'")))))))
(native-inputs
(list python-coveralls
python-pyinstrument
python-pytest
python-pytest-cov))
- (arguments
- `(;; TODO: Get tests to work.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-build
- (lambda _
- (substitute* "trimesh/resources/templates/blender_boolean.py.tmpl"
- (("\\$MESH_PRE")
- "'$MESH_PRE'")))))))
+ (propagated-inputs
+ (list python-chardet
+ python-colorlog
+ python-httpx
+ python-jsonschema
+ python-lxml
+ python-networkx
+ python-numpy
+ python-pillow
+ ;; python-pycollada ; not packed yet, optional
+ ;; python-pyglet ; not packed yet, optional
+ python-requests
+ python-rtree
+ python-scipy
+ python-setuptools
+ python-shapely
+ ;; python-svg-path ; not packed yet, optional
+ python-sympy
+ python-xxhash))
(home-page "https://github.com/mikedh/trimesh")
(synopsis "Python library for loading and using triangular meshes")
(description
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 0/2] gnu: python-trimesh: Update to 4.0.10 and enable tests.
(address . 68672-done@debbugs.gnu.org)
87sf2hhx66.fsf@gmail.com
Pushed as a01afbd300...42c7b50e23 to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW23tEACgkQdtcnv/Ys
0rVp3hAAr48k5PK3CXYpWPGQhN3Ib7gy07vo9w7QQDGXgCpUOAm/LeRmzEAnZ4OW
WrDWJz/W1GfltlnEsAwnR0MggwN7VBtno/QYlZDk5kznHbJaKZpve8Dukvb6K99d
0KZIZ0PEYZTUi2VLPm9gThEQT3IgqzJ3C1HFwyEXuhcVXEPiEofl2uQpn20Pm+Q7
/9aBzeoZuyQ0x3BIQyowV/SVMqPvVpqQdUpNv5Ve20c9/4bemRoImw5glCM5BdHd
u/7U7Mg25DmzrGtFTR0m7bKCgDrxIswd++SJlsIIxoEu1eFRui9gwj4OYdTi36+v
DwvK2bE/vFdOA0JqpS5tus8eHAqsu7B89Rk26YRgrmsQ3XauKy37XA65faFHr8GS
uvcj3QNr6qxtldOAiz4wwNUqR6G8c0/Wo6C8sfVzGpE4RKARNVXk7xCV2QBffr00
Ee0JFEY0UbXlYi3teFdDbWYiyjWkzJ1uGyAekKEktL665uQF6boxfBIZSJwX8wBy
DbyNTlFsXHPEl8sAofgFoUJ2vqpy+gfmkZuqVBvplBe7hKnbXLjV/sQ7GlmjPIdm
GkJwB86jbgehBXWim2ONQXeE7v55W7zpfw5zjJXx1+I7e3kceHgiHTwzfmrNRfsT
Gu3k4rShTr+n9wFurT2YolQNW816Ci5ICTpsGKCIOMJgqGt3mfg=
=DNPA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68672@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68672
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help