[PATCH 0/1] scripts: describe: Support 'channels-sans-intro' format for local checkouts.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 1 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cover.1705994127.git.sarg@sarg.org.ru
Hi guix, I've noticed that `guix describe -f channels-sans-intro` doesn't work for local checkouts:

Toggle snippet (25 lines)
$ guix describe -f channels-sans-intro
Backtrace:
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
7 (apply-smob/0 #<thunk 7faea89112a0>)
In ice-9/boot-9.scm:
724:2 6 (call-with-prompt _ _ #<procedure default-prompt-handle...>)
In ice-9/eval.scm:
619:8 5 (_ #(#(#<directory (guile-user) 7faea8916c80>)))
In guix/ui.scm:
2324:7 4 (run-guix . _)
2287:10 3 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 2 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/describe.scm:
163:4 1 (_)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern" channels-sans-intro)'.


Sergey Trofimov (1):
scripts: describe: Support 'channels-sans-intro' format for local
checkouts.

guix/scripts/describe.scm | 2 ++
1 file changed, 2 insertions(+)


base-commit: ffc5fefce370f5fc01091869e13fdf525be1e0c0
--
2.41.0
Sergey Trofimov wrote 1 years ago
[PATCH 1/1] scripts: describe: Support 'channels-sans-intro' format for local checkouts.
(address . 68669@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
514e0727e1c14fef2c700d380534bf9d9db74f7d.1705994127.git.sarg@sarg.org.ru
* guix/scripts/describe.scm (%display-checkout-info):
Support 'channels-sans-intro' format.
---
guix/scripts/describe.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/guix/scripts/describe.scm b/guix/scripts/describe.scm
index 6d451dc902..449ab4b252 100644
--- a/guix/scripts/describe.scm
+++ b/guix/scripts/describe.scm
@@ -168,6 +168,8 @@ (define (display-checkout-info fmt)
(format #t (G_ " commit: ~a~%") (channel-commit channel)))
('channels
(pretty-print `(list ,(channel->code channel))))
+ ('channels-sans-intro
+ (pretty-print `(list ,(channel->code channel #:include-introduction? #f))))
('json
(display (channel->json channel))
(newline))
--
2.41.0
Ludovic Courtès wrote 1 years ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87plxqs7pi.fsf@gnu.org
Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (3 lines)
> * guix/scripts/describe.scm (%display-checkout-info):
> Support 'channels-sans-intro' format.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68669@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68669
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help