[PATCH 0/3] gnu: Add python-zodb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal
T
T
Troy Figiel wrote on 21 Jan 22:19 +0100
(address . guix-patches@gnu.org)
87edeaidtd.fsf@troyfigiel.com
This series of patches add python-zodb and its required dependencies.

Troy Figiel (3):
gnu: Add python-zconfig.
gnu: Add python-zodbpickle.
gnu: Add python-zodb.

gnu/packages/python-web.scm | 117 ++++++++++++++++++++++++++++++++++++
1 file changed, 117 insertions(+)


base-commit: 121de47decc1029c06f6e46e5f06d7fefe8e85ec
--
2.42.0
T
T
Troy Figiel wrote on 21 Jan 22:12 +0100
[PATCH 1/3] gnu: Add python-zconfig.
(address . 68649@debbugs.gnu.org)
87cytuidq6.fsf@troyfigiel.com
* gnu/packages/python-web.scm (python-zconfig): New variable.
---
gnu/packages/python-web.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c7303fa99..91e60bad8b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2651,6 +2651,44 @@ (define-public python-zc-lockfile
files. These locks can also be used to mediate access to other files.")
(license license:zpl2.1)))
+(define-public python-zconfig
+ (package
+ (name "python-zconfig")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ZConfig" version))
+ (sha256
+ (base32 "0mh13p38vq7ip4zkvaplzr8w0mqrmmqiyb5y663d165slvxl5mpq"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ ;; This test assumes we still have setup.py in the
+ ;; directory from which we import zconfig, which
+ ;; does not work after installing the package.
+ (delete-file-recursively
+ "src/ZConfig/tests/test_readme.py")
+ (invoke "zope-testrunner" "-vv" "--test-path=src"
+ "--all"))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list python-docutils python-manuel python-zope-exceptions
+ python-zope-testrunner))
+ (home-page "https://github.com/zopefoundation/ZConfig/")
+ (synopsis "Structured configuration library intended for general use")
+ (description
+ "@code{zconfig} is a configuration library intended for general
+use. It supports a hierarchical schema-driven configuration model that allows
+a schema to specify data conversion routines written in Python. Its model is
+very different from the model supported by the @code{configparser} module
+found in Python's standard library, and is more suitable to
+configuration-intensive applications.")
+ (license license:zpl2.1)))
+
(define-public python-zope-event
(package
(name "python-zope-event")
--
2.42.0
T
T
Troy Figiel wrote on 21 Jan 22:12 +0100
[PATCH 2/3] gnu: Add python-zodbpickle.
(address . 68649@debbugs.gnu.org)
87bk9eidpu.fsf@troyfigiel.com
* gnu/packages/python-web.scm (python-zodbpickle): New variable.
---
gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 91e60bad8b..4267b417c8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2689,6 +2689,34 @@ (define-public python-zconfig
configuration-intensive applications.")
(license license:zpl2.1)))
+(define-public python-zodbpickle
+ (package
+ (name "python-zodbpickle")
+ (version "3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zodbpickle" version))
+ (sha256
+ (base32 "04fcmdx10lk5ww740avphd1fj5wic2bav9skkavhif670vkk5v5r"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "zope-testrunner" "-vv" "--test-path=src"
+ "--all")
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list python-zope-testrunner))
+ (home-page "https://github.com/zopefoundation/zodbpickle")
+ (synopsis "Uniform pickling interface for @code{zodb}")
+ (description
+ "This package is a fork of the @code{pickle} module (and the
+supporting C extension) from both Python 3.2 and Python 3.3. The fork adds
+support for the @code{noload} operations used by @code{zodb}.")
+ (license (list license:psfl license:zpl2.1))))
+
(define-public python-zope-event
(package
(name "python-zope-event")
--
2.42.0
T
T
Troy Figiel wrote on 21 Jan 22:13 +0100
[PATCH 3/3] gnu: Add python-zodb.
(address . 68649@debbugs.gnu.org)
87a5oyidpi.fsf@troyfigiel.com
* gnu/packages/python-web.scm (python-zodb): New variable.
---
gnu/packages/python-web.scm | 51 +++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4267b417c8..762b7d7bb2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2689,6 +2689,57 @@ (define-public python-zconfig
configuration-intensive applications.")
(license license:zpl2.1)))
+(define-public python-zodb
+ (package
+ (name "python-zodb")
+ (version "5.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ZODB" version))
+ (sha256
+ (base32 "1pv4w8mnx6j4xvkcjbkh99pv8ljby7g9f7zjq7zhdmk06sykmiy6"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ ;; This test does not work after installing the
+ ;; package, since it expects the ZODB source code
+ ;; to reside in the src/ directory.
+ (delete-file-recursively
+ "src/ZODB/tests/testdocumentation.py")
+ (invoke "zope-testrunner" "-vv" "--test-path=src"
+ "--all"))
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-btrees
+ python-persistent
+ python-zconfig
+ python-six
+ python-transaction
+ python-zc-lockfile
+ python-zodbpickle
+ python-zope-interface))
+ (native-inputs (list python-manuel python-zope-testing
+ python-zope-testrunner))
+ (home-page "http://zodb-docs.readthedocs.io")
+ (synopsis "Object-oriented database for Python")
+ (description
+ "@code{ZODB} provides an object-oriented and @acronym{ACID,
+Atomicity Consistency Isolation Durability} compliant database for Python with
+a high degree of transparency. @code{ZODB} is an object-oriented database,
+not an object-relational mapping. This comes with several advantaged:
+
+@itemize
+@item no separate language for database operations
+@item very little impact on your code to make objects persistent
+@item no database mapper that partially hides the database.
+@item almost no seam between code and database.
+@end itemize")
+ (license license:zpl2.1)))
+
(define-public python-zodbpickle
(package
(name "python-zodbpickle")
--
2.42.0
S
S
Sharlatan Hellseher wrote on 15 Mar 00:32 +0100
[PATCH 0/3] gnu: Add python-zodb.
(address . 68649-done@debbugs.gnu.org)
87ttl8ie4r.fsf@gmail.com
Hi,

I've updated python-zodbpickle to 3.2 build and lint passed successfully
for all 3 patches.

Pushed as fb377b4af7..36da1ad73d to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXziPQACgkQdtcnv/Ys
0rVyXBAAjtYhoYNysAJEDTHUNWRH82qAuKVUMQTI/tTYcRTNdVQFcs1BrjEhOU3F
/CAROaeQFYYDBFZKFWI1/pCTeqVK3nnZYSJOj1RKyPHpBff/Gi8tumVRnchggfuE
3UoP6gklmsTGHsLw1TFY1FDohawmeJWD2UPOee9E8FgKr0zk1SWXOg3SZe+Q8EVH
pXnZyfe2mXii+oMas5NFStWlvPsVJPs0SZphvj5mrvPVD0jreDV7Msb0oEEseH85
NXyjn2IY0aFLznZJ/pxJqI509dAg8pkmQtceYvU6Jgh/Xjl7yfgjzMc+JVqWSPy7
Gtj43Xu0m8qLJNNnu1G1ObJBniXpvgVWBj5bOeREy12pWWdDWWrSuWluTjQWKUSV
JNeQWnQuCK8UoyzJWLl8j4qNPtp/L8tTmJ3tEtk1I8bpACrY0qyQbIGZ6hOD184w
NgAY/8odbaQm3hXt3LFtaKQLICq53/8qbqLnKFBXvZ5zVemFJX2QRiXeXTScq0fN
VVpzCEHnnwCvCEJvcOMBoevfXWlLDcogqQzvErip+Sn+jQLlI1ni+VLscUnsXnnp
Oet1GxLoN7dbW5orFSN/uazSKnzTZwtaNoknULLe2wN98v+xyeC1x85kHVaHg0Vj
J07/c4Y7aKytEzm6C2BcaBYgah/RtLjr8KoYKdWaSJqz/Nog5hE=
=IRs1
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68649@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68649
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch