[PATCH] gnu: Add python-pandas-vet.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87fryqiorz.fsf@troyfigiel.com
* gnu/packages/python-xyz.scm (python-pandas-vet): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b23108fbf4..dfd786e283 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13876,6 +13876,31 @@ (define-public python-flake8-isort
directives.")
(license license:gpl2+)))
+(define-public python-pandas-vet
+ (package
+ (name "python-pandas-vet")
+ ;; Newer versions require flake8>=6.0.0.
+ (version "0.2.3")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deppen8/pandas-vet")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b3pqcargv68p2lpv72q49siq6mxfh3znxhz9vd91rp6fd6lf2cz"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-attrs python-flake8))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/deppen8/pandas-vet")
+ (synopsis "Opionated @code{flake8} plugin for @code{pandas} code")
+ (description
+ "This package provides a @code{flake8} plugin to lint @code{pandas} code
+in an opinionated way.")
+ (license license:expat)))
+
(define-public python-autoflake
(package
(name "python-autoflake")

base-commit: 121de47decc1029c06f6e46e5f06d7fefe8e85ec
--
2.42.0
Sharlatan Hellseher wrote 1 years ago
(address . 68642@debbugs.gnu.org)
CAO+9K5rc1_v6xu-ML-aRkjpKDDtLuyxrzpBRwaU4O_Yi03Cgsg@mail.gmail.com
Hi,

Thank you for the patch!

I started reviewing it, it looks good. I've got question on placement:
- python-science next to pandas
or
- python-check as it is related to lint

What do you think?

Regards,
Oleg
Attachment: file
Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
90fee839-ea5b-4b52-9657-86d9f1cbb85c@troyfigiel.com
Hi Oleg,

Originally I put it under python-xyz, because it is a flake8 plugin and
most if not all flake8 plugins are defined in python-xyz.

It does indeed make more sense to have all flake8-related packages in
python-check instead, since it is a linting library. python-pylint is
defined under python-check for example.

For that reason, I would also advise against putting python-pandas-vet
in python-science. I leave the final placement up to you though :-)

Best wishes,

Troy
Sharlatan Hellseher wrote 1 years ago
[PATCH] gnu: Add python-pandas-vet.
(address . 68642-done@debbugs.gnu.org)
87a5o6r9rq.fsf@gmail.com
Hi,

I've added the package to python-check based on it's purpose.

Pushed as 579a1a8c029e97b69a7e3597ff9fd287805cf644 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXJNskACgkQdtcnv/Ys
0rUwtA//TyxXUf9N6ng2N5BC9XC/uDXWCH6Pl6xJ3LiP8aQ1uQUHncPasowzk1fF
xwmoqxkz94E7d55rqNY0vpc9YyHv7g9j+uWWtIUG/5ODH3X8VG37abCX88yndWSl
m9HBy0bjZKu/Dl7Q7Qak4kG0ujrPEOXdQAZxy1jttr9P3yyw6fIUdPWr1ipYG4UC
j4m1B9n8uvCc4hqtFCtpA7AOk5yI1X/TkbfQ3oqcgFRPo4zNrqbtEes8ecORcrRb
iSDdPGS86q663gkhmZf7ax3QbFDtaMn1h7Esjoaqf/PDw8UPqq6K3cLS3u9Rud8Y
x49J/iexWeeVuea+fKbuTjab+9djyKAN6ZXdwTp6BM4AxOTne+sLi9a9jMWOFKSo
5FMcBwqviWA5DUbLcMVCh+Z5bEAWhawzph6ME2phSL0NN96Lf102OdL4HXWy/bAq
v2qMMPj1+m7PRQsbLwCZ9mWeWRohVPtgxviXqIGjUTYMYOsuzyRqt3ZgZ9Hoa9Kw
xV2rXd33Mhp4iCl8iy7rjKmOq3SCTs5VSi7vUAD94XGncMP+eAvM70P8FWHRdYvZ
egS+WoHih+TdZXMSx6Om/tNY+6Svmp4rOYzmjyrOpm0kaDv3W/7aYiHlUA/L4CM0
RNFvSoyHr8M3rF1aQCVZnCeQwEU1Xgp3b7lHURt+RfkOU3wb9Ms=
=sQQN
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68642@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68642
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help