(address . bug-guix@gnu.org)
Greetings,
I installed Guix on top of Fedora via binary installation with the
`guix-install.sh' shell script. I set SELinux to permissive mode,
rebooted, ran `guix pull', `guix package -u`, and installed three
packages:
- hello
- glibc-locales
- guile
Before installing Guix I compiled Emacs and installed various packages
via melpa as well as separate programs with dnf (Fedora's package
manager) that inlcude many info manuals in /usr/local/share/info. Before
the Guix installation, every manual in /usr/local/share/info was being
picked up and included in the `dir' file as expected. However, after
installing Guix it has placed several info manuals in various languages
in /usr/local/share/info and overwrote the dir file to include only Guix
info manuals, all symlinked to
/var/guix/profiles/per-user/root/current-guix/share/info.
I now have significantly less manuals inside emacs when I browse for
documentation via `M-x info'. Though I can open them with dired by
pressing `I' this is significantly less convenient.
I suspect this is either a bug or at the least undesired behavior from
my perspective.
Below is relevant information and attached is the directory listing of
/usr/local/share/info. If anything else is needed please let me know,
thank you.
========================================================================
Fedora version: 39
Guix version/commit: 4532eb6389e0602c1aac2e452bbc085f251658a3
Emacs version: 29.1