[PATCH 0/2] gnu: python-pandera: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87le8kt8c8.fsf@troyfigiel.com
With the 1.5.3 upgrade of python-pandas, python-modin is broken. I tried
fixing it by upgrading it to a compatible version, but this has a ripple
effect on a variety of packages such as python-boto3, python-fsspec,
etc.

For now, I would suggest to simply remove python-modin as a native-input from python-pandera. Since it is an optional dependency in the first place, not much is lost as long as python-modin is broken on master.

Troy Figiel (2):
gnu: python-pandas-stubs: Update to 1.5.3.230321.
gnu: python-pandera: Fix build.

gnu/packages/python-science.scm | 35 +++++++++++++++++++++++----------
1 file changed, 25 insertions(+), 10 deletions(-)


base-commit: 0eadd486484fcf9a234758842f74ba28361640db
--
2.42.0
Troy Figiel wrote 1 years ago
[PATCH 1/2] gnu: python-pandas-stubs: Update to 1.5.3.230321.
(address . 68609@debbugs.gnu.org)
87jzo4t85z.fsf@troyfigiel.com
* gnu/packages/python-science.scm (python-pandas-stubs): Update to
1.5.3.230321.
[arguments]<#:test-flags>: Ignore tests that require a version of
python-pyarrow with ORC integration.
[native-inputs]: Add python-odfpy.
---
gnu/packages/python-science.scm | 20 ++++++++++++++++----
1 file changed, 16 insertions(+), 4 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3c131fe730..4eb0195889 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -580,8 +580,8 @@ (define-public python-pandas-stubs
(name "python-pandas-stubs")
;; The versioning follows that of Pandas and uses the date of the
;; python-pandas-stubs release. This is the latest version of
- ;; python-pandas-stubs for python-pandas 1.4.4.
- (version "1.4.4.220919")
+ ;; python-pandas-stubs for python-pandas 1.5.3.
+ (version "1.5.3.230321")
(source
(origin
;; No tests in the PyPI tarball.
@@ -591,10 +591,21 @@ (define-public python-pandas-stubs
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "14fhj1y71akwl41ws7cpazsbq5b8wf4rwaydqq2h39q7gylpcp99"))))
+ (base32 "1blwlq5053pxnmx721zdd6v8njiybz4azribx2ygq33jcpmknda6"))))
(build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ (list
+ #:test-flags #~(list "-k"
+ (string-append
+ ;; The python-pyarrow package in Guix is not built
+ ;; with ORC integration, causing these tests to
+ ;; fail.
+ "not test_orc"
+ " and not test_orc_path"
+ " and not test_orc_buffer"
+ " and not test_orc_columns"
+ " and not test_orc_bytes"))
+ #:phases '(modify-phases %standard-phases
(add-before 'check 'prepare-x
(lambda _
(system "Xvfb &")
@@ -607,6 +618,7 @@ (define-public python-pandas-stubs
;; tests will be skipped for now.
(native-inputs (list python-lxml
python-matplotlib
+ python-odfpy
python-pandas
python-poetry-core
python-pyarrow
--
2.42.0
Troy Figiel wrote 1 years ago
[PATCH 2/2] gnu: python-pandera: Fix build.
(address . 68609@debbugs.gnu.org)
87il3ot84y.fsf@troyfigiel.com
* gnu/packages/python-science.scm (python-pandera): Fix build.
[source]: Delete tests/modin directory.
[native-inputs]: Remove python-modin.
---
gnu/packages/python-science.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4eb0195889..3422302a87 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -661,16 +661,20 @@ (define-public python-pandera
(sha256
(base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
(modules '((guix build utils)))
- ;; These tests require PySpark. We need to remove the entire directory,
- ;; since the conftest.py in this directory contains a PySpark import.
- ;; (See: https://github.com/pytest-dev/pytest/issues/7452)
- (snippet '(delete-file-recursively "tests/pyspark"))))
+ ;; These tests require PySpark and Modin. We need to remove the entire
+ ;; directory, since the conftest.py in these directories contain
+ ;; imports. (See: https://github.com/pytest-dev/pytest/issues/7452)
+ (snippet '(begin
+ (delete-file-recursively "tests/pyspark")
+ (delete-file-recursively "tests/modin")))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags '(list "-k"
(string-append
- ;; Needs python-pandas >= 1.5
+ ;; Mypy functionality is experimental and relying
+ ;; on pandas-stubs can lead to false
+ ;; positives. These tests currently fail.
"not test_python_std_list_dict_generics"
" and not test_python_std_list_dict_empty_and_none"
" and not test_pandas_modules_importable"))))
@@ -692,7 +696,6 @@ (define-public python-pandera
(native-inputs (list python-dask ;dask extra
python-fastapi ;fastapi extra
python-geopandas ;geopandas extra
- python-modin ;modin extra
python-pyarrow ;needed to run fastapi tests
python-pytest
python-pytest-asyncio
--
2.42.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 0/2] gnu: python-pandera: Fix build.
(address . 68609-done@debbugs.gnu.org)
87edebodtu.fsf@gmail.com
Pushed as e1d3be4113c854d6efdfda6a8c3e5757753425ad

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmWsRP0ACgkQdtcnv/Ys
0rUMNhAAihxwydZvX+OtbUWxElfutv5VltoeRQcDhTidMaxTcc3/K7Xtsdd8HxFa
OvnXMTRTmODrxwoQdhZT7iYPWFLif1ylFTdlUGQPC3o3kB6Ou7X3rMg0srpKEJTW
q1mr9ew0JmHHJ9Ru9OlahJrp6n0vgeRG4NfmPcHvAVwU5v73HEZE3yaREYIY6ojy
mRkwgGuZ8bkKCYWTVR1GDASXf3BMJEjRsA5K1vSQYxIrHwLRk2m/7jgghWw+aYSg
LiANa8NLakkTTFxgS2TFs2CLovdPfD+INRQbW+MdMAP5csSx94ASI+mSx8rn1LqR
QjuUnh0vaWxMTEk8QdcxS2HRXIr8nvSRV+NOPCGGhn58nA+wLZYuWX/qUoVubC9n
nXlK5g0qMyL38MtoB3C2vTPF4ABhnOpl5lVbzeQhiD3aYwSHcGWAzfcLLuBELrAK
G+q+sU3Z4TNYcr0kDmMAw/FG0pUp28MfTjfL5q5GAy6fBe4v7DuYiFqszw3tdOKb
k+rZrwHIDkBff87OCEa0ocf04fcQTwpg4Mg34IEQ47kCWA2Mih6bJ4E4luyY0DX8
h1+YK36IYLbDxRGuFWmPxbTyoB+NDrFv1inTyWBhrI7YmuOLQ+qgRlcPozdMGWhB
TECo94AzLQgsDrQT/hY2SZplNVmYVAmB+S73devdPjBAiBC21jU=
=ED7D
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68609@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68609
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help