[PATCH] gnu: update Chicken Scheme eggs (auto-generated)

  • Open
  • quality assurance status badge
Details
One participant
  • Daniel Ziltener
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal
D
D
Daniel Ziltener wrote on 20 Jan 00:30 +0100
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
3319b2e53cad64e83e020033fcfc92a4@lyrion.ch
---
gnu/packages/chicken.scm | 13272 ++++++++++++++++++++++++++++++++++++-
1 file changed, 13048 insertions(+), 224 deletions(-)

Toggle diff (566 lines)
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 8f5e8ce98d..fe8e0c8f1d 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -1,7 +1,9 @@
+;; -*- geiser-scheme-implementation: guile; mode: scheme; -*-
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Evan Hanson <evhan@foldling.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
+;;; Copyright © 2024 Daniel Ziltener <dziltener@lyrion.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,12 +23,13 @@
(define-module (gnu packages chicken)
#:use-module (gnu packages)
#:use-module (guix packages)
- #:use-module (guix build-system chicken)
+ #:use-module (gnu build-system chicken)
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix svn-download)
#:use-module (gnu packages commencement)
+ #:use-module (gnu packages chicken)
#:use-module ((guix licenses)
#:prefix license:))
@@ -76,298 +79,13119 @@ (define-public chicken
produces portable and efficient C, supports almost all of the R5RS Scheme
language standard, and includes many enhancements and extensions.")
(license license:bsd-3)))
+(define-public
+ chicken-json
+ (package
+ (name "chicken-json")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "json" "1.6"))
+ (sha256
+ (base32 "1h27h6z7awadijk9w51df9dyk3wma27fp180j7xwl27sbw7h76wz"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-packrat" "chicken-srfi-1" "chicken-srfi-69")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "json"))
+ (synopsis "A JSON library")
+ (home-page "https://wiki.call-cc.org/eggref/5/json")
+ (description "A JSON library")
+ (license license:expat)))
+
+(define-public
+ chicken-memoize
+ (package
+ (name "chicken-memoize")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "memoize" "0.3"))
+ (sha256
+ (base32 "1xh9cfxbr28x2kmsr4n54ynmpz9z5wl9b0rc455mhb6ilsl5nyzi"))))
+ (propagated-inputs (specifications->packages (list "chicken-srfi-69")))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "memoize"))
+ (synopsis "Procedures memoization")
+ (home-page "https://wiki.call-cc.org/eggref/5/memoize")
+ (description "Procedures memoization")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-srfi-101
+ (package
+ (name "chicken-srfi-101")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "srfi-101" "0.0.3"))
+ (sha256
+ (base32 "0jfkprl6jxyh2s241x0cmxnqdb3s1bl32jyfqyqzpadbbvrixm56"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-srfi-1" "chicken-srfi-69" "chicken-vector-lib")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "srfi-101"))
+ (synopsis "SRFI 101")
+ (home-page "https://wiki.call-cc.org/eggref/5/srfi-101")
+ (description "SRFI 101")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-srfi-197
+ (package
+ (name "chicken-srfi-197")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "srfi-197" "0.2.0"))
+ (sha256
+ (base32 "19lxc4id9k7hqi1d8fm2mxn32gh18lv35xiash018r6cscz9hh01"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "srfi-197"))
+ (synopsis "SRFI-197: Pipeline Operators")
+ (home-page "https://wiki.call-cc.org/eggref/5/srfi-197")
+ (description "SRFI-197: Pipeline Operators")
+ (license license:expat)))
+
+(define-public
+ chicken-stb-image
+ (package
+ (name "chicken-stb-image")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "stb-image" "0.6"))
+ (sha256
+ (base32 "0h8a8212miihqnd93s6svj3gs5yw7ix787mpzj7bgd34vx5srbsy"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "stb-image"))
+ (synopsis "read png/jpg/tga/bmp/psd/gif/hdr/pic/pnm images into pixels")
+ (home-page "https://wiki.call-cc.org/eggref/5/stb-image")
+ (description "read png/jpg/tga/bmp/psd/gif/hdr/pic/pnm images into pixels")
+ (license license:public-domain)))
+
+(define-public
+ chicken-sdl2-image
+ (package
+ (name "chicken-sdl2-image")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "sdl2-image" "0.2.0"))
+ (sha256
+ (base32 "08kxmx97rw760vlqsfl6s89mjb2gxzynk2fvc6dd0s7spdjvjk34"))))
+ (propagated-inputs (specifications->packages (list "chicken-sdl2")))
+ (native-inputs
+ (specifications->packages (list "chicken-srfi-1" "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "sdl2-image"))
+ (synopsis "Bindings to SDL_image 2")
+ (home-page "https://wiki.call-cc.org/eggref/5/sdl2-image")
+ (description "Bindings to SDL_image 2")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-spiffy-sexpr-log
+ (package
+ (name "chicken-spiffy-sexpr-log")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "spiffy-sexpr-log" "0.3.2"))
+ (sha256
+ (base32 "0z2sxvjgnri80rvlgyajx6hbwdhs6qrxvida05j8dh25xj5kyiyj"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-spiffy" "chicken-srfi-1" "chicken-srfi-13")))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "spiffy-sexpr-log"))
+ (synopsis "Symbolic expression log format for Spiffy")
+ (home-page "https://wiki.call-cc.org/eggref/5/spiffy-sexpr-log")
+ (description "Symbolic expression log format for Spiffy")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-tiny-prolog
+ (package
+ (name "chicken-tiny-prolog")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "tiny-prolog" "2.1"))
+ (sha256
+ (base32 "0zz468zvr7v1dh2sg48kmlq43dbim66md3dv2dchdpzfjg378w8k"))))
+ (propagated-inputs (specifications->packages (list "chicken-srfi-69")))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "tiny-prolog"))
+ (synopsis "Tiny PROLOG interpreter.")
+ (home-page "https://wiki.call-cc.org/eggref/5/tiny-prolog")
+ (description "Tiny PROLOG interpreter.")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-7off
+ (package
+ (name "chicken-7off")
+ (version "1.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "7off" "1.31"))
+ (sha256
+ (base32 "0hsqxva92k3yasrlgl7bbq3z3d2d2nd3r3i2v6vimv7mp2chfkdr"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-anaphora"
+ "chicken-define-options"
+ "chicken-lowdown"
+ "chicken-matchable"
+ "chicken-srfi-1"
+ "chicken-sxml-transforms"
+ "chicken-sxpath"
+ "chicken-utf8"
+ "chicken-srfi-42"
+ "chicken-srfi-69"
+ "chicken-strse"
+ "chicken-uri-common")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "7off"))
+ (synopsis "Markdown to Gemini text")
+ (home-page "https://wiki.call-cc.org/eggref/5/7off")
+ (description "Markdown to Gemini text")
+ (license license:agpl3+)))
+
+(define-public
+ chicken-tiger-hash
+ (package
+ (name "chicken-tiger-hash")
+ (version "4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "tiger-hash" "4.1.2"))
+ (sha256
+ (base32 "0hcmp58byk2wg0nbmb5zh2zc7z670dhva21qjpix6l8hqgrf0151"))))
+ (propagated-inputs
+ (specifications->packages (list "chicken-message-digest-primitive")))
+ (native-inputs
+ (specifications->packages
+ (list "chicken-test"
+ "chicken-test-utils"
+ "chicken-srfi-13"
+ "chicken-message-digest-utils"
+ "chicken-message-digest-primitive")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "tiger-hash"))
+ (synopsis "Tiger/192 Message Digest")
+ (home-page "https://wiki.call-cc.org/eggref/5/tiger-hash")
+ (description "Tiger/192 Message Digest")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-regex
+ (package
+ (name "chicken-regex")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "regex" "2.0"))
+ (sha256
+ (base32 "1hxkva5jvk08wnj3x4lnyxhhyr5vkbs7q99qzpnwmfphbrzmmqzr"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "regex"))
+ (synopsis "Compatibility library for old regular expression API")
+ (home-page "https://wiki.call-cc.org/eggref/5/regex")
+ (description "Compatibility library for old regular expression API")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-leveldb
+ (package
+ (name "chicken-leveldb")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "leveldb" "1.2"))
+ (sha256
+ (base32 "14wjgiaclxm6f3m88fakg5hdpxd1f8d8yzm6vgwv01dd6izqpvfv"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "leveldb"))
+ (synopsis "Bindings to Google's LevelDB Key-Value Store")
+ (home-page "https://wiki.call-cc.org/eggref/5/leveldb")
+ (description "Bindings to Google's LevelDB Key-Value Store")
+ (license license:bsd-2)))
-(define-public chicken-compile-file
+(define-public
+ chicken-expand-full
+ (package
+ (name "chicken-expand-full")
+ (version "2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "expand-full" "2.1.3"))
+ (sha256
+ (base32 "072c5xvmsgkbz5wj4ihj0y4k5fvx9lsz5vjydvzmhnmwd613cg46"))))
+ (propagated-inputs (specifications->packages (list "chicken-srfi-1")))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "expand-full"))
+ (synopsis "Full macro expansion")
+ (home-page "https://wiki.call-cc.org/eggref/5/expand-full")
+ (description "Full macro expansion")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-magic
+ (package
+ (name "chicken-magic")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "magic" "0.1.0"))
+ (sha256
+ (base32 "17j25ckrhpm1k2ivl7qa1k87kylid466bb23ic96h64n111qhhdk"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "magic"))
+ (synopsis "libmagic bindings")
+ (home-page "https://wiki.call-cc.org/eggref/5/magic")
+ (description "libmagic bindings")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-spiffy-request-vars
+ (package
+ (name "chicken-spiffy-request-vars")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "spiffy-request-vars" "0.19"))
+ (sha256
+ (base32 "06wzpmwnn7djr7iz9v8qqn6nrxcddqi4d751ym7g7na4aqypcc80"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-intarweb"
+ "chicken-srfi-1"
+ "chicken-srfi-13"
+ "chicken-srfi-69"
+ "chicken-spiffy"
+ "chicken-uri-common")))
+ (native-inputs
+ (specifications->packages
+ (list "chicken-http-client" "chicken-server-test" "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "spiffy-request-vars"))
+ (synopsis "Easy access to variables from HTTP requests")
+ (home-page "https://wiki.call-cc.org/eggref/5/spiffy-request-vars")
+ (description "Easy access to variables from HTTP requests")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-soil
+ (package
+ (name "chicken-soil")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "soil" "1.6.0"))
+ (sha256
+ (base32 "0h562n1ql23kjwkx5dvsxrzpyc3rnfp61i1mss88kcnrwy6hk6ad"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "soil"))
+ (synopsis
+ "Lightweight, simple library for loading image files into OpenGL-friendly format.")
+ (home-page "https://wiki.call-cc.org/eggref/5/soil")
+ (description
+ "Lightweight, simple library for loading image files into OpenGL-friendly format.")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-tree-walkers
+ (package
+ (name "chicken-tree-walkers")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "tree-walkers" "1.0"))
+ (sha256
+ (base32 "1if8njjaac4i23126jlmzw67y7hcr2hs842nwsgyzi2hi780pzvk"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-simple-tests")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "tree-walkers"))
+ (synopsis "replacement of car, cdr and consorts")
+ (home-page "https://wiki.call-cc.org/eggref/5/tree-walkers")
+ (description "replacement of car, cdr and consorts")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-xml-rpc
+ (package
+ (name "chicken-xml-rpc")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "xml-rpc" "3.0.1"))
+ (sha256
+ (base32 "05qn5fd872q3zh0ic9gq32j8rnvpg6l1p5bj86pdyan1iqxypnsq"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-base64"
+ "chicken-http-client"
+ "chicken-intarweb"
+ "chicken-ssax"
+ "chicken-sxpath"
+ "chicken-srfi-1"
+ "chicken-srfi-13"
+ "chicken-srfi-18"
+ "chicken-srfi-69")))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "xml-rpc"))
+ (synopsis "XML-RPC client/server")
+ (home-page "https://wiki.call-cc.org/eggref/5/xml-rpc")
+ (description "XML-RPC client/server")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-unsafe
+ (package
+ (name "chicken-unsafe")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "unsafe" "1.0"))
+ (sha256
+ (base32 "0nainz77q0a1pzac92dp4nbmpq4g20vqa4qxzaqg86rhy7rpr01x"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "unsafe"))
+ (synopsis "Unsafe operations")
+ (home-page "https://wiki.call-cc.org/eggref/5/unsafe")
+ (description "Unsafe operations")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-icu
+ (package
+ (name "chicken-icu")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "icu" "0.3.3"))
+ (sha256
+ (base32 "1hii4n3mraqaznaiwznwbx06yy99157pxxarkj558zarkn43k82y"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-utf8"
+ "chicken-srfi-13"
+ "chicken-srfi-1"
+ "chicken-foreigners"
+ "chicken-chalk")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "icu"))
+ (synopsis "Chicken bindings to the ICU unicode library")
+ (home-page "https://wiki.call-cc.org/eggref/5/icu")
+ (description "Chicken bindings to the ICU unicode library")
+ (license license:unicode)))
+
+(define-public
+ chicken-simple-timer
+ (package
+ (name "chicken-simple-timer")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "simple-timer" "0.1.2"))
+ (sha256
+ (base32 "1xnkf4xd7hx1lki1nxzkdpwynxx1zry6j8a8cyxk9hb72ygcd9p0"))))
+ (propagated-inputs
+ (specifications->packages
+ (list "chicken-srfi-18" "chicken-pigeon-hole" "chicken-llrb-tree")))
+ (native-inputs
+ (specifications->packages (list "chicken-test" "chicken-matchable")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "simple-timer"))
+ (synopsis "Simple, cancel-able, efficient timer API")
+ (home-page "https://wiki.call-cc.org/eggref/5/simple-timer")
+ (description "Simple, cancel-able, efficient timer API")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-srfi-193
+ (package
+ (name "chicken-srfi-193")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "srfi-193" "0.1.3"))
+ (sha256
+ (base32 "18raq9r8nvs6dvb9fq7095bi9sxh655pjs4k7jwj486369jn90di"))))
+ (propagated-inputs (specifications->packages (list)))
+ (native-inputs (specifications->packages (list "chicken-test")))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "srfi-193"))
+ (synopsis "SRFI 193: Command line")
+ (home-page "https://wiki.call-cc.org/eggref/5/srfi-193")
+ (description "SRFI 193: Command line")
+ (license license:isc)))
+
+(define-public
+ chicken-type-extensions
+ (package
+ (name "chicken-type-extensions")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "type-extensions" "0.1.0"))
+ (sha256
+ (base32 "0l4hp89v0x10is29fczhr6y89qrsd16bgdgbl2pf2l36pmlgqfmr"))))
+ (propagated-inputs (specifications->packages (list "chicken-matchable")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "type-extensions"))
+ (synopsis "Miscellaneous type system extensions")
+ (home-page "https://wiki.call-cc.org/eggref/5/type-extensions")
+ (description "Miscellaneous type system extensions")
+ (license license:bsd-2)))
+
+(define-public
+ chicken-pigeon-hole
+ (package
+ (name "chicken-pigeon-hole")
+ (version "0.2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (egg-uri "pigeon-hole" "0.2.8"))
+ (sha256
+ (base32 "0sz97xznai8a2gsfc2f2aink8rhmksz7iqbl7k061wfgf4w8vrvk"))))
+ (propagated-inputs (specifications->packages (list "chicken-srfi-18")))
+ (native-inputs (specifications->packages (list)))
+ (build-system chicken-build-system)
+
This message was truncated. Download the full message here.
D
D
Daniel Ziltener wrote on 14 Mar 11:50 +0100
GNU Debbugs <control@debbugs.gnu.org>
(address . 68597@debbugs.gnu.org)
652f0d20-1b7a-14b1-cf0a-67c362e7d54b@lyrion.ch
close 68597
thanks
?