[PATCH 0/2] Add emacs-devicetree-ts-mode

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal
A
A
Aleksandr Vityazev wrote on 17 Jan 18:44 +0100
(address . guix-patches@gnu.org)
875xzrkg6n.fsf@disroot.org
gnu: Add emacs-devicetree-ts-mode.
gnu: Add tree-sitter-devicetree.


gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)
gnu/packages/tree-sitter.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

--
Best regards,
Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 17 Jan 19:00 +0100
[PATCH 1/2] gnu: Add tree-sitter-devicetree.
(address . 68542@debbugs.gnu.org)
87y1cnj0vt.fsf@disroot.org
* gnu/packages/tree-sitter.scm (tree-sitter-devicetree): New variable.
Update copyright.
---
gnu/packages/tree-sitter.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 41257d42f1..25f9fdbf18 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2022, 2023 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
-;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022, 2024 Aleksandr Vityazev <avityazev@disroot.org>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
@@ -418,6 +418,14 @@ (define-public tree-sitter-c-sharp
"0lijbi5q49g50ji00p2lb45rvd76h07sif3xjl9b31yyxwillr6l"
"0.20.0"))
+(define-public tree-sitter-devicetree
+ (tree-sitter-grammar
+ "devicetree" "Devicetree"
+ "0igkwrlgbwphn8dwj91fy2film2mxz4kjdjnc141kmwi4czglwbq"
+ "0.8.0"
+ #:repository-url "https://github.com/joelspadin/tree-sitter-devicetree"
+ #:license license:expat))
+
(define-public tree-sitter-dockerfile
(tree-sitter-grammar
"dockerfile" "Dockerfile"

base-commit: b3e0a973bca6fe5de7356f3d70c4b7d468b0a759
--
2.41.0

--
Best regards,
Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 17 Jan 19:01 +0100
[PATCH 2/2] gnu: Add emacs-devicetree-ts-mode.
(address . 68542@debbugs.gnu.org)
87wms7j0ur.fsf@disroot.org
* gnu/packages/emacs-xyz.scm (emacs-devicetree-ts-mode): New variable.
Update copyright.
---
gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d99fb30ff..1ffbd3ed5d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -90,7 +90,7 @@
;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
-;;; Copyright © 2021, 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2021, 2022, 2024 Aleksandr Vityazev <avityazev@disroot>
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -26231,6 +26231,29 @@ (define-public emacs-dts-mode
device tree files.")
(license license:gpl3+)))
+(define-public emacs-devicetree-ts-mode
+ (package
+ (name "emacs-devicetree-ts-mode")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~akagi/devicetree-ts-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1aif25hqs9i1aax331s4p8b59kxrq584ynfnh640p43jzmqf5p3d"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list tree-sitter-devicetree))
+ (home-page "https://sr.ht/~akagi/devicetree-ts-mode")
+ (synopsis "Tree-sitter major mode for editing DTS files")
+ (description "This package provides tree-sitter major mode
+for editing Devicetree files.")
+ (license license:gpl3+)))
+
(define-public emacs-daemons
(package
(name "emacs-daemons")

base-commit: b3e0a973bca6fe5de7356f3d70c4b7d468b0a759
prerequisite-patch-id: e1db0107f090297757e8a5b96f5d5b9687151eda
--
2.41.0

--
Best regards,
Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 4 Feb 12:09 +0100
Re: [bug#68542] [PATCH 0/2] Add emacs-devicetree-ts-mode
(address . 68542@debbugs.gnu.org)
874jeo8oze.fsf@disroot.org
Hello,

just a gentle ping -- could anyone review these patches?

--
Best regards,
Aleksandr Vityazev
N
N
Nicolas Goaziou wrote on 6 May 14:33 +0200
(name . Aleksandr Vityazev via Guix-patches via)(address . guix-patches@gnu.org)
87seyvxgpq.fsf@nicolasgoaziou.fr
Hello,

Aleksandr Vityazev via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> just a gentle ping -- could anyone review these patches?

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68542@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68542
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch