[PATCH] gnu: Add r-caic4.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 1 years ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
0169fffe3638560fe0172cbe1a12d75f15eb1248.1705507648.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-caic4): New variable.

Change-Id: Ifdfb6e69c7d1801b347ce16b4ee48a4950963fe4
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 95bd62b5a7..2e99403ca1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -287,6 +287,33 @@ (define-public r-cachem
automatically pruning objects to maintain the constraints.")
(license license:expat)))
+(define-public r-caic4
+ (package
+ (name "r-caic4")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cAIC4" version))
+ (sha256
+ (base32 "1qg73g0g029wkzpmp0fgvyfz8p1k3x38yqx0404cpb3dxj4n4hcg"))))
+ (properties `((upstream-name . "cAIC4")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-lme4
+ r-matrix
+ r-mgcv
+ r-mvtnorm
+ r-nlme
+ r-rlrsim))
+ (home-page "https://cran.r-project.org/package=cAIC4")
+ (synopsis "Conditional AIC for 'lme4' and 'nlme'")
+ (description
+ "This package estimates conditional Akaike information in mixed-effect models.
+These models are fitted using (g)lmer() from lme4', lme() from nlme, and
+gamm() from mgcv'. The provided functions facilitate thecomputation of
+the conditional Akaike information for model evaluation.")
+ (license license:gpl2+)))
+
(define-public r-castor
(package
(name "r-castor")

base-commit: b3e0a973bca6fe5de7356f3d70c4b7d468b0a759
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . 68534-done@debbugs.gnu.org)
87le8n3onk.fsf@elephly.net
Thanks, applied with commit 7bbb329060f56ea4a102d2d7d0900fa0daf20265
after a few changes to the description.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68534@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68534
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help