(address . guix-patches@gnu.org)(name . TakeV)(address . takev@disroot.org)
* gnu/packages/music.scm (cmusfm): New variable.
Change-Id: Ib27ed6c065ba4eaae146a587f13105798118db9b
---
gnu/packages/music.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 77e952d383..4c5db33af9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -739,6 +739,31 @@ (define-public cmus
many input formats and provides a customisable Vi-style user interface.")
(license license:gpl2+)))
+(define-public cmusfm
+ (package
+ (name "cmusfm")
+ (version "v0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arkq/cmusfm.git")
+ (commit "v0.5.0")))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "06q3m57ss60hyy9042vrjj1hb8whfq0dbz1vhc5w7i34kbjpq3h8"))))
+ (native-inputs
+ (list pkg-config
+ autoconf
+ automake))
+ (inputs
+ (list cmus curl libnotify))
+ (build-system gnu-build-system)
+ (arguments (list #:configure-flags #~(list "--enable-libnotify")))
+ (home-page "https://github.com/Arkq/cmusfm")
+ (synopsis "Last.fm standalone scrobbler for the cmus music player")
+ (description "Last.fm standalone scrobbler for the cmus music player.")
+ (license license:gpl3+)))
+
(define-public denemo
(package
(name "denemo")
base-commit: 171ac4fa4f5e5dd2f2e110487de5d41b5b79a564
--
2.41.0