[PATCH] gnu: Add cmusfm.

  • Open
  • quality assurance status badge
Details
One participant
  • TakeV
Owner
unassigned
Submitted by
TakeV
Severity
normal
T
(address . guix-patches@gnu.org)(name . TakeV)(address . takev@disroot.org)
9882e887c0e29e61eef082d2ab1c0274b6476afe.1705455934.git.takev@disroot.org
* gnu/packages/music.scm (cmusfm): New variable.

Change-Id: Ib27ed6c065ba4eaae146a587f13105798118db9b
---
gnu/packages/music.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 77e952d383..4c5db33af9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -739,6 +739,31 @@ (define-public cmus
many input formats and provides a customisable Vi-style user interface.")
(license license:gpl2+)))
+(define-public cmusfm
+ (package
+ (name "cmusfm")
+ (version "v0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arkq/cmusfm.git")
+ (commit "v0.5.0")))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "06q3m57ss60hyy9042vrjj1hb8whfq0dbz1vhc5w7i34kbjpq3h8"))))
+ (native-inputs
+ (list pkg-config
+ autoconf
+ automake))
+ (inputs
+ (list cmus curl libnotify))
+ (build-system gnu-build-system)
+ (arguments (list #:configure-flags #~(list "--enable-libnotify")))
+ (home-page "https://github.com/Arkq/cmusfm")
+ (synopsis "Last.fm standalone scrobbler for the cmus music player")
+ (description "Last.fm standalone scrobbler for the cmus music player.")
+ (license license:gpl3+)))
+
(define-public denemo
(package
(name "denemo")

base-commit: 171ac4fa4f5e5dd2f2e110487de5d41b5b79a564
--
2.41.0
T
[PATCH vREVISION] gnu: Add cmusfm.
(address . 68522@debbugs.gnu.org)(name . TakeV)(address . takev@disroot.org)
e33c97b49b1e07430add49b1208408252c6d411c.1705505189.git.takev@disroot.org
Accidentally added cmus as an input.

* gnu/packages/music.scm (cmusfm): New variable.

Change-Id: Ib27ed6c065ba4eaae146a587f13105798118db9b
---
gnu/packages/music.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 77e952d383..7c69bce1a4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -739,6 +739,32 @@ (define-public cmus
many input formats and provides a customisable Vi-style user interface.")
(license license:gpl2+)))
+(define-public cmusfm
+ (package
+ (name "cmusfm")
+ (version "v0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arkq/cmusfm.git")
+ (commit "v0.5.0")))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "06q3m57ss60hyy9042vrjj1hb8whfq0dbz1vhc5w7i34kbjpq3h8"))))
+ (native-inputs
+ (list pkg-config
+ autoconf
+ automake))
+ (inputs
+ (list curl
+ libnotify))
+ (build-system gnu-build-system)
+ (arguments (list #:configure-flags #~(list "--enable-libnotify")))
+ (home-page "https://github.com/Arkq/cmusfm")
+ (synopsis "Last.fm standalone scrobbler for the cmus music player")
+ (description "Last.fm standalone scrobbler for the cmus music player.")
+ (license license:gpl3+)))
+
(define-public denemo
(package
(name "denemo")

base-commit: 171ac4fa4f5e5dd2f2e110487de5d41b5b79a564
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68522@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68522
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch