[PATCH] guix: chicken-build-system: fixes to make it actually work

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)
2d16444a-92b5-3474-3ab3-2ba4d2851766@lyrion.ch
---
guix/build-system/chicken.scm | 50 ++++++++++++++++++++---------
guix/build/chicken-build-system.scm | 17 ++++------
2 files changed, 40 insertions(+), 27 deletions(-)

Toggle diff (123 lines)
diff --git a/guix/build-system/chicken.scm b/guix/build-system/chicken.scm
index 9f518e66e6..17c3b7b144 100644
--- a/guix/build-system/chicken.scm
+++ b/guix/build-system/chicken.scm
@@ -45,8 +45,8 @@ (define %chicken-build-system-modules
,@%gnu-build-system-modules))
(define (default-chicken)
+ "Return the default Chicken package."
;; Lazily resolve the binding to avoid a circular dependency.
- ;; TODO is this actually needed in every build system?
(let ((chicken (resolve-interface '(gnu packages chicken))))
(module-ref chicken 'chicken)))
@@ -77,18 +77,32 @@ (define private-keywords
,@native-inputs))
(outputs outputs)
(build chicken-build)
- (arguments (strip-keyword-arguments private-keywords arguments)))))
+ (arguments
+ (substitute-keyword-arguments
+ (strip-keyword-arguments private-keywords arguments)
+ ((#:extra-directories extra-directories)
+ `(list ,@(append-map
+ (lambda (name)
+ (match (assoc name inputs)
+ ((_ pkg)
+ (match (package-transitive-propagated-inputs pkg)
+ (((propagated-names . _) ...)
+ (cons name propagated-names))))))
+ extra-directories))))))))
(define* (chicken-build name inputs
#:key
source
(phases '%standard-phases)
- (outputs '("out"))
+ (outputs '("out" "static"))
(search-paths '())
(egg-name "")
(unpack-path "")
(build-flags ''())
+ (configure-flags ''())
+ (extra-directories ''())
(tests? #t)
+ (parallel-build? #f)
(system (%current-system))
(guile #f)
(imported-modules %chicken-build-system-modules)
@@ -99,19 +113,23 @@ (define builder
(with-imported-modules imported-modules
#~(begin
(use-modules #$@(sexp->gexp modules))
- (chicken-build #:name #$name
- #:source #+source
- #:system #$system
- #:phases #$phases
- #:outputs #$(outputs->gexp outputs)
- #:search-paths '#$(sexp->gexp
- (map search-path-specification->sexp
- search-paths))
- #:egg-name #$egg-name
- #:unpack-path #$unpack-path
- #:build-flags #$build-flags
- #:tests? #$tests?
- #:inputs #$(input-tuples->gexp inputs)))))
+ #$(with-build-variables inputs-outputs
+ #~(chicken-build #:name #$name
+ #:source #+source
+ #:system #$system
+ #:phases #$phases
+ #:configure-flags #$configure-flags
+ #:extra-directories #$extra-directories
+ #:parallel-build? #$parallel-build?
+ #:outputs #$(outputs->gexp outputs)
+ #:search-paths '#$(sexp->gexp
+ (map search-path-specification->sexp
+ search-paths))
+ #:egg-name #$egg-name
+ #:unpack-path #$unpack-path
+ #:build-flags #$build-flags
+ #:tests? #$tests?
+ #:inputs #$(input-tuples->gexp inputs))))))
(mlet %store-monad ((guile (package->derivation (or guile (default-guile))
system #:graft? #f)))
diff --git a/guix/build/chicken-build-system.scm b/guix/build/chicken-build-system.scm
index 8f9f59cc25..6a4f0c43eb 100644
--- a/guix/build/chicken-build-system.scm
+++ b/guix/build/chicken-build-system.scm
@@ -42,13 +42,12 @@ (define (chicken-package? name)
(define* (setup-chicken-environment #:key inputs outputs #:allow-other-keys)
(setenv "CHICKEN_INSTALL_REPOSITORY"
- (string-concatenate
- ;; see TODO item about binary version above
- (append (list (assoc-ref outputs "out") "/var/lib/chicken/11/")
- (let ((oldenv (getenv "CHICKEN_INSTALL_REPOSITORY")))
- (if oldenv
- (list ":" oldenv)
- '())))))
+ (string-append (assoc-ref outputs "out") "/var/lib/chicken/11/"))
+ (setenv "CHICKEN_INSTALL_PREFIX"
+ (string-append (assoc-ref outputs "out") "/bin/"))
+ (setenv "CHICKEN_REPOSITORY_PATH"
+ (string-append (getenv "CHICKEN_REPOSITORY_PATH")
+ ":" (getenv "CHICKEN_INSTALL_REPOSITORY")))
(setenv "CHICKEN_EGG_CACHE" (getcwd))
#t)
@@ -104,10 +103,6 @@ (define* (check #:key egg-name tests? #:allow-other-keys)
;; there is no "-test-only" option, but we've already run install
;; so this just runs tests.
;; i think it's a fair assumption that phases won't be reordered.
- (setenv "CHICKEN_REPOSITORY_PATH"
- (string-append (getenv "CHICKEN_INSTALL_REPOSITORY")
- ":"
- (getenv "CHICKEN_REPOSITORY_PATH")))
(when tests?
(invoke "chicken-install" "-cached" "-test" "-no-install" egg-name)))
--
2.43.0
Daniel Ziltener wrote 1 years ago
(address . 68517@debbugs.gnu.org)
87h6jbdk6k.fsf@lyrion.ch
close 68517
thanks
Maxim Cournoyer wrote 1 years ago
control message for bug #68517
(address . control@debbugs.gnu.org)
87bk9aydg7.fsf@gmail.com
close 68517
quit
Maxim Cournoyer wrote 1 years ago
Re: [bug#68517] [PATCH] guix: chicken-build-system: fixes to make it actually work
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 68517-done@debbugs.gnu.org)
877cjyydf7.fsf@gmail.com
Hi,

Daniel Ziltener <dziltener@lyrion.ch> writes:

Toggle quote (3 lines)
> close 68517
> thanks

You forgot to include the 'GNU Debbugs <control@debbugs.gnu.org>'
control server in CC :-).

--
Thanks,
Maxim
Closed
Daniel Ziltener wrote 1 years ago
[PATCH] guix: chicken-build-system: fixes to make it actually work
(address . 68517@debbugs.gnu.org)(name . GNU Debbugs)(address . control@debbugs.gnu.org)
869284fe-ed98-cb96-9e1a-263b28748c81@lyrion.ch
close 67966
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68517@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68517
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help