[PATCH] .dir-locals.el: Add geiser-insert-actual-lambda.

  • Open
  • quality assurance status badge
Details
One participant
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 16 Jan 16:42 +0100
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
23eca2f239a6a3532829d97184f0b256940cadfb.1705419728.git.~@wolfsden.cz
Guix project seems to prefer using lambda over λ. Express that preference for
Geiser users by setting the geiser-insert-actual-lambda variable to nil. In
the 0.31 version it will affect how geiser-insert-lambda works, making it
insert lambda string (instead of the current λ.

* .dir-locals.el (nil): Add geiser-insert-actual-lambda set to nil.

Change-Id: Iccbd4a8df194d60b96b33879c342cfeb224bcfbb
---
.dir-locals.el | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index d18e6ba760..2cea9d4dd7 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -34,7 +34,8 @@
;; Geiser
;; This allows automatically setting the `geiser-guile-load-path'
;; variable when using various Guix checkouts (e.g., via git worktrees).
- (geiser-repl-per-project-p . t)))
+ (geiser-repl-per-project-p . t)
+ (geiser-insert-actual-lambda . nil)))
(c-mode . ((c-file-style . "gnu")))
(scheme-mode

base-commit: 21f5d20d68e0359f8111ccb936905649c70db9c1
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 68511@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68511
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch