[PATCH 0/2] gnu: ausweisapp: Update to 2.0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 16 Jan 11:24 +0100
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cover.1705400531.git.sarg@sarg.org.ru
Hello guix, sending a patch series to update ausweisapp to a newer version.

Sergey Trofimov (2):
gnu: qtscxml: Update to 6.5.2.
gnu: ausweisapp: Update to 2.0.2.

gnu/packages/qt.scm | 30 ++++++++++++++++++++--
gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
2 files changed, 50 insertions(+), 25 deletions(-)


base-commit: 21f5d20d68e0359f8111ccb936905649c70db9c1
--
2.41.0
S
S
Sergey Trofimov wrote on 16 Jan 11:28 +0100
[PATCH 1/2] gnu: qtscxml: Update to 6.5.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
4e99bf1440047a056e1026df92bdacb782f11362.1705400531.git.sarg@sarg.org.ru
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
gnu/packages/qt.scm | 30 ++++++++++++++++++++++++++++--
1 file changed, 28 insertions(+), 2 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b89e7e738..25821584ee 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2316,7 +2316,7 @@ (define-public qtgamepad
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2344,6 +2344,32 @@ (define-public qtscxml
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments (list #:tests? #f)) ; TODO: Enable the tests
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4453,7 +4479,7 @@ (define-public python-pyside-2
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5
--
2.41.0
S
S
Sergey Trofimov wrote on 16 Jan 11:28 +0100
[PATCH 2/2] gnu: ausweisapp: Update to 2.0.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
d26f319f0ab58a0b23a1af9b105f9e36d4facb5a.1705400531.git.sarg@sarg.org.ru
* gnu/packages/security-token.scm (ausweisapp): Update to 2.0.2.
(ausweisapp2): Rename to ausweisapp.
---
gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
1 file changed, 22 insertions(+), 23 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..34ae6ea215 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -950,43 +950,42 @@ (define-public nitrocli
devices.")
(license license:gpl3+)))
-(define-public ausweisapp2
+(define-public ausweisapp
(package
- (name "ausweisapp2")
- (version "1.22.2")
+ (name "ausweisapp")
+ (version "2.0.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
- "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+ "/download/" version "/AusweisApp-" version ".tar.gz"))
(sha256
(base32
- "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+ "1y0bnp8ry9x7nmf6akx9gfpx91p3x15jh72yrzpfpll6zmppcx3b"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(inputs
- (list qtbase-5
- qtsvg-5
- qtdeclarative-5
- qtwebsockets-5
+ (list qtbase
+ qtsvg
+ qtscxml
+ qtdeclarative
+ qtshadertools
+ qtwebsockets
qtgraphicaleffects
- qtquickcontrols2-5
pcsc-lite
openssl))
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
+ `(#:qtbase ,qtbase
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-qt
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
- (home-page "https://github.com/Governikus/AusweisApp2")
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))))))))
+ (home-page "https://github.com/Governikus/AusweisApp")
(synopsis
"Authentication program for German ID cards and residence permits")
(description
--
2.41.0
M
M
Maxim Cournoyer wrote on 17 Jan 15:02 +0100
Re: [bug#68500] [PATCH 1/2] gnu: qtscxml: Update to 6.5.2.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87cyu0oy73.fsf@gmail.com
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (40 lines)
> * gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
> (qtscxml-5): Add qt5 variant.
> (python-pyside-2)[inputs]: Use qtscxml-5.
> ---
> gnu/packages/qt.scm | 30 ++++++++++++++++++++++++++++--
> 1 file changed, 28 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 2b89e7e738..25821584ee 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -2316,7 +2316,7 @@ (define-public qtgamepad
> primary target audience are embedded devices with fullscreen user interfaces,
> and mobile applications targeting TV-like form factors.")))
>
> -(define-public qtscxml
> +(define-public qtscxml-5
> (package
> (inherit qtsvg-5)
> (name "qtscxml")
> @@ -2344,6 +2344,32 @@ (define-public qtscxml
> generating a C++ file that has a class implementing the state machine. It
> also contains functionality to support data models and executable content.")))
>
> +(define-public qtscxml
> + (package
> + (name "qtscxml")
> + (version "6.5.2")
> + (source (origin
> + (method url-fetch)
> + (uri (qt-url name version))
> + (sha256
> + (base32
> + "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
> + (modules '((guix build utils)))
> + (snippet
> + '(begin
> + (delete-file-recursively "tests/3rdparty")))))
> + (arguments (list #:tests? #f)) ; TODO: Enable the tests

Please make the effort to enable the test suite *now*, else it may never
happen :-). There's a lot of examples around that should provide some
help.

Could you please send a v2, attempting to enable the test suite?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 17 Jan 15:02 +0100
control message for bug #68500
(address . control@debbugs.gnu.org)
87zfx4njm7.fsf@gmail.com
tags 68500 + moreinfo
quit
S
S
Sergey Trofimov wrote on 17 Jan 21:36 +0100
[PATCH v1 0/2] gnu: ausweisapp: Update to 2.0.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cover.1705523575.git.sarg@sarg.org.ru
I've enabled tests for qtscxml. At first I've tried adding `make-flags`
parameter to `cmake-build-system`, but it seems to be causing a mass rebuild
of packages. Another option was to `(invoke "ctest" ...)`, but it becomes more
verbose and requires to support `tests?` and `parallel-tests` parameters.

Sergey Trofimov (2):
gnu: qtscxml: Update to 6.5.2.
gnu: ausweisapp: Update to 2.0.2.

gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++--
gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
2 files changed, 63 insertions(+), 25 deletions(-)


base-commit: b3e0a973bca6fe5de7356f3d70c4b7d468b0a759
--
2.41.0
S
S
Sergey Trofimov wrote on 17 Jan 21:36 +0100
[PATCH v1 1/2] gnu: qtscxml: Update to 6.5.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
9b0b983a7d860ae24e0d3bf9eff0e62a301573a1.1705523575.git.sarg@sarg.org.ru
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++++++++++++++--
1 file changed, 41 insertions(+), 2 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b89e7e738..febffff90e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2316,7 +2316,7 @@ (define-public qtgamepad
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2344,6 +2344,45 @@ (define-public qtscxml
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "ARGS" "-E tst_scion")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH"))))))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4453,7 +4492,7 @@ (define-public python-pyside-2
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5
--
2.41.0
S
S
Sergey Trofimov wrote on 17 Jan 21:36 +0100
[PATCH v1 2/2] gnu: ausweisapp: Update to 2.0.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
43f4cf2137ecab47a33b001cb714b9539e6f25ae.1705523575.git.sarg@sarg.org.ru
* gnu/packages/security-token.scm (ausweisapp): Update to 2.0.2.
(ausweisapp2): Rename to ausweisapp.
---
gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
1 file changed, 22 insertions(+), 23 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..34ae6ea215 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -950,43 +950,42 @@ (define-public nitrocli
devices.")
(license license:gpl3+)))
-(define-public ausweisapp2
+(define-public ausweisapp
(package
- (name "ausweisapp2")
- (version "1.22.2")
+ (name "ausweisapp")
+ (version "2.0.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
- "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+ "/download/" version "/AusweisApp-" version ".tar.gz"))
(sha256
(base32
- "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+ "1y0bnp8ry9x7nmf6akx9gfpx91p3x15jh72yrzpfpll6zmppcx3b"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(inputs
- (list qtbase-5
- qtsvg-5
- qtdeclarative-5
- qtwebsockets-5
+ (list qtbase
+ qtsvg
+ qtscxml
+ qtdeclarative
+ qtshadertools
+ qtwebsockets
qtgraphicaleffects
- qtquickcontrols2-5
pcsc-lite
openssl))
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
+ `(#:qtbase ,qtbase
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-qt
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
- (home-page "https://github.com/Governikus/AusweisApp2")
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))))))))
+ (home-page "https://github.com/Governikus/AusweisApp")
(synopsis
"Authentication program for German ID cards and residence permits")
(description
--
2.41.0
S
S
Sergey Trofimov wrote on 4 Mar 19:03 +0100
[PATCH v2 1/2] gnu: qtscxml: Update to 6.5.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
5bfa707ec1a839e9329c1320a0f152eee8abff30.1709575388.git.sarg@sarg.org.ru
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++++++++++++++--
1 file changed, 41 insertions(+), 2 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 761d12e31f..8a521be3c0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2349,7 +2349,7 @@ (define-public qtgamepad
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2377,6 +2377,45 @@ (define-public qtscxml
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "ARGS" "-E tst_scion")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH"))))))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4486,7 +4525,7 @@ (define-public python-pyside-2
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5

base-commit: 3da49b1472919a62df1fe399638f23a246aa325d
prerequisite-patch-id: 4b5032a22b70bff803b7bbd0693b00984f53a25e
prerequisite-patch-id: 68eb78a4650b2e0880ad3735fbd1f0296adc7de7
prerequisite-patch-id: bb61e272c86d80072ad9dc79c17ecde91127999b
prerequisite-patch-id: 7f3cf0da78d3a019888053ba63cd03c3abd6bf2e
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: aba438a3c32ef44149bbc749c1e0b89d00006b3e
prerequisite-patch-id: 51199b8d0dc0c9fd45bca2f8743d83565255ea80
--
2.41.0
S
S
Sergey Trofimov wrote on 4 Mar 19:03 +0100
[PATCH v2 2/2] gnu: ausweisapp: Update to 2.1.0.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
c3d7d864219f9cee667c2ebeff9d3363e7e23816.1709575388.git.sarg@sarg.org.ru
* gnu/packages/security-token.scm (ausweisapp): Update to 2.1.0.
(ausweisapp2): Rename to ausweisapp.
---
gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
1 file changed, 22 insertions(+), 23 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..3e46e318c3 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -950,43 +950,42 @@ (define-public nitrocli
devices.")
(license license:gpl3+)))
-(define-public ausweisapp2
+(define-public ausweisapp
(package
- (name "ausweisapp2")
- (version "1.22.2")
+ (name "ausweisapp")
+ (version "2.1.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
- "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+ "/download/" version "/AusweisApp-" version ".tar.gz"))
(sha256
(base32
- "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+ "1jzxfybjrc3byw42bqjvn1nsn7vbgcl8y94sywjy6vaj3a58hy36"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(inputs
- (list qtbase-5
- qtsvg-5
- qtdeclarative-5
- qtwebsockets-5
+ (list qtbase
+ qtsvg
+ qtscxml
+ qtdeclarative
+ qtshadertools
+ qtwebsockets
qtgraphicaleffects
- qtquickcontrols2-5
pcsc-lite
openssl))
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
+ `(#:qtbase ,qtbase
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-qt
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
- (home-page "https://github.com/Governikus/AusweisApp2")
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))))))))
+ (home-page "https://github.com/Governikus/AusweisApp")
(synopsis
"Authentication program for German ID cards and residence permits")
(description
--
2.41.0
M
M
Maxim Cournoyer wrote on 10 Mar 02:21 +0100
Re: [bug#68500] [PATCH v2 1/2] gnu: qtscxml: Update to 6.5.2.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87le6qdgph.fsf@gmail.com
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (4 lines)
> * gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
> (qtscxml-5): Add qt5 variant.
> (python-pyside-2)[inputs]: Use qtscxml-5.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 10 Mar 02:28 +0100
Re: [bug#68500] [PATCH v2 2/2] gnu: ausweisapp: Update to 2.1.0.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 68500@debbugs.gnu.org)
87h6hedgeq.fsf@gmail.com
Hi Sergey,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (3 lines)
> * gnu/packages/security-token.scm (ausweisapp): Update to 2.1.0.
> (ausweisapp2): Rename to ausweisapp.

The changelog commit message should mention the change to inputs and
arguments, e.g.:

[native-inputs]: Replace qttools-5 with qttools.
...

Toggle quote (75 lines)
> ---
> gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
> 1 file changed, 22 insertions(+), 23 deletions(-)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index a1fc058db8..3e46e318c3 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -950,43 +950,42 @@ (define-public nitrocli
> devices.")
> (license license:gpl3+)))
>
> -(define-public ausweisapp2
> +(define-public ausweisapp
> (package
> - (name "ausweisapp2")
> - (version "1.22.2")
> + (name "ausweisapp")
> + (version "2.1.0")
> (source (origin
> (method url-fetch)
> - (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
> - "/download/" version "/AusweisApp2-" version ".tar.gz"))
> + (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
> + "/download/" version "/AusweisApp-" version ".tar.gz"))
> (sha256
> (base32
> - "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
> + "1jzxfybjrc3byw42bqjvn1nsn7vbgcl8y94sywjy6vaj3a58hy36"))))
>
> - (build-system cmake-build-system)
> + (build-system qt-build-system)
> (native-inputs
> - (list pkg-config qttools-5))
> + (list pkg-config qttools))
> (inputs
> - (list qtbase-5
> - qtsvg-5
> - qtdeclarative-5
> - qtwebsockets-5
> + (list qtbase
> + qtsvg
> + qtscxml
> + qtdeclarative
> + qtshadertools
> + qtwebsockets
> qtgraphicaleffects
> - qtquickcontrols2-5
> pcsc-lite
> openssl))
> (arguments
> - `(#:modules ((guix build cmake-build-system)
> - (guix build qt-utils)
> - (guix build utils))
> - #:imported-modules (,@%cmake-build-system-modules
> - (guix build qt-utils))
> + `(#:qtbase ,qtbase
> #:phases
> (modify-phases %standard-phases
> - (add-after 'install 'wrap-qt
> - (lambda* (#:key inputs outputs #:allow-other-keys)
> - (let ((out (assoc-ref outputs "out")))
> - (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
> - (home-page "https://github.com/Governikus/AusweisApp2")
> + (replace 'check
> + (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
> + (when tests? (invoke "ctest" "--output-on-failure" "-j"
> + (if parallel-tests?
> + (number->string (parallel-job-count))
> + "1"))))))))
> + (home-page "https://github.com/Governikus/AusweisApp")
> (synopsis
> "Authentication program for German ID cards and residence permits")
> (description

The rest LGTM, but it'd be best to use define-precated/public for
current users ausweisapp2; I think something like:

Toggle snippet (3 lines)
(define-deprecated/public "ausweisapp2" ausweisapp)

Could you please send a v3 with the above changes?

--
Thanks,
Maxim
S
S
Sergey Trofimov wrote on 10 Mar 08:26 +0100
[PATCH v3 1/2] gnu: qtscxml: Update to 6.5.2.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
1d2ee6c41a236ebd33dc353afafac21778a10efb.1710055531.git.sarg@sarg.org.ru
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++++++++++++++--
1 file changed, 41 insertions(+), 2 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9df49d7fb3..5866d33394 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2360,7 +2360,7 @@ (define-public qtgamepad
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2388,6 +2388,45 @@ (define-public qtscxml
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "ARGS" "-E tst_scion")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH"))))))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4497,7 +4536,7 @@ (define-public python-pyside-2
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5

base-commit: 7758e63f7a89f53fbb7c7a265ae472af0a8dfab0
prerequisite-patch-id: 4b5032a22b70bff803b7bbd0693b00984f53a25e
prerequisite-patch-id: 68eb78a4650b2e0880ad3735fbd1f0296adc7de7
prerequisite-patch-id: bb61e272c86d80072ad9dc79c17ecde91127999b
prerequisite-patch-id: 7f3cf0da78d3a019888053ba63cd03c3abd6bf2e
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: aba438a3c32ef44149bbc749c1e0b89d00006b3e
prerequisite-patch-id: 51199b8d0dc0c9fd45bca2f8743d83565255ea80
--
2.41.0
S
S
Sergey Trofimov wrote on 10 Mar 08:26 +0100
[PATCH v3 2/2] gnu: ausweisapp: Update to 2.1.0.
(address . 68500@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
aa97abf359747f1e370dc838465f42e4c763cc98.1710055531.git.sarg@sarg.org.ru
* gnu/packages/security-token.scm (ausweisapp2): Deprecate and rename to...
(ausweisapp): ... this. Update to 2.1.0.
[build-system]: Switch to qt-build-system.
[inputs]: Update dependencies to Qt6.
[native-inputs]: Replace qttools-5 with qttools.
---
gnu/packages/security-token.scm | 49 +++++++++++++++++----------------
1 file changed, 26 insertions(+), 23 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..8fe9039f20 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -41,6 +41,7 @@ (define-module (gnu packages security-token)
#:use-module (gnu packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix utils)
@@ -950,43 +951,42 @@ (define-public nitrocli
devices.")
(license license:gpl3+)))
-(define-public ausweisapp2
+(define-public ausweisapp
(package
- (name "ausweisapp2")
- (version "1.22.2")
+ (name "ausweisapp")
+ (version "2.1.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
- "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+ "/download/" version "/AusweisApp-" version ".tar.gz"))
(sha256
(base32
- "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+ "1jzxfybjrc3byw42bqjvn1nsn7vbgcl8y94sywjy6vaj3a58hy36"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(inputs
- (list qtbase-5
- qtsvg-5
- qtdeclarative-5
- qtwebsockets-5
+ (list qtbase
+ qtsvg
+ qtscxml
+ qtdeclarative
+ qtshadertools
+ qtwebsockets
qtgraphicaleffects
- qtquickcontrols2-5
pcsc-lite
openssl))
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
+ `(#:qtbase ,qtbase
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-qt
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
- (home-page "https://github.com/Governikus/AusweisApp2")
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests? (invoke "ctest" "--output-on-failure" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))))))))
+ (home-page "https://github.com/Governikus/AusweisApp")
(synopsis
"Authentication program for German ID cards and residence permits")
(description
@@ -996,6 +996,9 @@ (define-public ausweisapp2
phone is required.")
(license license:eupl1.2)))
+(define-deprecated/public ausweisapp2 ausweisapp
+ (deprecated-package "ausweisapp2" ausweisapp))
+
(define-public libfido2
(package
(name "libfido2")
--
2.41.0
M
M
Maxim Cournoyer wrote on 19 Mar 08:45 +0100
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 68500-done@debbugs.gnu.org)
87zfuumzpy.fsf@gmail.com
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (6 lines)
> * gnu/packages/security-token.scm (ausweisapp2): Deprecate and rename to...
> (ausweisapp): ... this. Update to 2.1.0.
> [build-system]: Switch to qt-build-system.
> [inputs]: Update dependencies to Qt6.
> [native-inputs]: Replace qttools-5 with qttools.

I pushed this commit and the previous one, at last.

Thank you!

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68500@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68500
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch