[PATCH 0/2] Update bcachefs-tools to 1.4.1 and restyle

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 1 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1705378667.git.a.r.draidi@redscript.org
Bcachefs is finally released! :D

Ahmad Draidi (2):
gnu: bcachefs-tools: Update to 1.4.1.
gnu: bcachefs-tools: Restyle format.

gnu/packages/file-systems.scm | 186 +++++++++++++++++-----------------
1 file changed, 93 insertions(+), 93 deletions(-)


base-commit: 162d6a2fdd6af13272967c77347a54934ecb45e6
--
2.41.0
Ahmad Draidi wrote 1 years ago
[PATCH 1/2] gnu: bcachefs-tools: Update to 1.4.1.
(address . 68495@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
0f7d0c5dd9fc6021d775cb31c8e5c54d569e4576.1705379539.git.a.r.draidi@redscript.org
* gnu/packages/file-systems.scm (bcachefs-tools): Update to 1.4.1.
[source]: Use version instead of commit.
[arguments]:<#:make-flags>: Add "PKGCONFIG_UDEVRULESDIR" to put udev rules
under "PREFIX" folder.
[inputs]: Add bash-minimal to fix lint.

Change-Id: I6818bc41260586664d408234323bdc9461e4b8e1
---
gnu/packages/file-systems.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 8cac1eae9c..b0bf09625c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -581,26 +581,25 @@ (define-public gphotofs
(license license:gpl2+)))
(define-public bcachefs-tools
- (let ((commit "1e358401ecdf1963e5799de19ab69111e82e5ebc")
- (revision "0"))
(package
(name "bcachefs-tools")
- (version (git-version "1.2" revision commit))
+ (version "1.4.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://evilpiepirate.org/git/bcachefs-tools.git")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0bflgqb3q9jikyyrv6hywv6m1fapzzn874hlhf86pn6abxrlf5fa"))))
+ (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
#~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
(string-append "PREFIX=" #$output)
"INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+ "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
(string-append "CC=" #$(cc-for-target))
(string-append "PKG_CONFIG=" #$(pkg-config-for-target))
;; ‘This will be less of an option in the future, as more
@@ -666,6 +665,7 @@ (define-public bcachefs-tools
`(,zstd "lib")
;; Only for mount.bcachefs.sh.
+ bash-minimal
coreutils-minimal
gawk
util-linux))
@@ -682,7 +682,7 @@ (define-public bcachefs-tools
In addition, bcachefs provides all the functionality of bcache, a block-layer
caching system, and lets you assign different roles to each device based on its
performance and other characteristics.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public bcachefs-tools/static
(package

base-commit: 162d6a2fdd6af13272967c77347a54934ecb45e6
--
2.41.0
Ahmad Draidi wrote 1 years ago
[PATCH 2/2] gnu: bcachefs-tools: Restyle format.
(address . 68495@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
47ec0f53c75d2db052eabb006025712d4ba862e6.1705379539.git.a.r.draidi@redscript.org
* gnu/packages/file-systems.scm (bcachefs-tools): Reindent all lines.

Change-Id: I6f3ae711daf2f5d66724f513fe5e8876147f5ccf
---
gnu/packages/file-systems.scm | 186 +++++++++++++++++-----------------
1 file changed, 93 insertions(+), 93 deletions(-)

Toggle diff (206 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b0bf09625c..87af8ac925 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -581,98 +581,98 @@ (define-public gphotofs
(license license:gpl2+)))
(define-public bcachefs-tools
- (package
- (name "bcachefs-tools")
- (version "1.4.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://evilpiepirate.org/git/bcachefs-tools.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
- (string-append "PREFIX=" #$output)
- "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
- "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
- (string-append "CC=" #$(cc-for-target))
- (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
- ;; ‘This will be less of an option in the future, as more
- ;; code gets rewritten in Rust.’
- "NO_RUST=better")
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (replace 'check
- ;; The test suite is moribund upstream (‘never been useful’),
- ;; but let's keep running it as a sanity check until then.
- (lambda* (#:key tests? make-flags #:allow-other-keys)
- (when tests?
- ;; We must manually build the test_helper first.
- (apply invoke "make" "tests" make-flags)
- (invoke (string-append
- #$(this-package-native-input "python-pytest")
- "/bin/pytest") "-k"
- ;; These fail (‘invalid argument’) on kernels
- ;; with a previous bcachefs version.
- (string-append "not test_format and "
- "not test_fsck and "
- "not test_list and "
- "not test_list_inodes and "
- "not test_list_dirent")))))
- (add-after 'install 'promote-mount.bcachefs.sh
- ;; The (optional) ‘mount.bcachefs’ requires rust:cargo.
- ;; This shell alternative does the job well enough for now.
- (lambda* (#:key inputs #:allow-other-keys)
- (define (whence file)
- (dirname (search-input-file inputs file)))
- (let ((mount (string-append #$output
- "/sbin/mount.bcachefs")))
- (delete-file mount) ; symlink to ‘bcachefs’
- (copy-file "mount.bcachefs.sh" mount)
- ;; WRAP-SCRIPT causes bogus ‘Insufficient arguments’ errors.
- (wrap-program mount
- `("PATH" ":" prefix
- ,(list (getcwd)
- (whence "bin/tail")
- (whence "bin/awk")
- (whence "bin/mount"))))))))))
- (native-inputs
- (cons* pkg-config
- ;; For generating documentation with rst2man.
- python
- python-docutils
- ;; For tests.
- python-pytest
- (if (member (%current-system) (package-supported-systems valgrind))
- (list valgrind)
- '())))
- (inputs
- (list eudev
- keyutils
- libaio
- libscrypt
- libsodium
- liburcu
- `(,util-linux "lib")
- lz4
- zlib
- `(,zstd "lib")
-
- ;; Only for mount.bcachefs.sh.
- bash-minimal
- coreutils-minimal
- gawk
- util-linux))
- (home-page "https://bcachefs.org/")
- (synopsis "Tools to create and manage bcachefs file systems")
- (description
- "The bcachefs-tools are command-line utilities for creating, checking,
+ (package
+ (name "bcachefs-tools")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://evilpiepirate.org/git/bcachefs-tools.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
+ (string-append "PREFIX=" #$output)
+ "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+ "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+ ;; ‘This will be less of an option in the future, as more
+ ;; code gets rewritten in Rust.’
+ "NO_RUST=better")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'check
+ ;; The test suite is moribund upstream (‘never been useful’),
+ ;; but let's keep running it as a sanity check until then.
+ (lambda* (#:key tests? make-flags #:allow-other-keys)
+ (when tests?
+ ;; We must manually build the test_helper first.
+ (apply invoke "make" "tests" make-flags)
+ (invoke (string-append
+ #$(this-package-native-input "python-pytest")
+ "/bin/pytest") "-k"
+ ;; These fail (‘invalid argument’) on kernels
+ ;; with a previous bcachefs version.
+ (string-append "not test_format and "
+ "not test_fsck and "
+ "not test_list and "
+ "not test_list_inodes and "
+ "not test_list_dirent")))))
+ (add-after 'install 'promote-mount.bcachefs.sh
+ ;; The (optional) ‘mount.bcachefs’ requires rust:cargo.
+ ;; This shell alternative does the job well enough for now.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (whence file)
+ (dirname (search-input-file inputs file)))
+ (let ((mount (string-append #$output
+ "/sbin/mount.bcachefs")))
+ (delete-file mount) ; symlink to ‘bcachefs’
+ (copy-file "mount.bcachefs.sh" mount)
+ ;; WRAP-SCRIPT causes bogus ‘Insufficient arguments’ errors.
+ (wrap-program mount
+ `("PATH" ":" prefix
+ ,(list (getcwd)
+ (whence "bin/tail")
+ (whence "bin/awk")
+ (whence "bin/mount"))))))))))
+ (native-inputs
+ (cons* pkg-config
+ ;; For generating documentation with rst2man.
+ python
+ python-docutils
+ ;; For tests.
+ python-pytest
+ (if (member (%current-system) (package-supported-systems valgrind))
+ (list valgrind)
+ '())))
+ (inputs
+ (list eudev
+ keyutils
+ libaio
+ libscrypt
+ libsodium
+ liburcu
+ `(,util-linux "lib")
+ lz4
+ zlib
+ `(,zstd "lib")
+
+ ;; Only for mount.bcachefs.sh.
+ bash-minimal
+ coreutils-minimal
+ gawk
+ util-linux))
+ (home-page "https://bcachefs.org/")
+ (synopsis "Tools to create and manage bcachefs file systems")
+ (description
+ "The bcachefs-tools are command-line utilities for creating, checking,
and otherwise managing bcachefs file systems.
Bcachefs is a @acronym{CoW, copy-on-write} file system supporting native
@@ -682,7 +682,7 @@ (define-public bcachefs-tools
In addition, bcachefs provides all the functionality of bcache, a block-layer
caching system, and lets you assign different roles to each device based on its
performance and other characteristics.")
- (license license:gpl2+)))
+ (license license:gpl2+)))
(define-public bcachefs-tools/static
(package
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 0/2] Update bcachefs-tools to 1.4.1 and restyle
(address . 68495-done@debbugs.gnu.org)
87y1bts2ig.fsf@gmail.com
Hi

Pushed as aabbcb0ef9..b186fa1306 to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXGpUcACgkQdtcnv/Ys
0rUtdw//ToMoZO494RDndSbKwc5v8bKeIaKCa3lvtf64dZUQWJKzHxSSmEBbfgIF
ESMb3PXzysIYRZTe2WrnLK0t3mgukMr4jVtLfdWU0L9G8dafsbtulTU8vDdUWPbz
iwCjIIxYxPRyz1jychHEsQnWmSAcQpyEFp5XFUKH9mpSj9fg4Rs6kIhM9UBmll6t
Re8MPaPouHNB7YnI3VsArkw6PXBn7X0louVybDtOwSub6rm/bnZfvtLNnjg1nERm
mmUayamH87v0DXWuvW37/6F+Pd0zdSKyxKIaZurajb+44zEW4V1g3NfSOY6mfuHB
S6iFqLTx2KxMaHxPtJ2wYDMUUGjHu8Lfn+bCPt3bn9peSlkGUu20lh9HtfjA4qUR
GEw4NgnzkB8xYj4S/u3xWsOIfQS4IQRgTfUsQVybCb1vU6/ARsx1lI/efX6WtjJk
g7JTRuJbYf5baxvAkHEssP9ehGJOHPlN3rJsjqbYe/DeoHJyitDkW2wpIOPdb//B
L/6YW6WbIoPBHfDZB5lFP/eHCtmCr9bgMos6BbIJZi5rlAQps79DL3oAx+jGuQwM
cztuUC+pcK6iZrg4m6PGIxT8B/d5LRt9Qw/9KZPl8W94dlBHgdOHlkygqsPDKlf5
6SOPzJJwhqVXhVMrIpABevnblzdFwMJu9whp9ij2ad5DOZpxnMw=
=0APn
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68495@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68495
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help