[PATCH] image: Consider grub-efi-removable-bootloader to be EFI bootloader.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
8591c1022344b09e865048d2c20fbb8ee3375654.1705355855.git.~@wolfsden.cz
Without this change, trying to create a system image with efi-raw type while
using grub-efi-removable-bootloader fails with fairly confusing message:

EFI bootloader required with GPT partitioning

* gnu/system/image.scm (system-disk-image): Consider
grub-efi-removable-bootloader to be EFI bootloader.

Change-Id: I5f5e1a94e825fd29d6880c5bafb330e16a5ac962
---
gnu/system/image.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 2cc1012893..5456b3a5a0 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -535,7 +535,8 @@ (define* (system-disk-image image
(when (and (gpt-image? image)
(not
- (memq (bootloader-name bootloader) '(grub-efi grub-efi32))))
+ (memq (bootloader-name bootloader)
+ '(grub-efi grub-efi32 grub-efi-removable-bootloader))))
(raise
(formatted-message
(G_ "EFI bootloader required with GPT partitioning"))))

base-commit: 31e736dac29e6f0ff8a2de3f28e210a68684ad21
--
2.41.0
Mathieu Othacehe wrote 1 years ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 68488-done@debbugs.gnu.org)
8734uwl20c.fsf@gnu.org
Hey,

Toggle quote (8 lines)
> Without this change, trying to create a system image with efi-raw type while
> using grub-efi-removable-bootloader fails with fairly confusing message:
>
> EFI bootloader required with GPT partitioning
>
> * gnu/system/image.scm (system-disk-image): Consider
> grub-efi-removable-bootloader to be EFI bootloader.

Looks good, applied. I agree the error message is misleading. Would you
like to give a try at rewording it? The goal is to prevent the failing
combination GPT + non-EFI bootloader.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68488@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68488
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help