Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
Without this change, trying to create a system image with efi-raw type while
using grub-efi-removable-bootloader fails with fairly confusing message:
EFI bootloader required with GPT partitioning
* gnu/system/image.scm (system-disk-image): Consider
grub-efi-removable-bootloader to be EFI bootloader.
Change-Id: I5f5e1a94e825fd29d6880c5bafb330e16a5ac962
---
gnu/system/image.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 2cc1012893..5456b3a5a0 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -535,7 +535,8 @@ (define* (system-disk-image image
(when (and (gpt-image? image)
(not
- (memq (bootloader-name bootloader) '(grub-efi grub-efi32))))
+ (memq (bootloader-name bootloader)
+ '(grub-efi grub-efi32 grub-efi-removable-bootloader))))
(raise
(formatted-message
(G_ "EFI bootloader required with GPT partitioning"))))
base-commit: 31e736dac29e6f0ff8a2de3f28e210a68684ad21
--
2.41.0