[PATCH] gnu: Add emacs-plan9-theme.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Suhail
  • Suhail Singh
Owner
unassigned
Submitted by
Suhail
Severity
normal
S
S
Suhail wrote on 15 Jan 00:59 +0100
(name . Guix-patches mailing list)(address . guix-patches@gnu.org)
1cad23a76cf90c95c1b0672f6d0d9abd6cc73a71.1705276359.git.suhail@bayesians.ca
* gnu/packages/emacs-xyz.scm (emacs-plan9-theme): New variable.

Change-Id: I6053ce66cfceca5a34d0dfd55691be9346f3a916
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a24f4a106..89b6f10de0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33771,6 +33771,27 @@ (define-public emacs-modus-themes
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+(define-public emacs-plan9-theme
+ (package
+ (name "emacs-plan9-theme")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john2x/plan9-theme.el")
+ (commit "c2da2fcb241e9800d931a1ff19ecd9fd84d30382")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjxbk9fljnjmg00vdqcyynzg591cgknyy2d92xsxsyg4d28dvwi"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/john2x/plan9-theme.el")
+ (synopsis "Light color theme for Emacs based on Plan 9")
+ (description
+ "@code{plan9} is an Emacs theme with light colors and a classic
+look which is inspired by the colors of Plan 9 from Bell Labs.")
+ (license license:gpl3+)))
+
(define-public emacs-punpun-theme
(let ((commit "7026684cd568cb691af3ced5de14c375fe6f5a1a")
(revision "0"))

base-commit: f2102cb5b9239be2ed2023b908b726af542e0124
--
2.43.0
S
S
Suhail wrote on 16 Feb 05:44 +0100
(name . bug#68462)(address . 68462@debbugs.gnu.org)
87r0hdnhl6.fsf@bayesians.ca
Bumping this. In case a potential reviewer sees this, this may well be
a relatively simple patch to review (new package with no dependencies).

--
Suhail
S
S
Suhail Singh wrote on 6 Mar 07:17 +0100
[PATCH v2] gnu: Add emacs-plan9-theme.
(address . 68462@debbugs.gnu.org)
773d704faaff87efdcc3e64fa21c9f681963f525.1709705676.git.suhail@bayesians.ca
* gnu/packages/emacs-xyz.scm (emacs-plan9-theme): New variable.

Change-Id: I6053ce66cfceca5a34d0dfd55691be9346f3a916
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e1d14ea4aa..4a06231a39 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34309,6 +34309,29 @@ (define-public emacs-modus-themes
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+(define-public emacs-plan9-theme
+ (let ((commit "c2da2fcb241e9800d931a1ff19ecd9fd84d30382")
+ (revision "0"))
+ (package
+ (name "emacs-plan9-theme")
+ (home-page "https://github.com/john2x/plan9-theme.el")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjxbk9fljnjmg00vdqcyynzg591cgknyy2d92xsxsyg4d28dvwi"))))
+ (build-system emacs-build-system)
+ (synopsis "Light color theme for Emacs based on Plan 9")
+ (description
+ "@code{plan9} is an Emacs theme with light colors and a classic
+look which is inspired by the colors of Plan 9 from Bell Labs.")
+ (license license:gpl3+))))
+
(define-public emacs-punpun-theme
(let ((commit "7026684cd568cb691af3ced5de14c375fe6f5a1a")
(revision "0"))

base-commit: f18d13b5f89c161c6ee88d15ecdaa8d973ee4503
--
2.44.0
L
L
Liliana Marie Prikler wrote on 17 Mar 13:31 +0100
64a75bc0d449a48b6bb4a81afd0115b32827e4d3.camel@gmail.com
Am Mittwoch, dem 06.03.2024 um 01:17 -0500 schrieb Suhail Singh:
Toggle quote (4 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-plan9-theme): New variable.
>
> Change-Id: I6053ce66cfceca5a34d0dfd55691be9346f3a916
Pushed. Cheers
Closed
?